Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

QoS - Bandwidth Shaping - Which to use ?

I have 50 or so remote offices connected using frame-relay with connection speeds ranging from 56k to 256k. I need to give telnet top priority followed by http & ftp without dropping http or ftp packets. More bandwidth is not an option.

Would priority Queuing work best, Custom Queuing or use MQC.

Very Confused !!

6 REPLIES
Bronze

Re: QoS - Bandwidth Shaping - Which to use ?

Custom queuing is probably the way to go as it will attempt to prioritise without totally starving the lower priority queues which can happen with Priority Queuing.

See the following URL for more information -

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fqos_c/fqcprt2/qcfcq.htm

New Member

Re: QoS - Bandwidth Shaping - Which to use ?

Hi

Class based WFQ is the best option here CBWFQ via MQC commands, here you can not only specify howmuch bandwidth each application gets but if you add shaping to the class you can limit the maximum bandwidth used per appliction.

New Member

Re: QoS - Bandwidth Shaping - Which to use ?

You could even take it one step further and use Low Latency Queueing (LLQ). Although this is typically used for VoIP applications, it can also be useful in this scenario. LLQ is CBWFQ with a priority queue. But, you can still set a bandwidth limit on that PQ, so you can put your telnet traffic in the PQ but still let other traffic through according to your bandwidth settings.

You should probably also be using traffic shaping, since you have a diverse set os speeds coming into a single, high-speed line. In this way you won't overload your low speed links with traffic coming from your high-speed side.

New Member

Re: QoS - Bandwidth Shaping - Which to use ?

I must be doing something wrong. After looking at the differnet ways for congestion management I'm trying Priority Queuing. Below is a config. from a remote site that I'm using for testing. I believe I have entered the correct commands but I'm stay seeing a delay in my telnet application (Reflection software connecting to a VAX system) when someone is downloading. Any suggestions would be grateful.

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname folcroft

!

logging rate-limit console 10 except errors

enable secret 5

enable password 7

!

memory-size iomem 25

ip subnet-zero

no ip finger

no ip domain-lookup

ip domain-name pilotair.com

ip name-server 172.16.2.1

ip name-server 172.16.2.2

ip name-server 172.16.2.3

no ip dhcp conflict logging

ip dhcp excluded-address 172.10.1.1 172.10.1.30

!

ip dhcp pool 0

network 172.10.0.0 255.255.0.0

default-router 172.10.1.1

dns-server 172.16.2.1 172.16.2.2 172.16.2.3

!

!

!

!

interface FastEthernet0

ip address 172.10.1.1 255.255.0.0

speed auto

priority-group 1

!

interface Serial0

description FMS:58495549 NUA:3832300992 TERMS:REL3/20145

bandwidth 128

no ip address

encapsulation frame-relay

priority-group 1

service-module t1 timeslots 1-2

frame-relay lmi-type ansi

!

interface Serial0.1 point-to-point

description PVC to Lima s0/0.40 DLCI 30

ip address 172.17.1.157 255.255.255.252

delay 20000

frame-relay interface-dlci 30

!

interface Serial0.2 point-to-point

description PVC to Lima s0/1.40 DLCI 30

ip address 172.18.1.157 255.255.255.252

frame-relay interface-dlci 31

!

router eigrp 1

network 172.10.0.0

network 172.16.0.0

network 172.17.0.0

network 172.18.0.0

auto-summary

no eigrp log-neighbor-changes

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.19.1.254

ip http server

!

priority-list 1 protocol ip high tcp telnet

priority-list 1 protocol ip low tcp ftp

priority-list 1 protocol ip low tcp pop3

priority-list 1 protocol ip low tcp smtp

snmp-server community RW

!

line con 0

password 7

login

transport input none

line aux 0

password 7

line vty 0 4

password 7

login

!

end

New Member

Re: QoS - Bandwidth Shaping - Which to use ?

This is a frame link , try the following:

nterface Serial0

no shut

ip address x.x.x.x y.y.y.y

encapsulation frame-relay

frame-relay traffic-shaping

frame-relay interface-dlci 16

class pq

!

map-class frame-relay pq

frame-relay priority-group 1

!

priority-list 1 protocol ip high list 100

priority-list 1 protocol ip medium list 101

priority-list 1 default normal

priority-list 1 protocol ip low list 102

access-list 100 permit udp any any

access-list 101 permit tcp any any eq 23

access-list 102 permit tcp any any eq 25

This is based on a physical interface but it will work for a sub-interface as well.

New Member

Re: QoS - Bandwidth Shaping - Which to use ?

Low Latency Queueing was primarily designed for UDP type rapid packet flows. Therefore, implementing LLQ for TCP connections somehow create burst size mistmatches/insufficiency. As a result you can observe packet drops, even of the higher priority traffic.

Solution of "j.vanrooyen" seems the most applicable.

If you decide to use CBWFQ, you should give the amount (or percentage) of the flows. Following is an example for the MQC part of the configuration:

*****

ip access-list extended telnet-acl

permit tcp any any eq telnet

ip access-list extended smtp-acl

permit tcp any any eq smtp

ip access-list extended ftp-acl

permit tcp any any eq ftp

!

class-map match-all telnet

match access-group name telnet-acl

class-map match-all portal

match access-group name smtp-acl

class-map match-all as400

match access-group name ftp-acl

class-map match-all notes

!

policy-map policy1

class telnet

set ip precedence 5

bandwidth percent 75

class smtp

bandwidth percent 10

class ftp

bandwidth percent 10

class class-default

set ip precedence 0

fair-queue

!

!

!

interface serial0

service-policy output policy1

*******

141
Views
0
Helpful
6
Replies