Cisco Support Community
Community Member

QoS : CBWFQ on GRE Tunnels at ATM/FR circuits with IPSEC using DSCP mark

i have a problem about the Class-Based WFQ shaping.

i am running ATM at the HQ site and the Frame-Relay Circuit at the remote sites. i am also applying IPSEC with GRE tunneling.

Inbound packets are marked with DSCP flags and outbound shaping is determined by checking the IP DSCP bit field.

i get the following results when trying to perform FTP from the remote site to the HQ simultaneously: - 32KBps (Assign=80%, actual=29%) - 77KBps (Assign=10%, actual=71%)

Can someone has experience about CB WFQ shaping on ATM subinterface with IPSEC GRE tunneling ?



Configuration Highlight

boot system flash disk0:c7200-ik9s-mz.122-8.T5.bin

access-list 2300 permit ip host any

access-list 2301 permit ip host any

access-list 111 permit gre host host

crypto map tunnel11 10 ipsec-isakmp

set peer <ip address>

set transform-set vpn_set

match address 111

qos pre-classify

policy-map inbound

class smartics_tra_1

set ip dscp 1

class other_tra_1

set ip dscp 4

policy-map outbound

class dscp1

bandwidth percent 80

class dscp4

bandwidth percent 10

class-map match-all dscp4

match ip dscp 4

class-map match-all other_tra_1

match access-group 2301

class-map match-all dscp1

match ip dscp 1

class-map match-all smartics_tra_1

match access-group 2300

interface Tunnel11

ip address <ip address>

tunnel source <ip address>

tunnel destination <ip address>

tunnel key < deleted >

crypto map tunnel11

qos pre-classify

interface ATM2/0.11 point-to-point

mtu 1500

bandwidth 1500

ip address <ip address>

pvc 22/32

vbr-nrt 1500 1500

max-reserved-bandwidth 90

tx-ring-limit 3

encapsulation aal5snap

ip addr inarp

service-policy output outbound

crypto map tunnel11



Re: QoS : CBWFQ on GRE Tunnels at ATM/FR circuits with IPSEC usi

Though I have tried QoS with IPSec, I have not configured it over ATM. Just wondering if the ATM traffic parameters have got something do with the rates that you are observing. You can check whethere any of these documents give you some clue :

CreatePlease to create content