Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QOS config for voip

Hi,

I have multiple spoke routers with FR to the service provider and on the hub side I am using IMA( atm multiplexing), and isdn as the backup for all these.

On both sides of the networks I have voice data coming on vlan 2, which is configured as sup-interface on the ethernet on the inside of every router. And data is coming on vlan 1 which is another sub interface on the ethernet.

Is there any QOS sample config, so that voice will have more priority over data in case of congestion in both direction.

Appreciate your info.

Thanks,

Habib Dashti

4 REPLIES
Silver

Re: QOS config for voip

Dashti,

Using the QOS MQC with Policy-maps and Class-maps can get you what you need for prioritization. Implementation of these and thier performance varies greatly on the platform you are using. Here is a link giving examples (see policy-map).

http://www.cisco.com/en/US/partner/products/sw/iosswrel/ps1835/products_command_reference_chapter09186a0080087f3c.html#1032964

Hope this helps you,

Don

New Member

Re: QOS config for voip

Hi Don,

Thanks, that gives me a good idea. but I am not able to apply the service-policy to the sub interfaces.

I am getting error that it cannot be applied to the sub interface

This is what I did

class-map match-all voice

match access-group 105

!

!

policy-map voip

class voice

priority 48

class class-default

fair-queue

stockton#

stockton#conf t

Enter configuration commands, one per line. End with CNTL/Z.

stockton(config)#int ser

stockton(config)#int serial 0/0.1

stockton(config-subif)#service-policy output voip

CBWFQ : Not supported on subinterfaces

stockton(config-subif)#

The procedure was greate but I am missing some thing here.

Appreciate your input.

Thanks,

Habib

Silver

Re: QOS config for voip

Habib,

As I said in previous email, this will depend on what type HW /router platform you have as to how this will be implemented. Service policies might only work on physical interfaces on your platform. Will putting this on your physical interface work for you? Since you are marking/policing on egress you could also try this on ingress to get the same results as well.

Hope this helps,

Don

New Member

Re: QOS config for voip

Hi Don,

I think I got it.

this is what I have on the FR side, I applied the service-policy on the map-class command for FR.

that is .

class-map match-all voice

match access-group 105

!

!

policy-map voip

class voice

priority 48

class class-default

fair-queue

!

interface Serial0/0

no ip address

encapsulation frame-relay

no fair-queue

frame-relay traffic-shaping

!

interface Serial0/0.1 point-to-point

ip address 192.168.200.14 255.255.255.252

frame-relay interface-dlci 16

class sacramento

!

map-class frame-relay sacramento

frame-relay cir 256000

frame-relay bc 384000

service-policy output voip

And on the ATM side I have same policy-map and class commands, and

interface ATM2/IMA0.1 point-to-point

description For Kankakee

ip address 192.168.200.5 255.255.255.252

pvc 10/40

abr 384 256

encapsulation aal5snap

service-policy output voip

!

Thanks a lot. If I am missing anything, appreciate your comments on it.

Thanks,

Habib

85
Views
0
Helpful
4
Replies
CreatePlease login to create content