cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
232
Views
0
Helpful
1
Replies

QOS for VoIP

jdepies
Level 1
Level 1

Hello,

I am new to QOS, and am looking for the easiest way to give the highest priority to all VoIP traffic between two routers (connected via serial T1).

I have read about DSCP / IP Precendence / COS / WFQ / ....

but I am not sure which comes into place when I am only worried about router to router communication. Eventually I will want to configure QOS on the LAN (through our catalyst switches), but for now I just want to get the WAN traffic dialed in.

I am assuming I will need two policies per router (one for inbound, and one for outbound), is it as simple as:

class-map voip

match ip protocol "range_of_ports"

Policy-map traffic-out

class voip

set ip dscp ef

priority 1544

Policy-map Traffic-in

class voip

set ip dscp ef

priority 1544

interface serial 0

service-policy output traffic-out

service-policy input traffic-in

Thanks for any help in this matter

Jeff

1 Reply 1

badamson
Level 1
Level 1

Jeff,

On a serial interface, you only need to put QOS on the outbound traffic. We have found something like the following to work well:

class-map match-all VoIP

match access-group 100

class-map match-all Video

match access-group 101

!

!

policy-map QOS-T1

class VoIP

priority 528

class Video

bandwidth 400

class class-default

fair-queue

!

access-list 100 permit ip any any dscp ef

access-list 100 permit ip any any precedence critical

access-list 101 permit ip any any dscp af41

access-list 101 permit ip any any precedence flash-override

Put the command "service-policy output QOS-T1" on the serial interfaces and set your bandwidth commands appropriately for the compression type you are using and the number of simultaneous calls. You may also want to look at classifying your call control traffic as well, although not as high as the actual voice traffic.

You'll want to use WRED on your ethernet side of the router, which is enabled through the use of the random-detect command.

Finally, pay close attention to the revision of IOS you are using. The config I showed is considered class-based weighted fair queuing (CBWFQ) and is only supported on newer code.

Hope this helps.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: