Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QoS in Medium Network with 2950 e 3550

Hello, I'm triyng to implement a QoS policy in a medium size network that has a lot of equipment.

The network provides cable access as well as WiFi access. The only bootleneck the network has is at the 3350 switch.

Because there's diferent kind of people working over the network I need to prioritize certain type of trafic in despite of other.

The network diagram is shown bellow.

WIFI - cisco AP1100 Cable

| |

| |

\ /

\ /

\ /

\ /

2950 (With Vlan's)

|

| (5 more 2950 with AP's)

| /

| /

| /

|/

3550 (only Fiber)

|

|

PIX 315

|

|

10 Mb's to another location

Has I mencioned before, the only bootleneck of the network is the connection to another location, after the the PIX machine.

I don't have voip yet, and probably never will.

What I want to know is what is the best location to implement per network and per protocol(http,smtp,pop3, other) QoS. some say that at the edge of the network is best, others say that right before the bootleneck is best. What say you?

And if there is not much to ask I you apreciate some examples of configuration. I know something about QoS, but I lack the experience in Cisco IOS commands. I've tried applying one policy in a 2950 switch but with Chariot (Net analyzer) I couln't see any results? (sh run is bellow, because I has unable to attach it)

Help please

Current configuration : 2183 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Switch

!

!

wrr-queue bandwidth 60 20 20 1

wrr-queue cos-map 1 5

wrr-queue cos-map 2 2 3

wrr-queue cos-map 3 4

wrr-queue cos-map 4 0 1 6 7

!

class-map match-all CABLAGEM

match access-group 110

class-map match-all RESTO

match access-group 111

!

!

policy-map REST

class RESTO

set ip dscp 8

policy-map QOS

class CABLETRAFFIC

set ip dscp 40

!

mls qos map cos-dscp 0 8 16 26 32 40 48 56

ip subnet-zero

!

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

!

!

interface FastEthernet0/1

switchport access vlan 600

speed 10

service-policy input QOS

!

interface FastEthernet0/2

switchport access vlan 600

service-policy input QOS

!

interface FastEthernet0/3

switchport access vlan 200

!

interface FastEthernet0/4

switchport access vlan 200

!

interface FastEthernet0/5

switchport access vlan 600

speed 10

service-policy input QOS

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

switchport mode trunk

speed 10

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1

ip address 10.9.100.47 255.255.255.0

no ip route-cache

!

interface Vlan600

no ip address

no ip route-cache

shutdown

!

ip default-gateway 10.9.100.254

ip http server

access-list 110 permit tcp 10.0.0.0 0.0.7.255 any eq www

access-list 110 permit tcp 10.0.0.0 0.0.7.255 any eq smtp

access-list 110 permit tcp 10.0.0.0 0.0.7.255 any eq pop3

access-list 111 permit tcp 10.0.0.0 0.0.7.255 any

!

line con 0

line vty 0 4

password teste

login

line vty 5 15

login

!

!

end

12 REPLIES

Re: QoS in Medium Network with 2950 e 3550

Hello,

your policy should be modified a bit I suppose.

no policy-map REST

policy-map QOS

class CABLETRAFFIC

set ip dscp 40

class RESTO

set ip dscp 8

class class-default

set ip dscp 0

Apply the map to all access ports. The policy-map is like a set of rules to be applied. There can be only one in each direction per port.

Where should you apply QoS? Well classification and marking (your policy) should be done at the entry to your network - no matter where this is.

What you can then do is to trust your settings for CoS/DSCP and then use them to distribute resources in queuing. As a general rule you should apply specific queueing configuration to every port, where an overload situation could potentially occur.

This would be also outbound on the trunk port as well as access ports in your switch. The access ports can be overloaded when two FE are sending towards on FE at the same time.

Hope this helps. Please rate all posts.

Regards, Martin

New Member

Re: QoS in Medium Network with 2950 e 3550

thank you for your answer, but i still have a doubt.

how do I tell the switch to put the packet marked with dscp 40 in the queue with most weight??

the assingment of packet to queues is made with COS field, and not with DSCP field !!!

Re: QoS in Medium Network with 2950 e 3550

Hello,

in the global configuration you can configure DSCP-to-CoS and CoS-to-DSCP mappings.

The default settings should take care about it. In case you want to change something use the command:

mls qos dscp 40 to 5 ! DSCP to CoS mappings

mls qos cos-to-dscp 0 8 ... (give the 8 values you would like to have for CoS 0 to 7)

Hope this helps! Please rate all posts.

Regards, Martin

Purple

Re: QoS in Medium Network with 2950 e 3550

Hi,

Typically, you would use the 'mls qos map dscp-cos' command to provide the DSCP to CoS mappings. Then, the 'wrr-queue cos-map' command would be used to select the queue based on the CoS.

The default mapping for DSCP 40 is to the CoS value of 5 and the CoS value of 5 is mapped to queue 3. Now, you wish to map this to queue 1, since you have allocated queue 1 the highest bandwidth. Since you have the following line in your config - 'wrr-queue cos-map 1 5' - you are mapping CoS 5 to queue 1. Therefore, your config will result in all DSCP 40 mapped to Cos 5 and all of this traffic will be placed into queue 1, as you required. You do not need to change anything.

Hope that helps - pls rate the post if it does.

Regards,

Paresh

New Member

Re: QoS in Medium Network with 2950 e 3550

Is the ' mls qos map cos-dscp ' instruction the same as 'mls qos map dscp-cos'??

because the switch does not accept the 'mls qos map dscp-cos' instruction after i have ' mls qos map cos-dscp '

I knew I was mapping the cos to the queues correctly, but i didn't know if the packets were being marked at COS field correctly

thanks in advance to all the people that helped me until now, and to those who will

Purple

Re: QoS in Medium Network with 2950 e 3550

Hi again,

The 'mls qos map cos-dscp' and the 'mls qos map dscp-cos' are quite different commands and should be able to co-exist.

Which switch are you trying this on - the 2950 or the 3550 ? Can you post the error you receive when you try to enter the 'mls qos map dscp-cos' command ?

Hope that helps - pls rate the post if it does.

Regards,

Paresh.

Purple

Re: QoS in Medium Network with 2950 e 3550

Hi again,

I just tried this on my switch:

LAB3550-12G(config)#mls qos map cos-dscp 0 8 16 26 32 40 48 56

LAB3550-12G(config)#mls qos map dscp-cos 63 to 5

LAB3550-12G(config)#^Z

LAB3550-12G#sh run | i mls qos

mls qos map cos-dscp 0 8 16 26 32 40 48 56

As you can see (and as you stated), the 'mls qos map dscp-cos ' command does not appear in the config.

However, the change has taken effect. If you issue the 'show mls qos map dscp-cos'

command you will see that the DSCP-to-CoS map has changed.

For example, on my switch I get the following:

LAB3550-12G#show mls qos map dscp-cos

Dscp-cos map:

d1 : d2 0 1 2 3 4 5 6 7 8 9

---------------------------------------

0 : 00 00 00 00 00 00 00 00 01 01

1 : 01 01 01 01 01 01 02 02 02 02

2 : 02 02 02 02 03 03 03 03 03 03

3 : 03 03 04 04 04 04 04 04 04 04

4 : 05 05 05 05 05 05 05 05 06 06

5 : 06 06 06 06 06 06 07 07 07 07

6 : 07 07 07 05

Note that the CoS mapping for DSCP 63 has now changed to 5.

Hope that helps - pls rate the post if it does.

Regards,

Paresh.

New Member

Re: QoS in Medium Network with 2950 e 3550

thnks... I didn't knew how to interperter the output of that comand.

All I have to do know is to trust the COS/DSCP setting in the 3550, and assign te diferent COS values to the queues correctly. maybe with wrr-queue or srr-queue.

But in my 3550 i have this version Version 12.1(20)EA1, but it doesn't have wrr-queue nor srr-queue, so how do i assing the cos values to the queues??

under config prompt all I have is queue-list and priority-list.

Purple

Re: QoS in Medium Network with 2950 e 3550

Hmm.. that does not seem right.

The command reference for version 12.1(11)EA1, an older version than you've got, supports the wrr-queue command so I'm sure your version should support it too.

What do you see when you type in 'wrr?' at the command prompt in configuration mode ?

Hope that helps - pls rate posts that help.

Regards,

Paresh

New Member

Re: QoS in Medium Network with 2950 e 3550

I've found the answer. in the 3550 the wrr-queues are a per interfance setting.

every interface has a wrr-queue.

but where can i find the IOS command manifest?

Re: QoS in Medium Network with 2950 e 3550

Hello,

one source of information is the chapter "Configuring QoS" from the "Catalyst 3550 Multilayer Switch Software Configuration Guide" at

http://www.cisco.com/en/US/products/hw/switches/ps646/products_configuration_guide_chapter09186a00801f0a5a.html

Hope this helps! Please rate all posts.

regards, Martin

Purple

Re: QoS in Medium Network with 2950 e 3550

Hi,

The following is probably the nest location for this:

http://www.cisco.com/en/US/customer/products/hw/switches/ps646/prod_command_reference_list.html

Just pick the command reference for your IOS version and you should be right !

Pls remember to rate posts.

Regards,

Paresh

156
Views
19
Helpful
12
Replies