Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Cisco Support Community site will be in read only mode on Dec14, 2017 from 12:01am PST to 11:30am for standard maintenance. Sorry for the inconvenience.

New Member

qos on 3550

Hi

Here is the config for the 3550 switch.

bell3550_1#sh run

Building configuration...

Current configuration : 9545 bytes

!

version 12.1

no service single-slot-reload-enable

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname bell3550_1

!

!

ip subnet-zero

ip routing

!

mls qos map cos-dscp 0 8 16 26 34 46 48 56

mls qos

!

class-map match-all Voice-Control

match access-group name Voice-Control

class-map match-all Voice

match access-group name Voice

!

!

policy-map 3550-LAN-Edge-In

class Voice-Control

set ip dscp 26

class Voice

set ip dscp 46

!

!

!

spanning-tree extend system-id

spanning-tree vlan 1 priority 24576

spanning-tree vlan 100 priority 24576

!

!

!

interface Port-channel1

no ip address

!

interface Port-channel2

no ip address

!

interface FastEthernet0/1

description To 3640 Router

no switchport

ip address 172.31.251.202 255.255.255.252

service-policy input 3550-LAN-Edge-In

wrr-queue cos-map 1 0 1

wrr-queue cos-map 2 2 3

wrr-queue cos-map 3 4

wrr-queue cos-map 4 5 6 7

priority-queue out

!

interface FastEthernet0/2

description To Call Manager Publisher

switchport access vlan 100

no ip address

duplex full

speed 100

service-policy input 3550-LAN-Edge-In

wrr-queue cos-map 1 0 1

wrr-queue cos-map 2 2 3

wrr-queue cos-map 3 4

wrr-queue cos-map 4 5 6 7

priority-queue out

spanning-tree portfast

!

interface FastEthernet0/3

description To Call Manager Subscriber

switchport access vlan 100

no ip address

duplex full

speed 100

service-policy input 3550-LAN-Edge-In

wrr-queue cos-map 1 0 1

wrr-queue cos-map 2 2 3

wrr-queue cos-map 3 4

wrr-queue cos-map 4 5 6 7

priority-queue out

spanning-tree portfast

!

interface FastEthernet0/4

description I3 Publisher

switchport access vlan 100

no ip address

duplex full

speed 100

service-policy input 3550-LAN-Edge-In

wrr-queue cos-map 1 0 1

wrr-queue cos-map 2 2 3

wrr-queue cos-map 3 4

wrr-queue cos-map 4 5 6 7

priority-queue out

channel-group 1 mode on

spanning-tree portfast

!

interface FastEthernet0/5

description I3 Publisher

switchport access vlan 100

no ip address

duplex full

speed 100

service-policy input 3550-LAN-Edge-In

wrr-queue cos-map 1 0 1

wrr-queue cos-map 2 2 3

wrr-queue cos-map 3 4

wrr-queue cos-map 4 5 6 7

priority-queue out

channel-group 1 mode on

spanning-tree portfast

!

interface FastEthernet0/6

description I3 Subscriber

switchport access vlan 100

no ip address

duplex full

speed 100

service-policy input 3550-LAN-Edge-In

wrr-queue cos-map 1 0 1

wrr-queue cos-map 2 2 3

wrr-queue cos-map 3 4

wrr-queue cos-map 4 5 6 7

priority-queue out

channel-group 2 mode on

spanning-tree portfast

!

interface FastEthernet0/7

description I3 Subscriber

switchport access vlan 100

no ip address

duplex full

speed 100

service-policy input 3550-LAN-Edge-In

wrr-queue cos-map 1 0 1

wrr-queue cos-map 2 2 3

wrr-queue cos-map 3 4

wrr-queue cos-map 4 5 6 7

priority-queue out

channel-group 2 mode on

spanning-tree portfast

!

interface FastEthernet0/8

description To VG200 DSPfarm

switchport access vlan 100

no ip address

duplex full

speed 100

service-policy input 3550-LAN-Edge-In

wrr-queue cos-map 1 0 1

wrr-queue cos-map 2 2 3

wrr-queue cos-map 3 4

wrr-queue cos-map 4 5 6 7

priority-queue out

spanning-tree portfast

!

interface FastEthernet0/9

description IPphone/PC

switchport trunk encapsulation dot1q

switchport voice vlan 100

switchport priority extend cos 0

no ip address

mls qos trust cos

wrr-queue cos-map 1 0 1

wrr-queue cos-map 2 2 3

wrr-queue cos-map 3 4

wrr-queue cos-map 4 5 6 7

priority-queue out

spanning-tree portfast

!

interface FastEthernet0/10

description IPphone/PC

switchport trunk encapsulation dot1q

switchport voice vlan 100

switchport priority extend cos 0

no ip address

mls qos trust cos

wrr-queue cos-map 1 0 1

wrr-queue cos-map 2 2 3

wrr-queue cos-map 3 4

wrr-queue cos-map 4 5 6 7

priority-queue out

spanning-tree portfast

!

interface FastEthernet0/11

description IPphone/PC

switchport trunk encapsulation dot1q

switchport voice vlan 100

switchport priority extend cos 0

no ip address

mls qos trust cos

wrr-queue cos-map 1 0 1

wrr-queue cos-map 2 2 3

wrr-queue cos-map 3 4

wrr-queue cos-map 4 5 6 7

priority-queue out

spanning-tree portfast

!

interface FastEthernet0/12

description IPphone/PC

switchport trunk encapsulation dot1q

switchport voice vlan 100

switchport priority extend cos 0

no ip address

mls qos trust cos

wrr-queue cos-map 1 0 1

wrr-queue cos-map 2 2 3

wrr-queue cos-map 3 4

wrr-queue cos-map 4 5 6 7

priority-queue out

spanning-tree portfast

!

interface FastEthernet0/13

description IPphone/PC

switchport trunk encapsulation dot1q

switchport voice vlan 100

switchport priority extend cos 0

no ip address

mls qos trust cos

wrr-queue cos-map 1 0 1

wrr-queue cos-map 2 2 3

wrr-queue cos-map 3 4

wrr-queue cos-map 4 5 6 7

priority-queue out

spanning-tree portfast

!

interface FastEthernet0/14

description IPphone/PC

switchport trunk encapsulation dot1q

switchport voice vlan 100

switchport priority extend cos 0

no ip address

mls qos trust cos

wrr-queue cos-map 1 0 1

wrr-queue cos-map 2 2 3

wrr-queue cos-map 3 4

wrr-queue cos-map 4 5 6 7

priority-queue out

spanning-tree portfast

!

interface FastEthernet0/15

description IPphone/PC

switchport trunk encapsulation dot1q

switchport voice vlan 100

switchport priority extend cos 0

no ip address

mls qos trust cos

wrr-queue cos-map 1 0 1

wrr-queue cos-map 2 2 3

wrr-queue cos-map 3 4

wrr-queue cos-map 4 5 6 7

priority-queue out

spanning-tree portfast

!

interface FastEthernet0/16

description IPphone/PC

switchport trunk encapsulation dot1q

switchport voice vlan 100

switchport priority extend cos 0

no ip address

mls qos trust cos

wrr-queue cos-map 1 0 1

wrr-queue cos-map 2 2 3

wrr-queue cos-map 3 4

wrr-queue cos-map 4 5 6 7

priority-queue out

spanning-tree portfast

!

interface FastEthernet0/17

description IPphone/PC

switchport trunk encapsulation dot1q

switchport voice vlan 100

switchport priority extend cos 0

no ip address

mls qos trust cos

wrr-queue cos-map 1 0 1

wrr-queue cos-map 2 2 3

wrr-queue cos-map 3 4

wrr-queue cos-map 4 5 6 7

priority-queue out

spanning-tree portfast

!

interface FastEthernet0/18

description IPphone/PC

switchport trunk encapsulation dot1q

switchport voice vlan 100

switchport priority extend cos 0

no ip address

mls qos trust cos

wrr-queue cos-map 1 0 1

wrr-queue cos-map 2 2 3

wrr-queue cos-map 3 4

wrr-queue cos-map 4 5 6 7

priority-queue out

spanning-tree portfast

!

interface FastEthernet0/19

description IPphone/PC

switchport trunk encapsulation dot1q

switchport voice vlan 100

switchport priority extend cos 0

no ip address

mls qos trust cos

wrr-queue cos-map 1 0 1

wrr-queue cos-map 2 2 3

wrr-queue cos-map 3 4

wrr-queue cos-map 4 5 6 7

priority-queue out

spanning-tree portfast

!

interface FastEthernet0/20

description IPphone/PC

switchport trunk encapsulation dot1q

switchport voice vlan 100

switchport priority extend cos 0

no ip address

mls qos trust cos

wrr-queue cos-map 1 0 1

wrr-queue cos-map 2 2 3

wrr-queue cos-map 3 4

wrr-queue cos-map 4 5 6 7

priority-queue out

spanning-tree portfast

!

interface FastEthernet0/21

description IPphone/PC

switchport trunk encapsulation dot1q

switchport voice vlan 100

switchport priority extend cos 0

no ip address

mls qos trust cos

wrr-queue cos-map 1 0 1

wrr-queue cos-map 2 2 3

wrr-queue cos-map 3 4

wrr-queue cos-map 4 5 6 7

priority-queue out

spanning-tree portfast

!

interface FastEthernet0/22

description IPphone/PC

switchport trunk encapsulation dot1q

switchport voice vlan 100

switchport priority extend cos 0

no ip address

mls qos trust cos

wrr-queue cos-map 1 0 1

wrr-queue cos-map 2 2 3

wrr-queue cos-map 3 4

wrr-queue cos-map 4 5 6 7

priority-queue out

spanning-tree portfast

!

interface FastEthernet0/23

description IPphone/PC

switchport trunk encapsulation dot1q

switchport voice vlan 100

switchport priority extend cos 0

no ip address

mls qos trust cos

wrr-queue cos-map 1 0 1

wrr-queue cos-map 2 2 3

wrr-queue cos-map 3 4

wrr-queue cos-map 4 5 6 7

priority-queue out

spanning-tree portfast

!

interface FastEthernet0/24

description IPphone/PC

switchport trunk encapsulation dot1q

switchport voice vlan 100

switchport priority extend cos 0

no ip address

mls qos trust cos

wrr-queue cos-map 1 0 1

wrr-queue cos-map 2 2 3

wrr-queue cos-map 3 4

wrr-queue cos-map 4 5 6 7

priority-queue out

spanning-tree portfast

!

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

no ip address

wrr-queue cos-map 1 0 1

wrr-queue cos-map 2 2 3

wrr-queue cos-map 3 4

wrr-queue cos-map 4 5 6 7

priority-queue out

!

interface GigabitEthernet0/2

switchport trunk encapsulation dot1q

switchport mode trunk

no ip address

wrr-queue cos-map 1 0 1

wrr-queue cos-map 2 2 3

wrr-queue cos-map 3 4

wrr-queue cos-map 4 5 6 7

priority-queue out

!

interface Vlan1

ip address 172.30.105.1 255.255.255.0

!

interface Vlan100

ip address 172.30.132.1 255.255.255.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.31.251.201

ip http server

!

ip access-list extended Voice

permit udp any any range 16384 32767

ip access-list extended Voice-Control

permit tcp any any range 2000 2002

permit tcp any any eq 1720

permit tcp any any range 11000 11999

permit udp any any eq 2427

!

!

!

!

end

bell3550_1#sh pol

bell3550_1#sh policy-map

Policy Map 3550-LAN-Edge-In

class Voice-Control

set ip dscp 26

class Voice

set ip dscp 46

bell3550_1#sh ip acc

bell3550_1#sh ip acce

bell3550_1#sh ip access-lists

Extended IP access list Voice

permit udp any any range 16384 32767

Extended IP access list Voice-Control

permit tcp any any range 2000 2002

permit tcp any any eq 1720

permit tcp any any range 11000 11999

permit udp any any eq 2427

bell3550_1#sh ver

Cisco Internetwork Operating System Software

IOS (tm) C3550 Software (C3550-I5Q3L2-M), Version 12.1(12c)EA1, RELEASE SOFTWARE

(fc1)

Copyright (c) 1986-2002 by cisco Systems, Inc.

Compiled Mon 25-Nov-02 00:07 by antonino

Image text-base: 0x00003000, data-base: 0x0075FE48

ROM: Bootstrap program is C3550 boot loader

bell3550_1 uptime is 16 hours, 44 minutes

System returned to ROM by power-on

System image file is "flash:c3550-i5q3l2-mz.121-12c.EA1/c3550-i5q3l2-mz.121-12c.

EA1.bin"

cisco WS-C3550-24-PWR (PowerPC) processor (revision A0) with 65526K/8192K bytes

of memory.

Processor board ID CHK0650W21A

Last reset from warm-reset

Bridging software.

Running Layer2/3 Switching Image

Ethernet-controller 1 has 12 Fast Ethernet/IEEE 802.3 interfaces

Ethernet-controller 2 has 12 Fast Ethernet/IEEE 802.3 interfaces

Ethernet-controller 3 has 1 Gigabit Ethernet/IEEE 802.3 interface

Ethernet-controller 4 has 1 Gigabit Ethernet/IEEE 802.3 interface

24 FastEthernet/IEEE 802.3 interface(s)

2 Gigabit Ethernet/IEEE 802.3 interface(s)

The password-recovery mechanism is enabled.

384K bytes of flash-simulated non-volatile configuration memory.

Base ethernet MAC Address: 00:0B:5F:7F:60:80

Motherboard assembly number: 73-8100-05

Power supply part number: 341-0029-01

Motherboard serial number: CAT06490AAT

Power supply serial number: LIT065000FF

Model revision number: A0

Motherboard revision number: A0

Model number: WS-C3550-24PWR-EMI

System serial number: CHK0650W21A

Configuration register is 0x10F

bell3550_1#

but i see no hit counts generated for any of the access-list. I also tried numbered access list , yet i don't see any access-list hit counts. If i miss anything in the config please let me know.

i also tried creating one more access list for ip traffic and tried applying it directly in the interface , yet i don't see any access list hits.

any help is appreciated.

thanks

sen

2 REPLIES
New Member

Re: qos on 3550

use

show mls qos int command to look for qos actions...

also use the 'mls qos monitor' interface command for details

you can use the show access-list hardware counter cmd to look for ACL hits...this is not per acl though.

New Member

Re: qos on 3550

i think acl hits is not taking here because another 3640 is doing the inter vlan routing. do you think that might be the issue., why acl hits not taking place. because my understanding is routers alone can process the acl.

please advice.

thanks

sen

87
Views
0
Helpful
2
Replies
CreatePlease to create content