Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

QOS on SOHO97 or series 800

Hello,

Is it possible to make a QOS appilcation

(FTP or HTTP) ?

i would like to reserve an pourcentage of my bandwitch for example FTP or HTTP application. I see with class-map.

And if it's possible, what is a IOS correct, please ?

Best regards,

Fabrice.

13 REPLIES

Re: QOS on SOHO97 or series 800

Hi

Since you havent specified the exact model details do find the datasheets of both soho series router and 800 series router.

from that you can find out the required details about qos support on those models..

http://cisco.com/en/US/products/hw/routers/ps4866/products_data_sheets_list.html

http://cisco.com/en/US/products/hw/routers/ps380/products_data_sheets_list.html

regds

New Member

Re: QOS on SOHO97 or series 800

Thank for reply,

But have you an example for QOS between 2 Cisco 806 or with an Cisco 1700 ?

Regards.

Re: QOS on SOHO97 or series 800

Hi

Do find a simple configuration assigining 50 percent of available bandwidth to telnet application and 25 percent to traffic accessed through port number 80.

you need to start the process with classifying the traffic using either access-lists or NBAR which is most widely being used and easy to use too.

Once you are done with classification then either you need to mark them or need to allocate the kinda priority you expect to given or the bandwidth gurantee required to given for the classes of traffic designed.

Then you need to bind the policy map under the physical interface which acts as the exit point and in which you need to have the kinda gurantee or priority.

!

access-list 102 permit tcp any any eq 23

access-list 103 permit tcp any any eq 80

!

class-map data

match access-group 102

class-map net

match access-group 103

!

policy-map mlppp

class data

bandwidth percent 50

class net

bandwidth percent 25

class class-default

fair-queue

!

interface BRI2/1

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

no cdp enable

ppp authentication chap

!

interface BRI2/2

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

no cdp enable

ppp authentication chap

!

interface Dialer2

ip unnumbered Loopback0

encapsulation ppp

dialer pool 1

dialer load-threshold 1 either

dialer string 6113

dialer string 6114

dialer-group 1

ppp authentication chap

ppp multilink

service-policy output mlppp

regds

New Member

Re: QOS on SOHO97 or series 800

HI,

This configuration doesn't work. i attached a file.

I think all trafic pass in my class default.

Regards,

Re: QOS on SOHO97 or series 800

hi

Can you post your configuration and the traffic pattern for which you want to give bandwidth gurantee also the bandwidth available as well as the amount of bandwidth gurantee you want to have for your traffic..

In my ealier post i did post a simple sample config to assist and get you going..

regds

New Member

Re: QOS on SOHO97 or series 800

hi,

thank for reply.

i attached a file.

I would like a gurantee 25% for FTP and 50 % HTTP.

For information, my config is an crypto VPN on eth1.

Re: QOS on SOHO97 or series 800

Hi

Try to configure qos pre-classify under your ipsec policy and check for the stats.

crypto map vpn 10 ipsec-isakmp

qos pre-classify

Also configure the exact bandwidth provided to you under the ethernet interface using bandwidth command.

regds

New Member

Re: QOS on SOHO97 or series 800

Hi,

When i try to set QOS command on crypto map, i have a msg:

input invalid command.

I attached my sh ver.

And you want that set bandwidth command on int eth0 or eth1 ? how many bandwidth, i set.

Regrads,

Re: QOS on SOHO97 or series 800

Hi

I did give a try for the QOS for Virtual Private Networks feature in Cisco 806 router and ended up with null.

I dont think its possible to bind that commmand under ipsec policy in 806 since the feature - Qos for Virtual Private Networks is not included in any of the codes avl for 806 series...

I meant to set the bandwidth under the ethernet1 (which gets you connected to the otuside world or remote peer)interface which is basically the available bandwidth on the physical line which gets terminated over there in the ethernet port.

regds

New Member

Re: QOS on SOHO97 or series 800

Hi,

With QOS for VPN is not possible on the 806 and C837 or 1700, is it possible ?

I will try within Crypto VPN, and i have Cisco 1720 ADSL, there is not VPN tunnel, i connect directly to the outside world, Can you help me for configuration ?

Thank

New Member

Re: QOS on SOHO97 or series 800

My new config is in the file and sh policy.

I have in eth1 10Mbits/s. when i donwload on the FTP site, my rate transfert is a 500 KO/s, in my config

i limeted a bandwitch for FTP at Bandwidth 1 (%)

Bandwidth 100 (kbps)

Why my speed is 500 KO/s transfer ?

With application is FTP Expert.

Thank

Re: QOS on SOHO97 or series 800

Hi

Are you using 1720 to connect to your remote location or external FTP sites ?

you can also think of using CAR for limiting the bandwidth being used by different applications instead of class based bandwidth gurantee.

you can configure CAR matching the access-list (matching your ftp traffic) and the average bandwidth you would like to allow also with necessary burst and excess burst rates..

you can refer this link which can help u to get to know about how you can do the same using CAR..

http://www.cisco.com/en/US/products/sw/iosswrel/ps1835/products_configuration_guide_chapter09186a00800c75ce.html

regds

New Member

Re: QOS on SOHO97 or series 800

Hi,

When i configured CAR matching for limiting the bandwitch on Cisco806 or cisco1720, i haven't problem. the configuration with Rate-Limit and ACL for FTP is correct an works but if i enabled the crypto map, it doesn't work.

I have problem only with configuration Class-Map and Policy.

Regards.

269
Views
0
Helpful
13
Replies
CreatePlease to create content