Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QOS prioritizing on a 827

Hi All,

We have a 827 router on a 512/128 k ADSL link.

We wish to use QoS to prioritise traffic.

Any ideas or config examples - the ones i am using dont do anything! :(

is it even possible?

cheers.

dave

7 REPLIES
VIP Purple

Re: QOS prioritizing on a 827

Hello,

you could use Class-based Weighted Fair Queueing. A sample config would look like this:

class-map match-all PRIORITY

match protocol ica (--> this would prioritise ICS/CITRIX traffic)

class-map match-all PRIORITY1

match protocol ipx (this is just an example)

!

policy-map PRIORITISE

class PRIORITY

set ip precedence 5

class PRIORITY1

set ip precedence 4

!

interface ethernet0

service-policy output PRIORITISE

!

In this example, ICA/CITRIX traffic would be prioritised over IPX traffic.

This is just an example, check out the following link for more config samples:

http://www.cisco.com/en/US/partner/products/hw/routers/ps380/products_configuration_guide_chapter09186a0080118cbb.html

Regards,

Georg

New Member

Re: QOS prioritizing on a 827

hi Georg,

Would i apply it to eth0 or atm0 or even dialer1?

Also i cannot get to that link - not enough priveleges. can you email it to me?

david@cs.curtin.edu.au

cheers

d.

VIP Purple

Re: QOS prioritizing on a 827

Hello David,

apply the policy map to Ethernet0.

The link is actually a page with other links...hard to send, I´ll check if I can send it somehow.

Regards,

Georg

New Member

Re: QOS prioritizing on a 827

hi,

ok this is my config so far:

class-map match-any LOW

match access-group 110

policy-map PRIORITISE

class LOW

set ip precedence 0

class class-default

set ip precedence 5

interface Ethernet0

service-policy output PRIORITISE

access-list 110 permit ip host 192.168.0.110 any

but when i do a show policy int there are no packets going into the LOW class?

what do you reckon?

cheers.

d.

New Member

Re: QOS prioritizing on a 827

anyone?

Bronze

Re: QOS prioritizing on a 827

Hi Dave,

From your config, any traffic coming from source 192.168.0.110 should be in marked with 0 precedence. Did you make sure that you sent traffic from that source.

You can enable logging against the Access-list, just type the keyword 'log' at the end of the access list and pass some traffic. Give a show access list command an it will show you the no of packets that matched the access-list criteria. You should see these no. of packets in the LOW class.

HTH

Aslam

New Member

Re: QOS prioritizing on a 827

hi,

thanks for repling :)

yes the source of the packets is 192.168.0.110 it is machine connected to the lan interface (eth0).

ive changed the eth0 to service-policy input PRIORITISE rather than output

that seems to be doing the right thing when i do a show policy-map int

but im not sure if its having the desired effect.

basically any traffic that 192.168.0.110 generates i want to make a lower priority than the rest of the network - this goes for traffic that is being sent to this machine as well.

but im not sure if i am doing it correctly.

an example might help:

192.168.0.110 is downloading from FTP

192.168.0.50 is doing a telnet session to a remote host

i dont want .50's "response" time to be affected by the download that 110 is doing.???

what do you think?

cheers

dave

172
Views
0
Helpful
7
Replies
CreatePlease login to create content