Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QOS problem (multicast) with 3750

Hi,

I need help to solve following problem.

I have setup qos in our 3750, see below.

Unicast traffic is handle correct, However with multicast streams the router set the dscp to 0

Has somebody any idea what is missing?

Too old sw?   Cisco IOS Software, C3750 Software (C3750-ADVIPSERVICESK9-M), Version 12.2(35)SE,

Regards Niklas

ip multicast-routing distributed
ip multicast multipath
!
mls qos srr-queue input priority-queue 1 bandwidth 10
mls qos srr-queue input dscp-map queue 1 threshold 1  46
mls qos srr-queue input dscp-map queue 2 threshold 1  11 24 30 48
mls qos srr-queue output dscp-map queue 1 threshold 1  48
mls qos srr-queue output dscp-map queue 2 threshold 1  46
mls qos srr-queue output dscp-map queue 3 threshold 1  40
mls qos srr-queue output dscp-map queue 4 threshold 1  11 24 30
mls qos

interface GigabitEthernet1/0/22
switchport access vlan 41
switchport mode access
load-interval 30
srr-queue bandwidth share 25 25 25 20
priority-queue out
mls qos trust dscp
!
interface GigabitEthernet1/0/23
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 40
switchport mode trunk
load-interval 30
srr-queue bandwidth share 25 25 25 20
priority-queue out
mls qos trust dscp

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: QOS problem (multicast) with 3750

You welcome.

To see which queue is dropping use "show plat port-asic stats drop x/x"

HTH,

Lei Tian

12 REPLIES
Cisco Employee

Re: QOS problem (multicast) with 3750

Hi Niklas,

You are trusting DSCP on the interface; if the receiving traffic with dscp 0, the switch will not change it unless you configure the switch to do it.

HTH,

Lei Tian

New Member

Re: QOS problem (multicast) with 3750

Hi,

The multicast stream has dscp 32 , when is leaving 3750 it has 0.

With unicast traffic this behavior is not occur.

BR Niklas

Cisco Employee

Re: QOS problem (multicast) with 3750

Hi Niklas,

Did you check the statistics from that 2 interfaces? Can you post the output?

show mls qos interface x/x statistics

thanks,

Lei Tian

New Member

Re: QOS problem (multicast) with 3750

Hi,

Here comes the printouts:

with mls qos enabled:

cisco-Mcast#sh mls qos interface gigabitEthernet 1/0/22 statistics
GigabitEthernet1/0/22

  dscp: incoming 
-------------------------------

  0 -  4 :           0            0            0            0            0 
  5 -  9 :           0            0            0            0            0 
10 - 14 :           0            0            0            0            0 
15 - 19 :           0            0            0            0            0 
20 - 24 :           0            0            0            0            0 
25 - 29 :           0            0            0            0            0 
30 - 34 :           0            0            0            0            0 
35 - 39 :           0            0            0            0            0 
40 - 44 :           0            0            0            0            0 
45 - 49 :           0            0            0            0            0 
50 - 54 :           0            0            0            0            0 
55 - 59 :           0            0            0            0            0 
60 - 64 :           0            0            0            0 
  dscp: outgoing
-------------------------------

  0 -  4 :     8881981            0            0            0            0 
  5 -  9 :           0            0            0            0            0 
10 - 14 :           0            0            0            0            0 
15 - 19 :           0            0            0            0            0 
20 - 24 :           0            0            0            0            0 
25 - 29 :           0            0            0            0            0 
30 - 34 :           0            0            0            0            0 
35 - 39 :           0            0            0            0            0 
40 - 44 :           0            0            0            0            0 
45 - 49 :           0            0            0          307            0 
50 - 54 :           0            0            0            0            0 
55 - 59 :           0            0            0            0            0 
60 - 64 :           0            0            0            0 
  cos: incoming 
-------------------------------

  0 -  4 :           0            0            0            0            0 
  5 -  7 :           0            0            0 
  cos: outgoing
-------------------------------

  0 -  4 :     8881981            0            0            0            0 
  5 -  7 :           0          307            0 
Policer: Inprofile:            0 OutofProfile:            0

cisco-Mcast#sh mls qos interface gigabitEthernet 1/0/23 statistics
GigabitEthernet1/0/23

  dscp: incoming 
-------------------------------

  0 -  4 :     8931330            0            0            0            0 
  5 -  9 :           0            0            0            0            0 
10 - 14 :           0            0            0            0            0 
15 - 19 :           0            0            0            0            0 
20 - 24 :           0            0            0            0            0 
25 - 29 :           0            0            0            0            0 
30 - 34 :           0            0            0            0            0 
35 - 39 :           0            0            0            0            0 
40 - 44 :           0            0            0            0            0 
45 - 49 :           0            0            0          202            0 
50 - 54 :           0            0            0            0            0 
55 - 59 :           0            0            0            0            0 
60 - 64 :           0            0            0            0 
  dscp: outgoing
-------------------------------

  0 -  4 :           0            0            0            0            0 
  5 -  9 :           0            0            0            0            0 
10 - 14 :           0            0            0            0            0 
15 - 19 :           0            0            0            0            0 
20 - 24 :           0            0            0            0            0 
25 - 29 :           0            0            0            0            0 
30 - 34 :           0            0            0            0            0 
35 - 39 :           0            0            0            0            0 
40 - 44 :           0            0            0            0            0 
45 - 49 :           0            0            0         1206            0 
50 - 54 :           0            0            0            0            0 
55 - 59 :           0            0            0            0            0 
60 - 64 :           0            0            0            0 
  cos: incoming 
-------------------------------

  0 -  4 :    11357772            0            0            0            0 
  5 -  7 :           0            2            0 
  cos: outgoing
-------------------------------

  0 -  4 :           0            0            0            0            0 
  5 -  7 :           0         1206            2 
Policer: Inprofile:            0 OutofProfile:            0

cisco-Mcast#

mls qos disabled:

cisco-Mcast#sh mls qos interface gigabitEthernet 1/0/22 statistics
GigabitEthernet1/0/22

  dscp: incoming 
-------------------------------

  0 -  4 :           0            0            0            0            0 
  5 -  9 :           0            0            0            0            0 
10 - 14 :           0            0            0            0            0 
15 - 19 :           0            0            0            0            0 
20 - 24 :           0            0            0            0            0 
25 - 29 :           0            0            0            0            0 
30 - 34 :           0            0            0            0            0 
35 - 39 :           0            0            0            0            0 
40 - 44 :           0            0            0            0            0 
45 - 49 :           0            0            0            0            0 
50 - 54 :           0            0            0            0            0 
55 - 59 :           0            0            0            0            0 
60 - 64 :           0            0            0            0 
  dscp: outgoing
-------------------------------

  0 -  4 :           0            0            0            0            0 
  5 -  9 :           0            0            0            0            0 
10 - 14 :           0            0            0            0            0 
15 - 19 :           0            0            0            0            0 
20 - 24 :           0            0            0            0            0 
25 - 29 :           0            0            0            0            0 
30 - 34 :           0            0         7371            0            0 
35 - 39 :           0            0            0            0            0 
40 - 44 :           0            0            0            0            0 
45 - 49 :           0            0            0            0            0 
50 - 54 :           0            0            0            0            0 
55 - 59 :           0            0            0            0            0 
60 - 64 :           0            0            0            0 
  cos: incoming 
-------------------------------

  0 -  4 :           0            0            0            0            0 
  5 -  7 :           0            0            0 
  cos: outgoing
-------------------------------

  0 -  4 :        7371            0            0            0            0 
  5 -  7 :           0            0            0 
Policer: Inprofile:            0 OutofProfile:            0

cisco-Mcast#sh mls qos interface gigabitEthernet 1/0/23 statistics
GigabitEthernet1/0/23

  dscp: incoming 
-------------------------------

  0 -  4 :           0            0            0            0            0 
  5 -  9 :           0            0            0            0            0 
10 - 14 :           0            0            0            0            0 
15 - 19 :           0            0            0            0            0 
20 - 24 :           0            0            0            0            0 
25 - 29 :           0            0            0            0            0 
30 - 34 :           0            0        23281            0            0 
35 - 39 :           0            0            0            0            0 
40 - 44 :           0            0            0            0            0 
45 - 49 :           0            0            0            0            0 
50 - 54 :           0            0            0            0            0 
55 - 59 :           0            0            0            0            0 
60 - 64 :           0            0            0            0 
  dscp: outgoing
-------------------------------

  0 -  4 :           0            0            0            0            0 
  5 -  9 :           0            0            0            0            0 
10 - 14 :           0            0            0            0            0 
15 - 19 :           0            0            0            0            0 
20 - 24 :           0            0            0            0            0 
25 - 29 :           0            0            0            0            0 
30 - 34 :           0            0            0            0            0 
35 - 39 :           0            0            0            0            0 
40 - 44 :           0            0            0            0            0 
45 - 49 :           0            0            0            2            0 
50 - 54 :           0            0            0            0            0 
55 - 59 :           0            0            0            0            0 
60 - 64 :           0            0            0            0 
  cos: incoming 
-------------------------------

  0 -  4 :       29272            0            0            0            0 
  5 -  7 :           0            0            0 
  cos: outgoing
-------------------------------

  0 -  4 :           0            0            0            0            0 
  5 -  7 :           0            2            0 
Policer: Inprofile:            0 OutofProfile:            0

cisco-Mcast#

BR Niklas

Cisco Employee

Re: QOS problem (multicast) with 3750

So the problem is after you turn on mls qos, switch rewrite dscp to 0 for all multicast traffic, and all unicast traffic are fine.  Will it make difference if you change g1/0/23 to access port?

What is the code version that switch running?

New Member

Re: QOS problem (multicast) with 3750

Hi,

Yes that's correct.

Cisco IOS Software, C3750 Software (C3750-ADVIPSERVICESK9-M), Version 12.2(35)SE,

Very strange behavior.

BR Niklas

Cisco Employee

Re: QOS problem (multicast) with 3750

Yes, that is abnormal. Is that switch a L3 or L2 switch? where are the L3 interfaces terminate?

New Member

Re: QOS problem (multicast) with 3750

Hi,

The switch is a layer3

interface Vlan40
ip address 10.0.0.1 255.255.255.0
ip pim sparse-mode
!
interface Vlan41
ip address 192.168.98.129 255.255.255.128
ip pim sparse-mode

Have also upgraded the switch to the latest software.

No changes

Any ideas?

BR Niklas

Cisco Employee

Re: QOS problem (multicast) with 3750

Hi,

So since you changed the code and still seeing the same, I think probably that't not a software issue.

How does the multicast traffic flow from source to the receiver? Is that interface directly connected to the multicast source? Can you post the output of show ip mroute on the switch?

Thanks

Lei Tian

New Member

Re: QOS problem (multicast) with 3750

Hi,

The multicat source is not directly connected.

I really appreciate your help

BR Niklas

cisco-Mcast#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group
       V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 233.12.166.131), 19:38:44/00:02:52, RP 192.168.90.1, flags: SP
  Incoming interface: Vlan40, RPF nbr 10.0.0.2
  Outgoing interface list: Null

(*, 233.12.166.48), 19:38:46/stopped, RP 192.168.90.1, flags: SJC
  Incoming interface: Vlan40, RPF nbr 10.0.0.2
  Outgoing interface list:
    Vlan41, Forward/Sparse, 19:38:45/00:02:21

(213.204.47.175, 233.12.166.48), 19:38:45/00:02:52, flags: JT
  Incoming interface: Vlan40, RPF nbr 10.0.0.2
  Outgoing interface list:
    Vlan41, Forward/Sparse, 19:38:45/00:02:21

(*, 233.12.166.46), 19:38:44/stopped, RP 192.168.90.1, flags: SJC
  Incoming interface: Vlan40, RPF nbr 10.0.0.2
  Outgoing interface list:
    Vlan41, Forward/Sparse, 19:38:44/00:02:16

(213.204.47.175, 233.12.166.46), 19:38:44/00:02:52, flags: JT
  Incoming interface: Vlan40, RPF nbr 10.0.0.2
  Outgoing interface list:
    Vlan41, Forward/Sparse, 19:38:44/00:02:16

(*, 233.12.166.47), 19:38:46/stopped, RP 192.168.90.1, flags: SJC
  Incoming interface: Vlan40, RPF nbr 10.0.0.2
  Outgoing interface list:
    Vlan41, Forward/Sparse, 19:38:45/00:02:16

(213.204.47.175, 233.12.166.47), 19:38:45/00:02:52, flags: JT
  Incoming interface: Vlan40, RPF nbr 10.0.0.2
  Outgoing interface list:
    Vlan41, Forward/Sparse, 19:38:45/00:02:16

(*, 233.12.166.44), 19:38:46/stopped, RP 192.168.90.1, flags: SJC
  Incoming interface: Vlan40, RPF nbr 10.0.0.2
  Outgoing interface list:
    Vlan41, Forward/Sparse, 19:38:44/00:02:16

(213.204.47.160, 233.12.166.44), 19:38:44/00:02:52, flags: JT
  Incoming interface: Vlan40, RPF nbr 10.0.0.2
  Outgoing interface list:
    Vlan41, Forward/Sparse, 19:38:44/00:02:16

(*, 224.0.1.40), 19:39:21/00:02:18, RP 192.168.90.1, flags: SJCL
  Incoming interface: Vlan40, RPF nbr 10.0.0.2
  Outgoing interface list:
    Loopback0, Forward/Sparse, 19:39:19/00:02:18

cisco-Mcast#

New Member

Re: QOS problem (multicast) with 3750

Hi Again,

I have found the issue.

I had forgot to activate mls qos trust dscp on one interface.

Thanks gain for all help.

Question.

What is the command to see in which queue traffic is dropping?

BR Niklas

Cisco Employee

Re: QOS problem (multicast) with 3750

You welcome.

To see which queue is dropping use "show plat port-asic stats drop x/x"

HTH,

Lei Tian

5409
Views
0
Helpful
12
Replies
CreatePlease to create content