Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

question about vlans and switches

Here is my config for the 3550 I am using for my default router:

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Switch

!

!

ip subnet-zero

no ip domain-lookup

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

!

!

interface FastEthernet0/1

switchport mode access

switchport access vlan 2

!

interface FastEthernet0/2

switchport mode access

switchport access vlan 1

!

interface FastEthernet0/3

no ip address

!

interface FastEthernet0/4

no ip address

!

interface FastEthernet0/5

no ip address

!

interface FastEthernet0/6

no ip address

!

interface FastEthernet0/7

no ip address

!

interface FastEthernet0/8

no ip address

!

interface FastEthernet0/9

no ip address

!

interface FastEthernet0/10

no ip address

!

interface FastEthernet0/11

no ip address

!

interface FastEthernet0/12

no ip address

!

interface FastEthernet0/13

no ip address

!

interface FastEthernet0/14

no ip address

!

interface FastEthernet0/15

no ip address

!

interface FastEthernet0/16

no ip address

!

interface FastEthernet0/17

no ip address

!

interface FastEthernet0/18

no ip address

!

interface FastEthernet0/19

no ip address

!

interface FastEthernet0/20

no ip address

!

interface FastEthernet0/21

no ip address

!

interface FastEthernet0/22

no ip address

!

interface FastEthernet0/23

no ip address

!

interface FastEthernet0/24

no switchport

no ip address

!

interface GigabitEthernet0/1

no ip address

!

interface GigabitEthernet0/2

no ip address

!

interface Vlan1

ip address x.x.x.x x.x.x.x

!

interface Vlan2

ip address x.x.x.x x.x.x.x

!

ip classless

no ip http server

!

!

!

!

line con 0

line vty 5 15

I have both vlans plugged into my 4006 switch. Do i have to create vlan trunks on my switch to get this to work? can i just assign ip addresses to the ports if i do not want to use vlans? will that work?

thanks for any info

5 REPLIES
Bronze

Re: question about vlans and switches

You don't need to use trunks if you have a single VLAN going across each link (i.e., if you have two links between the 3550 and 4006). You can give the interfaces themselves IP addresses on a 3550 rather than creating virtual VLAN interfaces, though you may need the EMI image to do so (I've never tried it with the SMI image).

New Member

Re: question about vlans and switches

Ok, I will look into that. thanks.

Jenn

Bronze

Re: question about vlans and switches

You may need to turn ip routing on with statement "ip routing". I don't see it in your config.

If you put the ip addresses on the physical interface you need to turn off switching on those ports and make them routed ports with "no switchport".

New Member

Re: question about vlans and switches

Ok. My initial idea was to configure the 3550 with multiple subnets and assign to a port without using vlans. i am not ready to break up my network into vlans - (hardware)

if i assign an ip to the port with no switchport and ip routing, could this work on the existing vlan? right now, cisco had me assign a secondary IP to vlan1.

Bronze

Re: question about vlans and switches

No, the ports set as routing ports would route data from the "int vlan" that the rest of the ports are in to the other device (cant remember what kind of switch it is). In other words the switch would have three ip addresses and one vlan1. That is not the way I would do it I was just pointing outthe need to shut off the switching IF you put an address on a port.

If you want two ip networks and one vlan then cisco's rec sounds good. All ports in one vlan with two addresses on the int vlan for those ports.

91
Views
0
Helpful
5
Replies
CreatePlease login to create content