Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Question on NAT

Hi,

I have an issue with the using the NAT which I would like to clarify and here's the scenario.

10.10.10.0 access via int vlan 2

192.168.100.0 - 192.168.110.0 access via int vlan 3

Configuration on the RSM.

interface vlan 1

ip address 192.168.1.1 255.255.255.0

interface vlan 2

ip address 192.168.2.1 255.255.255.0

ip nat outside

interface vlan 3

ip address 192.168.3.1 255.255.255.0

ip nat inside

access-list 150 permit ip 192.168.100.0 0.0.0.255 10.10.10.0 0.0.0.255

ip nat pool test 10.10.100.50 10.10.100.254 netmask 255.255.255.0

ip nat inside source list 150 pool test

Question.

I only wanted devices in the 192.168.100.0 range translated to the IP address in the test pool when accessing devices in 10.10.10.0 network. Will devices in the 192.168.101.0 to 192.168.110.0 networks (without translation) able to access devices in the 10.10.10.0 network or vice versa with the above setup?

TIA.

PF

2 REPLIES
Bronze

Re: Question on NAT

Yes, providing that there is ip connectivity and for this, both would have to reside within your private network since both the 10 network and the 192.168 network will never be routed over the internet.

New Member

Re: Question on NAT

Hi,

Just thought of another issue I would like to confirm. When devices on 192.168.100.0/24 access devices on 10.10.10.0/24 network, the address will be translated to 10.10.100.0/24. The translation will stay in the translation table until the defined timeout period.

Question.

If a device 192.168.100.10 translated to 10.10.100.10 is still on the translated table, access a device 192.168.1.5 (on vlan 1), what source address will 192.168.1.5 see? Will it be the original address 192.168.100.10 or the translated address 10.10.100.10?

Thanks.

PF

84
Views
0
Helpful
2
Replies
CreatePlease login to create content