Cisco Support Community
Community Member

"Slow" 2621 PAT Routing

I am using my newly-purchased 2621 router (NM-4E, 64 ram, 16 flash, 12.2(7b)) as a replacement for my Watchguard SOHO router/firewall. I have not yet begun to configure IPSec firewall features and have started with the PAT so my inside 15 PCs/Macs can use my single IP address from my cable company.

Internet (web-based applications) access is definitely present but ~1/2 the speed of the Watchguard. When you try to connect to a site, the initial delay, and subsequent download of text/images takes about twice the time.

My PAT-specific configuration details are:

interface Ethernet1/0 (my cable-WAN link)

ip address dhcp hostname XXXXXX <-- omitted for privacy

ip nat outside

no ip route-cache (I tried enabling/disabling fast switching with no effect)

no ip mroute-cache


interface FastEthernet0/0 (my inside LAN link)

ip address

ip nat inside

speed 100


router rip

version 2

passive-interface Ethernet 1/0


ip nat inside source list 1 interface Ethernet1/0 overload

ip classless

ip route Ethernet1/0

access-list 1 permit

ip name-server (my internal DNS server)

ip name-server (my Cable provider's DNS)

ip name-server

Other than the change from the Watchguard SOHO to the 2621, no ther changes have been made to my LAN.

I appreciate recommendations/suggestions you could offer!

Thank you for your time,



Re: "Slow" 2621 PAT Routing

You should be running cef on this box, rather than fast or process... I doubt it will make much difference unless you have a lot of traffic, though. Are you seeing a lot of collisions and such on any of the interfaces? You could have a duplex mismatch problem someplace. Generally, check for interface errors and problems first.


Community Member

Re: "Slow" 2621 PAT Routing


Thank you for the reply. Upon checking Ethernet 1/0 stats (device connected to the cable modem), there are substantial issues:

Of 56,037 packets (7,470,507 bytes):

26151 output errors + 326 collisions

So I guess my issue is Ethernet 1/0 related...

Community Member

Re: "Slow" 2621 PAT Routing

I fixed the Ethernet 1/0 duplex mis-match and no longer have collisions.

CEF is enabled...

I still have the "slowness" associated with initial website-contact and data download...

CreatePlease to create content