Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Radius authentication for PPPoE on Ethernet

Anyone has an example on how to configure RADIUS authentication

for PPPoE on Ethernet?

Is this alright because it can't get authenticated by RADIUS.

aaa new-model

aaa authentication ppp default local group radius

aaa authorization network default local group radius

aaa accounting network default start-stop group radius

.

.

vpdn enable

!

vpdn-group 1

accept-dialin

protocol pppoe

virtual-template 1

.

interface Ethernet0/0

ip address xxx.xxx.xxx.xxx mask

half-duplex

pppoe enable

.

interface Serial0/0

ip address xxx.xxx.xxx.xxx mask

.

interface Virtual-Template1

mtu 1492

ip unnumbered Ethernet0/0

ppp authentication chap

.

radius-server host xxx.xxxx.xxx.xxx auth-port 1812 acct-port 1646

radius-server retransmit 3

radius-server key cisco

.

1 REPLY
New Member

Re: Radius authentication for PPPoE on Ethernet

aaa new-model

aaa authentication login default local group radius enable

aaa authentication login norad enable

aaa authentication ppp default if-needed local group radius

aaa authorization config-commands

aaa authorization exec default group radius if-authenticated

aaa authorization network default group radius if-authenticated

aaa accounting delay-start

aaa accounting network default start-stop group radius

1336
Views
0
Helpful
1
Replies
CreatePlease to create content