Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Rapid SPanning tree HELP!!!!!!

Hi

I have got 2 switches in 2 different buildings connected via a laser link which connects to both switches on a point to point link.I run spanning tree over the link as if it were one network.A bridge if you like.I have also got a wireless Lan access point at the one building and a client bridge at the other building.The 2 devices are also conencted to the 2 switches.The problem I am having is that the wirless needs to be used a fast rapid spanning tree backup in case the laser link fails.I have configured both switches with spanning-tree mode rapid-pvst.The one switch is the the root bridge.When i shut the laser link down to test my wirless backup with rapid spanning tree it does not seem to work although on the switch I can ping the wirless bridge and access point.I just cant ping any device or the switch on the other side......

I got this all to work in a test environment without any other devices connected to the switches,but now that I have got it all on the live network it does not want to use the alternative path down the wirless when I bring the laser down.The wirless has a cost of 100 and the laser has a cost of 19.Am I missing something out in my configuration.

My config os the root bridge switch is below....The other switch is the same besides the ip address and priority.I have also attache the show spanning tree command.Any help or guidance will be much appreciated.

spanning-tree mode rapid-pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

spanning-tree vlan 1 priority 61440

!

!

interface FastEthernet0/1

--More-- no ip address

!

interface FastEthernet0/2

no ip address

!

interface FastEthernet0/3

no ip address

!

interface FastEthernet0/4

no ip address

!

interface FastEthernet0/5

no ip address

!

interface FastEthernet0/6

no ip address

!

interface FastEthernet0/7

no ip address

!

interface FastEthernet0/8

no ip address

!

--More-- interface FastEthernet0/9

no ip address

!

interface FastEthernet0/10

no ip address

!

interface FastEthernet0/11

no ip address

!

interface FastEthernet0/12

no ip address

!

interface FastEthernet0/13

no ip address

!

interface FastEthernet0/14

no ip address

!

interface FastEthernet0/15

no ip address

!

interface FastEthernet0/16

no ip address

--More-- !

interface FastEthernet0/17

no ip address

!

interface FastEthernet0/18

no ip address

!

interface FastEthernet0/19

no ip address

!

interface FastEthernet0/20

no ip address

!

interface FastEthernet0/21

no ip address

!

interface FastEthernet0/22

no ip address

!

interface FastEthernet0/23

no ip address

!

interface FastEthernet0/24

--More-- no ip address

!

interface FastEthernet0/25

no ip address

!

interface FastEthernet0/26

no ip address

!

interface FastEthernet0/27

no ip address

!

interface FastEthernet0/28

no ip address

!

interface FastEthernet0/29

no ip address

!

interface FastEthernet0/30

no ip address

!

interface FastEthernet0/31

no ip address

!

--More-- interface FastEthernet0/32

no ip address

!

interface FastEthernet0/33

no ip address

!

interface FastEthernet0/34

no ip address

!

interface FastEthernet0/35

no ip address

!

interface FastEthernet0/36

no ip address

!

interface FastEthernet0/37

no ip address

!

interface FastEthernet0/38

no ip address

!

interface FastEthernet0/39

no ip address

--More-- !

interface FastEthernet0/40

no ip address

!

interface FastEthernet0/41

no ip address

!

interface FastEthernet0/42

no ip address

!

interface FastEthernet0/43

no ip address

!

interface FastEthernet0/44

no ip address

!

interface FastEthernet0/45

no ip address

!

interface FastEthernet0/46

no ip address

duplex full

speed 100

--More-- !

interface FastEthernet0/47

no ip address

duplex full

speed 100

!

interface FastEthernet0/48

no ip address

!

interface GigabitEthernet0/1

no ip address

!

interface GigabitEthernet0/2

no ip address

!

interface Vlan1

ip address 10.98.7.236 255.255.248.0

no ip route-cache

!

ip default-gateway 10.98.7.254

ip http server

!

snmp-server engineID local 000000090200000821F48F40

--More-- snmp-server community private RO

sho spann

NLONL03S02#sho spanning-tree

VLAN0001

Spanning tree enabled protocol rstp

Root ID Priority 10

Address 0005.dcc0.b1c0

Cost 19

Port 12 (FastEthernet0/12)

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 61441 (priority 61440 sys-id-ext 1)

Address 000b.fd7f.1080

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Aging Time 300

Interface Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Fa0/3 Desg FWD 19 128.3 P2p

Fa0/4 Desg FWD 100 128.4 Shr

Fa0/5 Desg FWD 19 128.5 P2p

Fa0/6 Desg FWD 19 128.6 P2p

Fa0/7 Desg FWD 19 128.7 P2p

Fa0/8 Desg FWD 19 128.8 P2p

Fa0/9 Desg FWD 19 128.9 Shr

--More--

Interface Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Fa0/10 Desg FWD 19 128.10 Shr

Fa0/12 Root FWD 19 128.12 P2p Peer(STP)

Fa0/13 Desg FWD 19 128.13 P2p

Fa0/14 Desg FWD 19 128.14 P2p

Fa0/15 Desg FWD 19 128.15 P2p

Fa0/16 Desg FWD 19 128.16 P2p

Fa0/17 Desg FWD 19 128.17 P2p

Fa0/18 Desg FWD 19 128.18 P2p

Fa0/19 Desg FWD 19 128.19 P2p

Fa0/20 Desg FWD 19 128.20 P2p

Fa0/21 Desg FWD 19 128.21 P2p

Fa0/22 Desg FWD 19 128.22 P2p

Fa0/23 Desg FWD 19 128.23 P2p

Fa0/25 Desg FWD 19 128.25 P2p

Fa0/27 Desg FWD 19 128.27 P2p

Fa0/28 Desg FWD 19 128.28 Shr

Fa0/29 Desg FWD 19 128.29 P2p

Fa0/31 Desg FWD 100 128.31 Shr

Fa0/32 Desg FWD 19 128.32 P2p

Fa0/33 Desg FWD 19 128.33 P2p

Fa0/34 Desg FWD 19 128.34 Shr

Fa0/35 Desg FWD 19 128.35 P2p

Fa0/36 Desg FWD 19 128.36 P2p

--More--

Interface Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Fa0/37 Desg FWD 19 128.37 P2p

Fa0/38 Desg FWD 100 128.38 Shr

Fa0/39 Desg FWD 19 128.39 P2p

Fa0/40 Desg FWD 100 128.40 Shr

Fa0/41 Desg FWD 19 128.41 P2p

Fa0/42 Desg FWD 19 128.42 Shr

Fa0/43 Desg FWD 19 128.43 P2p

Fa0/44 Desg FWD 100 128.44 Shr

Fa0/45 Desg FWD 100 128.45 Shr

Fa0/46 Desg FWD 19 128.46 P2p

Fa0/47 Desg FWD 19 128.47 P2p

Fa0/48 Desg FWD 100 128.48 P2p

Gi0/1 Desg FWD 4 128.49 P2p Peer(STP)

NLONL03S02#

4 REPLIES
New Member

Re: Rapid SPanning tree HELP!!!!!!

Please note that port 47 is the laser and port 48 the wirless link.

Thanks

Re: Rapid SPanning tree HELP!!!!!!

Hi,

regarding to the info provided:

1) the output says that root is some other switch connected to int Fa0/12, this switch has priority 61440. So check who is the root.

2) What devices are you using to the wireless connection? Access point and a client bridge types?

I think they participate in STP and might not support RPVSTP.

Regards,

Milan

New Member

Re: Rapid SPanning tree HELP!!!!!!

Thanks for your reply...

I have configured the priority to be 4096 now.

Before I connected this to out live network I tested the 2 links on there own connected to these switches.

When i pulled the laser out it was a matter of 250ms and all the traffic was now going down the wirless link.So i know that it does work in practice.Ever since I have got other devices connected to the switches now it does not want to play ball.

This is where I get stuck.The wirless devices are a client bridge and access point.Still not working unfortunately....

Re: Rapid SPanning tree HELP!!!!!!

Hi.

If you want anybody to help you you have to provide details.

What are the exact types of your switches and wireless devices? What IOS versions?

What is the distance between buildings?

Are the devices seeing each other via CDP?

Is the STP tree correct, i.e. is the wireless port forwarding on one side and blocked on the other side? (It might be even forwarding on both sides if the topology is more complex. If yes, the problem is on another device.)

The first idea why it could work in lab but not in the live network is the distance. Check if the wireless devices are really connected each to the other.

The second idea: Are there any difference between the lab test and living network? HW types, IOS versions?

The third idea: As I mentioned in the STP tree question, the problem might be on another device. What is the exact topology? Which port is expected to go forwarding when the laser goes down?

Regards,

Milan

127
Views
0
Helpful
4
Replies