Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Rate-limiting on C3550 EMI

We have a 3550 running OSPF, I wish to rate limit one of the Gigabit (routed ) ports to 10mbs, similar to the rate-limit command on routers.

The only way I could configure, was by policing. however after no success, I have since read on CCO that policing is not supported on svi or routed interfaces.

Does anyone have any suggested ideas how I can rate limit a 1 Gigabit routed port to 10mbs on the 3550 ?

see below for current ver of IOS and non working configuration

Cisco Internetwork Operating System Software

IOS (tm) C3550 Software (C3550-I5Q3L2-M), Version 12.1(14)EA1, RELEASE SOFTWARE (fc1

---------

mls qos

class-map match-all ALL_Traffic

match any

policy-map 10mbps

class ALL_Traffic

police 10000000 8000 exceed-action drop

interface GigabitEthernet0/1

no switchport

ip address x.x.x.x 255.255.255.252

no ip redirects

no ip proxy-arp

service-policy input 10mbps

service-policy output 10mbps

---------

alpha#sh policy-map int g0/1

GigabitEthernet0/1

service-policy input: 10mbps

class-map: ALL_Traffic (match-all)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

match: any qm_police_inform_feature: CLASS_SHOW

class-map: class-default (match-any)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

match: any

0 packets, 0 bytes

5 minute rate 0 bps

service-policy output: 10mbps

class-map: ALL_Traffic (match-all)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

match: any qm_police_inform_feature: CLASS_SHOW

class-map: class-default (match-any)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

match: any

0 packets, 0 bytes

5 minute rate 0 bps

alpha#sh mls qos int g0/1 stat

GigabitEthernet0/1

Ingress

dscp: incoming no_change classified policed dropped (in bytes)

Others: 1138291001 1137333865 957136 0 0

Egress

dscp: incoming no_change classified policed dropped (in bytes)

Others: 649645264 n/a n/a 0 0

WRED drop counts:

qid thresh1 thresh2 FreeQ

1 : 0 0 1024

2 : 0 0 1024

3 : 0 0 1024

4 : 0 0 1024

alpha#sh policy-map

Policy Map 10mbps

class ALL_Traffic

police 10000000 8000 exceed-action drop

alpha#sh class-map

Class Map match-any class-default (id 0)

Match any

Class Map match-all ALL_Traffic (id 2)

Match any

2 REPLIES
Silver

Re: Rate-limiting on C3550 EMI

Check if the following configuration is of help.

http://www.cisco.com/univercd/cc/td/doc/product/lan/c3550/12112cea/3550scg/swqos.htm#xtocid34

Some of the map statements are not supported on the 3550. There is a bug CSCea28771 that has the unsupported commands documented.

Community Member

Re: Rate-limiting on C3550 EMI

Policer is only possible at input direction. The policer per VLAN works for me. See configs below :

*******************************************

mls qos

!

class-map match-any cliente-vlan-dip

match access-group name cliente-vlan-dip

!

class-map match-all vlan220

match vlan 220

match class-map cliente-vlan-dip

!

class-map match-all vlan210

match vlan 210

match class-map cliente-vlan-dip

!

!

policy-map limitador-banda

class vlan220

police 128000 8000 exceed-action drop

class vlan210

police 10000000 156250 exceed-action drop

!

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,210-240,1006-4094

switchport mode trunk

service-policy input limitador-banda

*************************************

Hope to help you. Be aware that show commands are terrible for CAT3550.

270
Views
0
Helpful
2
Replies
CreatePlease to create content