Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Recovery of uBR924

Hello all,

My oldest is in a CNAP program at his high school. So the knowledge he has gained has proved bad for my uBR924. He erased the bootflash and the flash (he is only 16). The unit comes up in Rommon mode and I was able to reload the bootflash via xmodem. When the helper IOS(12.1) loaded, I was able to tftp over a new IOS(12.2) into flash. I set the config register and gave it the command (I forget the syntax) boot system flash and then the file name. The unit comes up always from bootflash (router(boot)>) and never loads the full IOS image. I have tried changing the config-reg to many different variations, reloaded (xmodem'ed) the bootflash, and am at a loss to explain this. The files are there, I have verified that much. I have tried different IOS images in flash. Nothing has proven successful as of yet.

With or without naming the file in bootflash to be loaded from flash it does not come up.

Luckily we had another cable modem (not Cisco) to use. So it is no big thing. I just don't like for things to beat me.

Any thoughts or a direction to go in now?

Thanks for your time,

Tom

1 REPLY
Cisco Employee

Re: Recovery of uBR924

make sure that the config register is set to 0x2102 to boot the router from image in flash.

Since the ubr is booting from boot-flash, you can issue "sh flash" to see the image is loaded with exact byte counts as it is on cco.

After that enter following command in the global config

boot system flash

config-register 0x2102

exit

write mem

reload

That should make ubr to boot from flash, if not, capture the console log and post it here along with "sh flash" output so that we can see what is going on during booting.

88
Views
0
Helpful
1
Replies