Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Redistribute iBGP into OSPF doesn't work.

Router "rpsaccess06" receives a route 192.168.99.16/28 via BGP and has to redistribute it into OSPF 1 (I use only area 0). A show ip route says that it redistributes it into OSPF but another OSPF router "rps-X25-TH01" doesn't have this route in it's OSPF database/routing table.

The oldest IOS software I'm running is from Sept 25 2003

Is it a bug? What am I doing wrong?

Config rpsaccess06:

interface Loopback1

ip address 10.32.141.2 255.255.255.255

interface Ethernet1/0

ip address 10.32.143.2 255.255.255.0

router ospf 1

log-adjacency-changes

redistribute static subnets

redistribute bgp 65432 metric 5000 metric-type 1 subnets

network 10.32.0.0 0.0.255.255 area 0

network 192.168.99.0 0.0.0.255 area 0

network 192.168.0.0 0.0.255.255 area 0

!

router bgp 65432

no synchronization

bgp log-neighbor-changes

redistribute connected

redistribute static

neighbor 10.32.142.113 remote-as 65432

neighbor 10.32.142.113 description rps-vpn-TH01

neighbor 10.32.142.113 update-source Ethernet1/0

neighbor 10.32.142.113 next-hop-self

neighbor 10.32.142.113 route-map adv-to-rps-vpn-TH01 out

no auto-summary

access-list 30 permit 10.32.112.0 0.0.3.255

access-list 30 permit 10.32.132.0 0.0.3.255

access-list 30 permit 10.32.136.0 0.0.7.255

route-map adv-to-rps-vpn-TH01 permit 10

match ip address 30

rpsaccess06#show ip route 192.168.99.16

Routing entry for 192.168.99.16/28

Known via "bgp 65432", distance 200, metric 284726016, type internal

Redistributing via ospf 1

Last update from 10.32.142.113 03:07:16 ago

Routing Descriptor Blocks:

* 10.32.142.113, from 10.32.142.113, 03:07:16 ago

Route metric is 284726016, traffic share count is 1

AS Hops 0

Config rps-X25-TH01:

interface FastEthernet0/0

ip address 10.32.143.42 255.255.255.0

router ospf 1

log-adjacency-changes

network 10.32.0.0 0.0.255.255 area 0

network 192.168.99.0 0.0.0.255 area 0

rps-X25-TH01#show ip ospf 1 database | include 192.168.99

<no output>

rps-X25-TH01#show ip route 192.168.99.16

% Network not in table

2 REPLIES
Silver

Re: Redistribute iBGP into OSPF doesn't work.

By default BGP will only redistribute EBGP routes into an IGP, you need to use the "BGP REDISTRIBUTE-INTERNAL" command to redistribute IBGP routes into an IGP such as OSPF:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios123/123tcr/123tip2r/ip2_a1gt.htm#1040739

New Member

Re: Redistribute iBGP into OSPF doesn't work.

Thanks Bob,

It's working.

Regards

Gerrit Vos

148
Views
0
Helpful
2
Replies