Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Redistribute

HI

I have a question about Redistribute.

I have some network and some router.

50% network use static route and some network use EIGRP.Now I want every network connect each other.

So I need configure one router for redistribute ?. and if need then what is the configuration example ?.

and what is the configuration example of between EIGRP and OSPF.

any experties help me.

Thanks

Biplob

10 REPLIES

Re: Redistribute

Hi Biplob,

This link will give you all the config examples for redistribution

Redistribution

1) Redistribution Between Two EIGRP Autonomous Systems

2) Redistribution Between EIGRP and IGRP in Two Different Autonomous Systems

3) Redistribution Between EIGRP and IGRP in the Same Autonomous System

4) Redistribution To and From Other Protocols

5) Redistribution of Static Routes to Interfaces

http://www.cisco.com/warp/customer/103/eigrp-toc.html#redis

HTH, if yes please rate the post.

Ankur

New Member

Re: Redistribute

HI

I see your link, It is obviously usefull

but about static route and EIGRP is short brief.I need eassy and more brief.

-----------

As an example I have 4 router A,B, C, D

A=router eigrp 100

network 192.168.5.0

network 192.168.6.0

B=router eigrp 100

network 192.168.6.0

network 192.168.7.0

--

C= Ip route 0.0.0.0 0.0.0.0 192.168.8.2

ip route 192.168.7.0 255.255.255.0 192.168.7.1

(E0-172.16.5.1 s0-192.168.8.1 s1-192.168.7.2)

D= IP route 0.0.0.0 0.0.0.0 192.168.8.1

(E0-172.16.4.1 s0-192.168.8.2)

----

Now in which router I want configure redistribute ?.

If I configure redistribute in router C then what i do?.

So I need clear concept.and also in here no link about OSPF and EIGRP. so help about that.

Thanks

Biplob

Re: Redistribute

Hi Biplob,

You cannot redistribute on router C. For redistribution you have to make sure that router on which redistribution is done must have both the things configured on it.

Like router B has only EIGRP and router C has only static route.

You have to tun eigrp on router C also and redistribute static route in it so that it can be carried by EIGRP from router C to router B to router A.

HTH

Ankur

New Member

Re: Redistribute

Hi

I understand .you tell redistribute in router c.

ok if I want redistribute in router B then

I do like this :

Hi

I understand .you tell redistribute in router c.

ok if I want redistribute in router B then

I do like this

B=router eigrp 100

network 192.168.6.0

network 192.168.7.0

ip route 192.168.7.0 255.255.255. 192.168.7.2

In here Router B have bopth Static and EIGRP.

so it is right ?. and what is the command for redistribute ?.

Thanks

Biplob

Purple

Re: Redistribute

You would do the following:

router eigrp 100

network 192.168.6.0

network 192.168.7.0

redistribute static

default-metric 10000 1 255 1 1500

Hope that helps - pls rate the post if it does.

Paresh

New Member

Re: Redistribute

Hi

Oh thanks for prompt response.

In here u mention clear. but I am not understand two things 1.default-metric 10000 1 255 1 1500 ?

2. B router i add static route ?.

----

again

Ok If I use Redistribute In Router c

then I give the command

C=

Ip route 0.0.0.0 0.0.0.0 192.168.8.2

redistribute EIGRP

EIGRP 100

router 192.168.8.0

router 192.168.7.0

it is right ?.

3. which is better redistribute in Router B or router c ?

I am greatefull to all for learn easily.

Thanks

Biplob

Re: Redistribute

Hi Biplob,

As I mentioned it earlier redistribution can only happen when a router is running both (EIGRP as well as static route)

Now as you said your router B has EIGRP also configured and static route you can very well redistribute on router B.

router eigrp 100

network 192.168.6.0

network 192.168.7.0

redistribute static

default-metric 10000 1 255 1 1500

As Paresh updated in his last post.

Now because you are redistributing static route into EIGRP you have to tell it to follow the procedures which EIGRP follows to calculate metric and that is the reason you define default-metric.

Now what will happen is all static routes which get reditribute into EIGRP, EIGRP will use all composite metric (10000 1 255 1 1500 ) bandwidth, load,reliability,delay and mtu to calculate the metric for those static routes.

HTH, if yes please rate the post.

Ankur

New Member

Re: Redistribute

Hi

Now i understand why i use default-metric.but it is must be use or value can be change ?.

and what is answer of 2/3question which i post last message ?. (In router c )

thanks

Biplob

Re: Redistribute

Hi Biplob,

You can very well change the values the way you want protocol(EIGRP) running on your router to calculate metric for your static routes.

Answer for your question 2

If you want to have redistribute on router B yes you have to add one static route and if you redistribute on router C you have to configure EIGRP but the way you have configure EIGRP is wrong it should have network statement rather than router statement

router EIGRP 100

network 192.168.8.0

network 192.168.7.0

network should be the interfaces subnet which exist on your router C.

Answer to yoru question 3

you can redistribute on any router B or C really does not matter only thing you need to think is on the router where you are doing redistribution should be running both eigrp and static route and that router should have a higher capability like more cpu and dram.

In your case itis ok because you are just redistributing static router but think of a situation where you wull redistribute 2 routing protocols and that router will learn routes from both protocols so should be of cability to handle all big routing table.

HTH, if yes please rate the post.

Ankur

New Member

Re: Redistribute

Hi

Thanks to all for sharing valuable time.

Biplob

375
Views
4
Helpful
10
Replies