Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Redistributed conn in eigrp

Hi All

I use loopbacks for ISDN backup for spokes etc, and also user dialer profiles. Because the dest dialer profile at the Central Office has its own loopback IP and the remote site has its own loopback IP, a floating static route of

ip route 0.0.0.0 0.0.0.0 dialer 1 200

ip route 172.20.4.0 255.255.252.0 dialer 1 200

The problem with this is that they are conn int the routing table hence redistributed across the WAN. I dont really like the idea of this. Is there any way other than dist-lists that I could make the router not redistibute these static routes.

Regards

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Redistributed conn in eigrp

Your remark is correct. You will always need to associate the next-hop IP to a dialer. The solution belows combines both options:

hostroute:

ip route 10.75.30.244 255.255.255.255 Dialer65

route to dest network:

ip route 10.52.46.0 255.255.255.0 10.75.30.244

In this way, the next-hop IP will be in your routing-table, the class-C network behind it will not nescessarily be there, it is not a connected route.

4 REPLIES

Re: Redistributed conn in eigrp

Yes, there is an alternative. When you specify the next-hop IP adress instead of the interface, the route is no longer connected and is hence not distributed into your AS.

New Member

Re: Redistributed conn in eigrp

But if I am using IP unnumbered loopback 0 where each loopback is in it own IP subnet with a 32bit mask, there router wont know which dialer to use, will it

spoke example

interface Loopback0

description ISDN Loopback

ip address 172.16.45.85 255.255.255.255

interface Dialer1

ip unnumbered Loopback0

encapsulation ppp

dialer pool 1

dialer remote-name router

dialer idle-timeout 1200

dialer string xxxxx

dialer load-threshold 120 outbound

dialer-group 1

ppp authentication chap

ppp multilink

ip route 0.0.0.0 0.0.0.0 172.16.45.2 200 (this is the CO ISDN router)

I think here the router wont know the dest subnet, especially if I use more than one dialer,

Please chat to me on this

Thanks for your comments

Re: Redistributed conn in eigrp

Your remark is correct. You will always need to associate the next-hop IP to a dialer. The solution belows combines both options:

hostroute:

ip route 10.75.30.244 255.255.255.255 Dialer65

route to dest network:

ip route 10.52.46.0 255.255.255.0 10.75.30.244

In this way, the next-hop IP will be in your routing-table, the class-C network behind it will not nescessarily be there, it is not a connected route.

New Member

Re: Redistributed conn in eigrp

Hey thanks .... that is awesome

Thanks for your time

94
Views
0
Helpful
4
Replies
CreatePlease login to create content