Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Redistributing ISIS / OSPF

2 routers (R1 and R3) are connected via Frame-Relay running ISIS. On each router there is a loopback-interface configured also for ISIS.

In the routing table on R3 I see the loopback from R1 as ISIS route and on R1 I see the loopback from R3. So far, it works perfect.

Now on R3 I redistribute ISIS into OSPF. In the routing table on R4 (OSPF router) there is only the loopback from R1. The link between R1 and R3 and the loopback on R3 is not in R4 routing table.

It seems that the directly connected links from R3 are not redistributed into OSPF.

Any idea why and how this can be solved?

3 REPLIES
Silver

Re: Redistributing ISIS / OSPF

Without your configuration it's hard to say whats the problem here. Try this in your redistribution statement in ospf.

redis isis level-1-2 subnets

If this is not the fix please include your ospf config on R3 as well as your isis routes present on R3.

Hope this helps,

Don

New Member

Re: Redistributing ISIS / OSPF

Hi,

That's the behavior of IS-IS, IS-IS will not redistribute connected interface to other protocol (Thinking about the config for IS-IS is a bit deferent from others, it use "ip router isis" command"). You must use "redistribute connected" command to redistribute the network into OSPF.

Best Regards

Teru Lei

New Member

Re: Redistributing ISIS / OSPF

Thanks for your advise.

Is it correct to do the "redistribute connected" on R3 in the OSPF process?

That's the only way I got it working (see config below)

I saw examples where the redistribute connected is done in ISIS. Can that be correct?

R3

interface Loopback0

ip address 135.3.3.3 255.255.255.0

ip router isis

interface Serial0/1

ip address 135.3.10.3 255.255.255.0

ip router isis

clockrate 128000

router ospf 110

router-id 3.3.3.3

log-adjacency-changes

area 1 virtual-link 4.4.4.4

redistribute connected subnets

redistribute isis level-1-2 subnets

network 135.3.20.0 0.0.0.255 area 1

!

router isis

net 42.0013.0000.0000.3333.00

*****************************************

R1

interface Loopback0

ip address 135.1.1.1 255.255.255.0

ip router isis

!

interface Serial0

ip address 135.3.10.1 255.255.255.0

ip router isis

router isis

net 42.0013.0000.0000.1111.00

******************************************

R4 (OSPF router)

R4#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

135.1.0.0/24 is subnetted, 1 subnets

O E2 135.1.1.0 [110/20] via 135.3.20.3, 00:00:05, Serial0/0.1

135.3.0.0/16 is variably subnetted, 7 subnets, 3 masks

O E2 135.3.3.0/24 [110/20] via 135.3.20.3, 00:00:05, Serial0/0.1

O E2 135.3.10.0/24 [110/20] via 135.3.20.3, 00:00:05, Serial0/0.1

C 135.3.20.0/24 is directly connected, Serial0/0.1

O 135.3.20.3/32 [110/64] via 135.3.20.3, 00:13:15, Serial0/0.1

O 135.3.20.6/32 [110/64] via 135.3.20.6, 00:13:15, Serial0/0.1

C 135.3.70.0/24 is directly connected, Serial0/1

O IA 135.3.66.0/29 [110/74] via 135.3.20.6, 00:00:06, Serial0/0.1

R4#

255
Views
0
Helpful
3
Replies