Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Redistributing RIP / EIGRP

The scenario is that a Router has 3 interfaces sharing the subnets from the same major network. On 2 interfaces we want to run EIGRP and on the remaining interface RIP v 2. What happens this that the EIGRP subnets are leaked into the RIP as RIP learned routes rather than redistributed routes. Is there a way through which we can ontrol this situation?

7 REPLIES

Re: Redistributing RIP / EIGRP

Rip doesnt distinguish between external and internal routes like other protocols does ( like E2/E1 routes for OSPF, EX routes for EIGRP etc). So on this router, even if redistribution is done or not the subnet would still appear as an R route.

Silver

Re: Redistributing RIP / EIGRP

What you can do is redistribute and apply a route-map to only allow the routes you wish to be redistributed

router eigrp 1

redistribute rip metric 1 route-map controlroutes

route-map controlroutes 10

match ip address 1

access-list 1 permit x.x.x.x

New Member

Re: Redistributing RIP / EIGRP

You can use 'passive-interface' command to make the intreface stop sending eigrp update to rip.

Gold

Re: Redistributing RIP / EIGRP

So, I'm confused.... Do you have something like this?

interface e0

ip add 10.1.1.1 255.255.255.0

!

interface e1

ip add 10.1.2.1 255.255.255.0

!

router rip

network 10.0.0.0

!

router eigrp 100

network 10.0.0.0

And the rip routes are showing up in eigrp, or the eigrp routes are showing up in rip? Do you have redistribution configured between rip and eigrp? As someone else has stated on this this thread, rip has no concept of externals, they are all just routes.

Second, if the network statements are set up this way, there's no way to prevent rip from picking up the interfaces you want to run eigrp on, and not advertise them as rip routes. You can passive the interfaces, as someone else has suggested, but that won't keep rip from advertising these interfaces.

With eigrp, you can use the wildcard bits on the network statement to keep eigrp from advertising the interfaces, but there's no way to do this in rip. You could build a dsitribute list to block what you're advertising, but that won't help if you plan on redistributing the routes into ripfrom eigrp anyway.

I hope at least some of this helps.... Since I don't really understand what you are trying to do.

:-)

Russ.W

New Member

Re: Redistributing RIP / EIGRP

yeah i guess only you were able to understood the scenario. Because the problem is that e.g we configure it as

interface e0

ip add 10.1.1.1 255.255.255.0

!

interface e1

ip add 10.1.2.1 255.255.255.0

!

router eigrp 100

network 10.1.2.0 0.0.0.255

redistribute rip route-map FROMRIP

no auto-summary

router rip

network 10.0.0.0

redistribute eigrp 100 route-map FROMEIGRP

ver 2

no auto-summary

route-map FROMRIP deny 10

match tag 100

route-map FROMRIP permit 20

set tag 1

route-map FROMEIGRP deny 10

match tag 1

route-map FROMEIGRP permit 20

set tag 100

No matter whatever we try, the 10.1.2.0 network would appear in the RIP domain as RIP route and would not be tagged as an EIGRP route.

you are right..distribute list is gonna block the route altogether...but then I tried this command under rip

router rip

distribute-list 1 out RIP

access-list 1 deny 10.1.2.0 0.0.0.0

This command should effectively block this route from being advertised as RIP route ( becuase if we see the sh ip protocols commands , it says redistributing from rip, as well).

Now if this command was in place then the RIP should have advertised EIGRP redistributed route...but is stops advertising this route altogether..becuase as long as 10.1.2.0 is in the RIP database, its not gonna add a redistributed route...I guess this is the problem.

Because this thing could lead to route feedbacks beacause at EIGRP we will be filtering on tag 100 ..but this route wont have that tag...

Please comment on this..

I would like to tell one of my learned friends that Passive-interface doesnot stop rip to advertise the route.

2nd Approach

I also come accross a very interesting thing.

I removed the network command and configured..redistribute connected with a route-map....and tried to configure the neighbor command on the ethernet network in the RIP domain...the interesting thing is that it does not even show suppressing null update...so again it means that unless or untill network command is there RIP would never send updates across that interface

Re: Redistributing RIP / EIGRP

comment on 2nd approach:

Network command enables RIP on an interface. network x.x.x.x will enable rip on all those interfaces which fall under the network x.x.x.x. So if there is no network command under rip configured, it will not advertise or receive updates on any interface. Thats the reason why you are not seeing any output on debug ip rip.

passive-interface command stops RIP from advertising routes on an interface. That is true (your friend is right). But RIP will continue to hear (receive) updates on that interface.

Gold

Re: Redistributing RIP / EIGRP

Okay, I think I understand what you are trying to do now. You are correct in your analysis of the options. Note rip doesn't carry tags, so you can't count on them on that side of the network to stop the loops. But, if you tag the eigrp routes (they are getting tagged, right, when you use the config above?), and then filter on the tag when redistributing from eigrp into rip, you should be fine as far as routing loops go.

I've never been able to validate or build a routing loop with one side tagged, breaking half the loop. You might get transients, but you're going to get that anyway with RIP. And you might get suboptimal routing, too.

Russ

303
Views
0
Helpful
7
Replies
CreatePlease login to create content