Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

redistributing static routes in OSPF

We have several routers running OSPF in area 0. These routers are redistributing static routes pointing to remote networks belonging of each of them. Ok all routers know remote networks of other routers by OSPF.

We have been testing and if you shutdown an interface (there are routes with remote ip address as next-hop), OSPF routers remains with this route in its routing table.

Why this routes remains in OSPF routers routing table if its router interface is down? What I´m doing wrong? Here´s OSPF configuration in one OSPF router:

log-adjacency-changes

summary-address 211.1.2.0 255.255.255.0

summary-address 211.1.3.0 255.255.255.0

summary-address 211.1.7.0 255.255.255.0

redistribute connected subnets

redistribute static metric-type 1 subnets

network 128.11.80.6 0.0.0.0 area 0

network 192.168.50.6 0.0.0.0 area 0

ip route 2.2.2.1 255.255.255.255 211.1.4.2

ip route 2.2.2.2 255.255.255.255 211.1.1.2

ip route 2.2.2.3 255.255.255.255 211.1.8.2

ip route 2.2.2.4 255.255.255.255 211.1.2.2

ip route 2.2.2.5 255.255.255.255 211.1.2.46

ip route 2.2.2.6 255.255.255.255 211.1.2.22

ip route 2.2.2.7 255.255.255.255 211.1.7.10

ip route 2.2.2.9 255.255.255.255 211.1.2.6

ip route 2.2.2.10 255.255.255.255 211.1.2.70

ip route 2.2.2.11 255.255.255.255 211.1.2.66

ip route 2.2.2.12 255.255.255.255 211.1.2.54

ip route 2.2.2.14 255.255.255.255 211.1.2.98

ip route 2.2.2.15 255.255.255.255 211.1.2.110

ip route 2.2.2.16 255.255.255.255 211.1.2.50

ip route 2.2.2.17 255.255.255.255 211.1.2.138

ip route 2.2.2.18 255.255.255.255 211.1.7.6

ip route 10.0.1.0 255.255.255.0 211.3.4.18

ip route 10.210.0.0 255.255.255.224 211.1.2.90

ip route 10.210.0.32 255.255.255.224 211.1.2.122

ip route 10.210.0.64 255.255.255.224 211.1.2.126

ip route 10.210.0.96 255.255.255.224 211.1.2.130

ip route 10.210.0.128 255.255.255.224 211.1.2.134

ip route 128.17.1.0 255.255.255.0 211.1.2.2

ip route 128.17.2.0 255.255.255.0 211.1.2.6

ip route 128.17.3.0 255.255.255.0 211.1.2.14

ip route 128.17.4.0 255.255.255.0 211.1.2.10

ip route 128.17.6.0 255.255.255.0 211.1.2.38

ip route 128.17.8.0 255.255.255.0 211.1.2.66

ip route 128.17.9.0 255.255.255.0 211.1.7.6

ip route 128.17.10.0 255.255.255.0 211.1.2.26

ip route 128.17.15.0 255.255.255.0 211.1.2.30

ip route 128.17.24.0 255.255.255.0 211.1.2.106

ip route 128.17.90.0 255.255.255.0 211.1.2.58

ip route 128.17.91.0 255.255.255.0 211.1.2.42

ip route 128.25.0.0 255.255.0.0 211.1.8.2

ip route 128.169.0.0 255.255.0.0 211.3.4.30

ip route 128.190.0.0 255.255.0.0 211.1.7.10

ip route 128.192.1.0 255.255.255.0 211.1.7.14

ip route 128.211.0.0 255.255.0.0 211.1.7.6

ip route 128.213.0.0 255.255.0.0 211.1.7.6

ip route 133.17.2.0 255.255.255.0 211.1.2.22

ip route 133.17.4.0 255.255.255.0 211.1.2.62

ip route 137.15.0.0 255.255.0.0 211.1.2.70

ip route 137.17.3.0 255.255.255.0 211.1.2.50

ip route 137.92.0.0 255.255.0.0 211.1.2.98

ip route 154.37.1.0 255.255.255.0 211.1.1.2

ip route 154.37.2.0 255.255.255.0 211.1.2.34

ip route 158.17.90.0 255.255.255.0 211.1.2.54

ip route 159.90.1.0 255.255.255.0 211.1.2.78

ip route 159.90.2.0 255.255.255.0 211.1.3.2

ip route 161.17.1.0 255.255.255.0 211.1.2.94

ip route 161.17.90.0 255.255.255.0 211.1.2.114

ip route 161.17.91.0 255.255.255.0 211.1.2.138

ip route 164.90.1.0 255.255.255.0 211.1.2.74

ip route 164.90.2.0 255.255.255.0 211.1.2.110

ip route 176.17.2.0 255.255.255.0 211.1.2.82

ip route 176.50.0.0 255.255.0.0 211.1.7.2

ip route 176.90.0.0 255.255.0.0 211.1.2.102

ip route 180.17.1.0 255.255.255.0 211.1.2.86

ip route 183.91.0.0 255.255.0.0 211.1.2.74

ip route 200.200.200.0 255.255.255.0 211.1.4.2

2 REPLIES
Gold

Re: redistributing static routes in OSPF

What type of interface? How are you shutting it down? How long are you waiting to see if the routes leave the routing table? We will need more information than this--it's probably best as a TAC case.

Russ

New Member

Re: redistributing static routes in OSPF

Your static routes are pointing to an IP address. If after shutting the interface, the router still has a route to the destination IP (perhaps there's a more general route somewhere) then the static route is still valid. Try making your routes point to the interface. Example: ip route 1.2.3.0 255.255.255.0 ser 0. This way when the interface is down, the route will no longer be valid.

193
Views
5
Helpful
2
Replies
CreatePlease login to create content