Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

redistribution between ospf and rip2

Hi All,

I am tring to mutual redistribute ospf and rip2 with tag, but it doesn't work. from RIP side I can see the ospf routes, but at ospf side I can't see any routes from RIP. Could someone figure out what's wrong in my configuration. Thanks a lot.

interface Loopback0

ip address 150.50.6.6 255.255.255.255

!

interface Ethernet0

ip address 150.50.100.6 255.255.255.0

!

interface Serial0

ip address 150.50.10.6 255.255.255.0

encapsulation frame-relay

ip ospf network point-to-point

frame-relay map ip 150.50.10.2 421 broadcast

frame-relay map ip 150.50.10.6 421

frame-relay lmi-type ansi

!

router ospf 1

log-adjacency-changes

redistribute rip subnets route-map rip-os

network 150.50.6.6 0.0.0.0 area 0

network 150.50.10.0 0.0.0.255 area 0

!

router rip

version 2

redistribute ospf 1 metric 1 route-map os-rip

passive-interface default

no passive-interface Ethernet0

network 150.50.0.0

!

route-map os-rip deny 10

match tag 120

!

route-map os-rip permit 20

set tag 110

!

route-map rip-os deny 10

match tag 110

!

route-map rip-os permit 20

set tag 120

5 REPLIES
Gold

Re: redistribution between ospf and rip2

You can't use the tags on the rip to ospf side--rip doesn't carry tags, so the result would probably be that no routes carry from rip into ospf. Second, you probably need a default metric on the ospf side, to carry from rip into ospf. This isn't always required, but it's always safe to put it in.

So, I'd try this:

route-map ospftorip deny 10

match tag 110

route-map ospftorip permit 20

!

route-map riptoospf permit 10

set tag 110

!

router rip

version 2

redistribute ospf 1 metric 1 route-map ospftorip

....

!

router ospf 1

network ....

redistribute rip subnet route-map riptoospf

default-metric 10

....

I can set up a sample config in the lab if this doesn't work, or you're still having problems.

Russ.W

New Member

Re: redistribution between ospf and rip2

Hi Russ,

Thanks for your reply. You solution is working.

But I have little bit confusing. Cause from Jeff Doyle's Routing TCP/IP Volume 1, it say RIP v2 does support route tag.

BTW, which version ios you use in your lab.

Banlan

Gold

Re: redistribution between ospf and rip2

Hmm.... RIPv2 does support tags--it's in the protocol extensions section of 2453. So, I went to the code to see if Cisco supports this, and it looks like we do.

So, then, I went to the lab, and checked, and I see that you can set and filter based on the tags in rip:

On the first router:

router rip

version 2

redistribute connected route-map testtag

network 208.0.7.0

default-metric 10

no auto-summary

!

route-map testtag permit 10

set tag 100

!

2651A#sho ip rip data

208.0.0.0/24 auto-summary

208.0.0.0/24 redistributed

[1] via 0.0.0.0,

208.0.7.0/24 auto-summary

208.0.7.0/24 directly connected, Serial0/0

On the second:

!

router eigrp 100

redistribute rip route-map testtag

network 208.0.6.0

default-metric 1000 1 255 1 1500

auto-summary

!

router rip

version 2

network 208.0.7.0

no auto-summary

!

route-map testtag permit 10

match tag 100

!

route-map testtag deny 20

7206F#sho ip eigrp topo

IP-EIGRP Topology Table for AS(100)/ID(208.0.10.4)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

r - reply Status, s - sia Status

P 208.0.0.0/24, 1 successors, FD is 2560256, tag is 100

via Redistributed (2560256/0)

P 208.0.6.0/24, 1 successors, FD is 281600

via Connected, Ethernet1/2

Note the tag in the eigrp table entry for the 208.0.0.0 network.

So, that means that you should be able to do this, and something else is wrong with your configs above. They look okay except for the missing default metric under ospf, so maybe that's the main problem, not the tags.

Could you try it with the default metric command under router ospf, and see if that works?

Check the routing table on your rip routes, and see if the tag is set there, on the receiving router, without the redsitribution. And make certain any intervening routers are set up right for this, as well.

It might well be the IOS version, I'm on 12.2T in my lab, throughout, so.... It might be that these tags were carried, but not supported for filtering, until the rip database work was done, which was only about a year or 18 months ago, I think. I'd have to go look--rip isn't a protocol I keep up with too much (obviously).

:-)

Russ.W

New Member

Re: redistribution between ospf and rip2

Hi Russ,

It seems an IOS problem. I change to another router which is running 12.1(16) C2500-I-L, it's working. My previous one is 12.2(1d) C2500-JK8OS-L.

I am trying to find a best way to do mutual redistribution, could you refer me some good links. Real appreciate your help.

Regards

Banlan

Gold

Re: redistribution between ospf and rip2

It is very possible that some versions will not require the default metric to work--did you try with a metric on the 12.2 version? It could also be a bug in the code (sorry, undoc'd feature, if you're talking to an SE). :-)

Anyway, it sounds like you have the config down. I don't have any real good tech tips or links into stuff on mutual redistribution. There are some slides in the eigrp networkers presentation for the last couple of years that talks about this in terms of EIGRP only, and there are some slides in the igp power session from this year's networkers.

There'll be a good solid section in the rewrite of Advanced IP Network Design (just under way, should be published june of 2004 or so, I think). There's some int he current edition of Advanced IP Network Design, but I don't recall how much. I can also put a tech tip on this on my list of things to do.

But of course none of that is going to help you right at the moment. :-( If you email me, I can poke around some more, and see what I can find in the way of stuff to point you to.

Russ.W

248
Views
0
Helpful
5
Replies