Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Redistribution from EIGRP to OSPF

Just looking for some confirmation for my brain on this one.

Let's say you have a network running OSPF on one side, and EIGRP on the other. There are two points of redistribution (for redundancy, lets call them ASBR1 and ASBR2) performing mutual redistribution (EIGRP into OSPF, and OSPF into EIGRP). This is controlled via distribution lists both ways to ensure OSPF sourced routes are not picked up in EIGRP and redistributed back into OSPF, etc, etc...

Let's say we add a static route in EIGRP and redistribute that. It becomes an external EIGRP route with an admin distance of 170 (along with the OSPF derived routes). We pick this up on the ASBR's, and happily redistribute this route into OSPF with it's default admin distance of 110.

Here's where the problem begins (i think)

Now we have an EIGRP static route floating around EIGRP with an admin distance of 170, and the same route floating around OSPF with an admin distance of 110. Due to OSPF's link state database, each point of redistribution MUST know about the other, hence these ASBR's both see the EIGRP sourced route, AND each others redistributed OSPF route for the same network, except now the OSPF route is preferred due to it's lower admin distance.

Does this make sense? Seems to only be a problem redistributing EIGRP external routes into OSPF, however there doesn't seem to be much info on it, and it seems to me this would be a fairly well documented issue. I've checked all the redistribution dox and not one mentions this could be a potential problem.

Solution:

Use the distance command on each ASBR raising the admin distance on those EIGRP static networks to something higher than 170 so they prefer their EIGRP routes.

ie. ASBR1 would have the distance command configured to raise the admin distance on all external routes coming from it's neighbor ASBR2.

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/ip_c/ipcprt2/1cdospf.htm#11650

Sound about right?

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Redistribution from EIGRP to OSPF

The filter_redist_eigrp needs to look something like this:

route-map filter_redist_eigrp deny 10

match tag 55

route-map filter_redist_eigrp permit 20

The rest looks good.

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
6 REPLIES
Cisco Employee

Re: Redistribution from EIGRP to OSPF

This is indeed an issue. The solution is as stated in the documentation you referred to, which is to raised the admin distance of OSPF external routes to something higher than 170. You have to be careful to to experience the same issue in the other direction if you redistribute external routes (coming from other sources than EIGRP) in EIGRP.

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Gold

Re: Redistribution from EIGRP to OSPF

Another option would be to tag the route coming into OSPF, and then filter the tagged routes from the local routing table on the other ASBR on the OSPF side. You can also tag the routes on the EIGRP side, and deny them on the other EIGRP redistribution router, as well. For the OSPF side, see:

http://www.cisco.com/en/US/products/sw/iosswrel/ps1829/products_feature_guide09186a008012db77.html

For EIGRP, see:

http://www.cisco.com/en/US/tech/tk365/tk207/technologies_tech_note09186a008009487e.shtml#ex3

Hope that helps....

:-)

Russ.W

Cisco Employee

Re: Redistribution from EIGRP to OSPF

Much better way indeed.

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Community Member

Re: Redistribution from EIGRP to OSPF

We've been looking at tagging for a while, so perhaps this is as good a time as any ;-)

This basically means I'll need both a redistribute route-map to tag/filter both BOTH protocols AND an inbound distribute-list on the OSPF interfaces to filter the redistributed EIGRP routes, right?

router ospf 1

redistribute eigrp 1 route-map eigrp_to_ospf subnets

distribute-list route-map filter_redist_eigrp in FastEthernet 0/0

!

router eigrp 1

redistribute ospf 1 route-map ospf_to_eigrp metric 1000 100 255 1 1500

!

route-map eigrp_to_ospf deny

match tag 44

route-map eigrp_to_ospf permit

set tag 55

!

route-map ospf_to_eigrp deny

match tag 55

route-map ospf_to_eigrp permit

set tag 44

!

route-map filter_redist_eigrp deny

match tag 55

Thanks for the confirmation and the additional info guys.

Cisco Employee

Re: Redistribution from EIGRP to OSPF

The filter_redist_eigrp needs to look something like this:

route-map filter_redist_eigrp deny 10

match tag 55

route-map filter_redist_eigrp permit 20

The rest looks good.

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Community Member

Re: Redistribution from EIGRP to OSPF

Whoops. You're right. Guess I'd have to allow the rest in wouldn't I.

Thanks again for the great info guys.

Muchos Gracias.

185
Views
12
Helpful
6
Replies
CreatePlease to create content