Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Redistribution of Static routes by Via RIP.

Hi,

i have 2 routers on a LAN. Router A and Router B.

I'm having problems redistributing a the static route 192.0.80.0 from router

"A" to router "B" via RIP.

Doing a "debug ip rip" on "B" shows RIP routes comming in but does not show

192.0.80.0 comming in.

Doing a "debug ip RIP" on "A" only says "sending v1 update to

255.255.255.255 via FastEthernet0/1 (192.168

.10.100)" - ie no specific info about whats being advertised.

Whats wrong?

Router "A" (12.2 - 2621)

interface FastEthernet0/1

ip address 192.168.10.100 255.255.255.0

load-interval 30

speed 100

full-duplex

no cdp enable

router rip

redistribute static

network 192.168.10.0

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.10.10

ip route 192.0.80.0 255.255.255.0 192.168.10.10

Router "B" (11.0 2501)

interface Ethernet0

ip address 192.168.10.105 255.255.255.0

router rip

network 192.168.10.0

ip route 0.0.0.0 0.0.0.0 192.168.10.10

2 REPLIES

Re: Redistribution of Static routes by Via RIP.

On router A, under router rip put default-metric 1 (or 2).

When you redistribute, you should always put default-metric (or the protocol won't understand the other redistributed protocol's metrics).

Hope it helps.

Steve

New Member

Re: Redistribution of Static routes by Via RIP.

Thanks for that Steve.

I tried that and it made no difference, However I did get it to work using another Topology.

I configured the serial interface on RouterA and connected it to a Frame Network. I changed the static route to point to a fictitious subnet out on the frame.

However a route pointing towards a gateway on the Ethernet side (a third router) still will not advertise for some reason. However I don't need pursue this.

98
Views
0
Helpful
2
Replies
CreatePlease login to create content