Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

redundance problem with two Cat.3550 (EMI)

Hello,

i have a problem with redundance between 2 Cat. 3550(EMI).

Below you can see my Configs:

Catalyst1 (Master)

vtp domain XXXX_VLANS

vtp mode transparent

!

vlan 1

tb-vlan1 1002

tb-vlan2 1003

vlan 2

vlan 3

vlan 4

vlan 5

vlan 6

vlan 7

vlan 8

vlan 98

vlan 99

vlan 1002

tb-vlan1 1

tb-vlan2 1003

!

vlan 1003

tb-vlan1 1

tb-vlan2 1002

!

vlan 1004

bridge 1

stp type ibm

cluster enable catalyst_cluster 0

!

!

spanning-tree extend system-id

spanning-tree vlan 1 priority 24576

spanning-tree vlan 2 priority 24576

spanning-tree vlan 2 hello-time 1

spanning-tree vlan 2 forward-time 7

spanning-tree vlan 2 max-age 10

spanning-tree vlan 3 priority 20480

spanning-tree vlan 4 priority 28672

spanning-tree vlan 4 hello-time 1

spanning-tree vlan 4 forward-time 7

spanning-tree vlan 4 max-age 10

spanning-tree vlan 5 priority 28672

spanning-tree vlan 5 hello-time 1

spanning-tree vlan 5 forward-time 7

spanning-tree vlan 5 max-age 10

spanning-tree vlan 6 priority 24576

spanning-tree vlan 6 hello-time 1

spanning-tree vlan 6 forward-time 7

spanning-tree vlan 6 max-age 10

spanning-tree vlan 7 priority 24576

spanning-tree vlan 7 hello-time 1

spanning-tree vlan 7 forward-time 7

spanning-tree vlan 7 max-age 10

spanning-tree vlan 8 priority 28672

spanning-tree vlan 8 hello-time 1

spanning-tree vlan 8 forward-time 7

spanning-tree vlan 8 max-age 10

spanning-tree vlan 99 priority 24576

!

!

!

interface Port-channel1

switchport access vlan 3

no ip address

interface FastEthernet0/2

switchport access vlan 2

switchport trunk encapsulation dot1q

no ip address

no cdp enable

!

interface FastEthernet0/3

switchport access vlan 2

switchport trunk encapsulation dot1q

no ip address

no cdp enable

!

interface FastEthernet0/4

switchport access vlan 3

no ip address

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/5

switchport access vlan 3

switchport trunk encapsulation dot1q

no ip address

no cdp enable

!

.

.

interface FastEthernet0/48

switchport access vlan 6

switchport trunk encapsulation dot1q

no ip address

no cdp enable

!

interface GigabitEthernet0/1

description Uplink to Catalyst2

switchport trunk encapsulation dot1q

switchport mode trunk

no ip address

no cdp enable

!

interface GigabitEthernet0/2

description Gigabit to 3Com-Switch

switchport access vlan 3

no ip address

no cdp enable

!

interface Vlan1

no ip address

no ip route-cache cef

shutdown

!

interface Vlan2

description xxxxxxxxxxxxxxxxx

ip address ..

no ip redirects

standby 2 ip xxx.xxx.xxx.xxx

standby 2 priority 105

standby 2 preempt

!

interface Vlan4

description

ip address ..

no ip redirects

standby 4 ip xxx.xxx.xxx.xxx

standby 4 priority 100

standby 4 preempt

!

interface Vlan5

description AL-Netz Zentrale

ip address ..

no ip redirects

standby 5 ip xxx.xxx.xxx.xxx

standby 5 priority 100

standby 5 preempt

!

interface Vlan6

description ALIS Pc-Netz

ip address ..

no ip redirects

standby 6 ip xxx.xxx.xxx.xxx

standby 6 priority 105

standby 6 preempt

!

interface Vlan7

description Transfernetz zwischen Router 3640 und Catalyst

ip address ..

no ip redirects

standby 7 ip xxx.xxx.xxx.xxx

standby 7 priority 105

standby 7 preempt

!

interface Vlan8

description AL-Netz mit Verbindung zum BT-Router

ip address ..

ip access-group 110 in

no ip redirects

standby 8 ip xxx.xxx.xxx.xxx

standby 8 priority 100

standby 8 preempt

!

interface Vlan98

description Testnet

ip address ..

no ip redirects

standby 98 ip xxx.xxx.xxx.xxx

standby 98 timers 4 20

standby 98 priority 105

standby 98 preempt

standby 98 track FastEthernet0/43 50

!

interface Vlan99

description TESTNETZ

ip address ..

no ip redirects

standby 255 ip xxx.xxx.xxx.xxx

standby 255 priority 105

standby 255 preempt

**********************************************************************************************

Catalyst2 (Backup)

vtp domain XXXX_VLANS

vtp mode transparent

!

vlan 1

tb-vlan1 1002

tb-vlan2 1003

!

vlan 2

vlan 3

vlan 4

vlan 5

vlan 6

vlan 7

vlan 8

vlan 98

vlan 99

vlan 1002

tb-vlan1 1

tb-vlan2 1003

!

vlan 1003

tb-vlan1 1

tb-vlan2 1002

!

vlan 1004

bridge 1

stp type ibm

cluster enable catalyst_cluster 0

!

!

spanning-tree extend system-id

spanning-tree vlan 1 priority 28672

spanning-tree vlan 2 priority 28672

spanning-tree vlan 2 hello-time 1

spanning-tree vlan 2 forward-time 7

spanning-tree vlan 2 max-age 10

spanning-tree vlan 3 priority 28672

spanning-tree vlan 4 priority 24576

spanning-tree vlan 4 hello-time 1

spanning-tree vlan 4 forward-time 7

spanning-tree vlan 4 max-age 10

spanning-tree vlan 5 priority 24576

spanning-tree vlan 5 hello-time 1

spanning-tree vlan 5 forward-time 7

spanning-tree vlan 5 max-age 10

spanning-tree vlan 6 priority 28672

spanning-tree vlan 6 hello-time 1

spanning-tree vlan 6 forward-time 7

spanning-tree vlan 6 max-age 10

spanning-tree vlan 7 priority 28672

spanning-tree vlan 7 hello-time 1

spanning-tree vlan 7 forward-time 7

spanning-tree vlan 7 max-age 10

spanning-tree vlan 8 priority 24576

spanning-tree vlan 8 hello-time 1

spanning-tree vlan 8 forward-time 7

spanning-tree vlan 8 max-age 10

spanning-tree vlan 99 priority 28672

!

!

!

interface Port-channel1

switchport access vlan 3

no ip address

!

interface FastEthernet0/1

no ip address

no cdp enable

!

interface FastEthernet0/2

switchport access vlan 2

switchport trunk encapsulation dot1q

no ip address

no cdp enable

!

interface FastEthernet0/3

switchport access vlan 2

switchport trunk encapsulation dot1q

no ip address

no cdp enable

!

interface FastEthernet0/4

switchport access vlan 3

no ip address

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/5

switchport access vlan 3

switchport trunk encapsulation dot1q

no ip address

no cdp enable

.

.

!

interface FastEthernet0/48

switchport access vlan 6

switchport trunk encapsulation dot1q

no ip address

no cdp enable

!

interface GigabitEthernet0/1

description Uplink to Catalyst1

switchport trunk encapsulation dot1q

switchport mode trunk

no ip address

no cdp enable

!

interface GigabitEthernet0/2

no ip address

no cdp enable

!

interface Vlan1

no ip address

shutdown

!

interface Vlan2

description

ip address ..

no ip redirects

standby 2 ip xxx.xxx.xxx.xxx

standby 2 priority 100

standby 2 preempt

!

interface Vlan4

description

ip address ..

no ip redirects

standby 4 ip xxx.xxx.xxx.xxx

standby 4 priority 105

standby 4 preempt

!

interface Vlan5

description

ip address ..

no ip redirects

standby 5 ip xxx.xxx.xxx.xxx1

standby 5 priority 105

standby 5 preempt

!

interface Vlan6

description

ip address ..

no ip redirects

standby 6 ip xxx.xxx.xxx.xxx

standby 6 priority 100

standby 6 preempt

!

interface Vlan7

description

ip address ..

no ip redirects

standby 7 ip xxx.xxx.xxx.xxx

standby 7 priority 100

standby 7 preempt

!

interface Vlan8

description

ip address ..

ip access-group 110 in

no ip redirects

standby 8 ip xxx.xxx.xxx.xxx

standby 8 priority 105

standby 8 preempt

!

interface Vlan98

description

ip address ..

no ip redirects

standby 98 ip xxx.xxx.xxx.xxx

standby 98 timers 4 20

standby 98 priority 110

standby 98 preempt

standby 98 track FastEthernet0/43 50

!

interface Vlan99

description

ip address ..

no ip redirects

standby 255 ip xxx.xxx.xxx.xxx

standby 255 priority 100

standby 255 preempt

!

The Catalyst 1 works fine without the Catalyst 2.

If I start the Catalyst 2 and connect both catalyst together over

the Gigabit-Port, i recive Messages below:

3w2d: STP: VLAN0005 sent Topology Change Notice on Fa0/33

3w2d: STP: VLAN0005 Gi0/1 -> blocking

3w2d: STP: VLAN0003 Topology Change rcvd on Fa0/5

3w2d: STP: VLAN0003 Topology Change rcvd on Fa0/5

3w2d: STP: VLAN0003 Topology Change rcvd on Fa0/5

3w2d: STP: VLAN0003 Topology Change rcvd on Fa0/5

3w2d: STP: VLAN0003 Topology Change rcvd on Fa0/5

3w2d: STP: VLAN0003 Topology Change rcvd on Fa0/5

3w2d: STP: VLAN0003 Topology Change rcvd on Fa0/5

3w2d: STP: VLAN0003 Topology Change rcvd on Fa0/5

3w2d: STP: VLAN0005 new root port Gi0/1, cost 59

3w2d: STP: VLAN0005 Gi0/1 -> listening

3w2d: STP: VLAN0005 heard root 24581-000b.be04.8f80 on Gi0/1

3w2d: STP: VLAN0003 Topology Change rcvd on Fa0/5

3w2d: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/33, changed state to down

3w2d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan5, changed state to down

3w2d: %STANDBY-6-STATECHANGE: Standby: 5: Vlan5 state Active -> Init

3w2d: STP: VLAN0005 sent Topology Change Notice on Gi0/1

3w2d: STP: VLAN0005 heard root 24581-000b.be04.8f80 on Gi0/1

3w2d: STP: VLAN0005 heard root 24581-000b.be04.8f80 on Gi0/1

3w2d: %SPANTREE-7-RECV_1Q_NON_TRUNK: Received 802.1Q BPDU on non trunk FastEthernet0/5 VLAN3.

3w2d: %SPANTREE-7-BLOCK_PORT_TYPE: Blocking FastEthernet0/5 on VLAN0003. Inconsistent port type.

3w2d: STP: VLAN0005 sent Topology Change Notice on Gi0/1

3w2d: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/33, changed state to up

3w2d: STP: VLAN0005 heard root 24581-000b.be04.8f80 on Gi0/1

3w2d: STP: VLAN0001 new root port Fa0/33, cost 55

3w2d: STP: VLAN0003 Topology Change rcvd on Fa0/5

3w2d: STP: VLAN0003 Topology Change rcvd on Fa0/5

3w2d: STP: VLAN0005 sent Topology Change Notice on Gi0/1

3w2d: STP: VLAN0005 heard root 24581-000b.be04.8f80 on Gi0/1

3w2d: STP: VLAN0003 Topology Change rcvd on Fa0/5

At this moment the catalyst are in loop i think.

If I disconnect the both catalyst, the catalyst 1 works

fine again.

Can anybody help me

  • Other Network Infrastructure Subjects
5 REPLIES
Silver

Re: redundance problem with two Cat.3550 (EMI)

The error messages suggest that the interface has an inconsistent port type and is being held in a spanning-tree blocking state until the port type inconsistency is resolved.

Verify that the configuration and operational state of the listed interface and that of the interface to which it is connected have the same mode (access or trunk). If the mode is trunk, verify that both interfaces use the same encapsulation (ISL or 802.1Q). When these parameters are consistent, spanning tree will automatically unblock the interfaces.

Hope this resolves the issue.

New Member

Re: redundance problem with two Cat.3550 (EMI)

Dear Member,

first off all, very much for your Help.

Could you tell me, whether i have to allowed or disallowed Vlans for Trunks?

Thanks for your Help

New Member

Re: redundance problem with two Cat.3550 (EMI)

Hello,

I'am suprised about your configuration for the port fa0/5

interface FastEthernet0/5

switchport access vlan 3

switchport trunk encapsulation dot1q

If it's a trunked port, why haven't you got the line "switchport mode trunk" <- ?

Secondly, it seems that you have a loop when you connect catalyst 1 and 2 behind gi0/1 and behind fa0/5 -> topology changes.

Is it normal ?

Regards.

New Member

Re: redundance problem with two Cat.3550 (EMI)

Hello,

on the Ports fa0/5 are be connected a 3 Com Switch with one Cable in each

Switch.

The catalyst are connected together over the gi0/1.

My goal is it to attach a SWITCH to both Catalyste (Redundance).

I do not know, which is the correct Configuration for this.

Best Regards

New Member

Re: redundance problem with two Cat.3550 (EMI)

You should have a VTP server. I suggest making both VTP servers since this is a high-availability model. All other switches should be VTP clients. Make sure you have the same VTP domain on the other switches.

Note: if both are VTP server then you must add, change and remove VLANS from both. Use the "vlan database" command (from exec mode) to manage VTP.

This appears to be PVST (default). If you decide to do MST set your revision number on the primary to the highest revision number and set the rev on the secondary to the second highest. Make sure your revs are set well above any other connected switch.

Don't try to trunk to a 3com switch. Eliminate the encapsulation and simply use the switchport access vlan 3 method. One of the 3550's will block on port fa0/5 because this is a loop. Do not enable portfast on fa0/5.

As someone already mentioned do not use switchport access on trunk ports. This can cause CAM flapping by advertising MAC addresses across multiple VLANS if you run fastetherchannel with trunking. You need to remove the "switchport access vlan X" from any trunk interfaces. Use the "switchport trunk native vlan X" statement instead. You must also include the "switchport mode trunk" statement.

If you decide to replace the 3com with a 3550 12G you would want the 12G to be spanning tree root and the primary 3550-EMI secondary root, and so on. Otherwise if the root is the 3550-EMI the other 3550-EMI will block the 12G uplink.

Why are you using the 3com to bridge these together? Do you have clients or servers hanging off the 3com switch on VLAN 3?

265
Views
0
Helpful
5
Replies
This widget could not be displayed.