Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Redundant Route

I have a Cisco 1721 router. The S0 int. connects to my intranet 192.168.104.1

The Fa0 int, connects to the internet. Is it possible to get the router to detect if the internet goes down to redirect the traffic back out the S0 port to another router in the network that has a separate internet connection?

Any suggestions and configs would be greatly appreciated.

Thanks

Dale

7 REPLIES

Re: Redundant Route

You mean when the interface goes down, right? Or the device connecting to the fa0 goes down? You can do floating static route pointing the serial interface with a slighty higher distance metric than the route to fa0 if and when the interface fa0/1 ever goes down.

something like:

ip route 0.0.0.0 0.0.0.0 interface serial

New Member

Re: Redundant Route

Thanks, I will try this and let you know

New Member

Re: Redundant Route

Ok that didn't work for some reason. I put in the route

ip route 0.0.0.0 0.0.0.0 interface serial0 254

and when I shut down the fa0 interface I never regained internet activety.

I can ping the router I need to get to from this router, but when the interface went down nothing happened.

The router I'm on has the following int configs

fa0 69.146.108.59 255.255.255.248

S0 192.168.104.1 255.255.255.0

the router that points at this

S0 192.168.104.2 255.255.255.0

fa0 10.6.18.8 255.255.255.0

The other internet router is

fa0 10.6.18.4

How do I get the first router to get to this router should the first routers internat connection go down?

Thanks Dale

ip route 0.0.0.0 0.0.0.0 69.146.108.57

The router I'm trying to get to

Purple

Re: Redundant Route

Hi Dale,

To make that work, you will need to use the reliable static route backup feature...

Try something like this...

Replace with an IP that you can ping through your main link - preferably the ISP side of the WAN link address.

interface FastEthernet 0

description Primary Link

ip address 10.1.1.1 255.0.0.0

!

interface Serial0:1

ip address 192.168.104.1 255.0.0.0

!

rtr 1

type echo protocol ipIcmpEcho

timeout 1000

frequency 3

threshold 2

!

rtr schedule 1 life forever start-time now

!

track 100 rtr 1 reachability

!

access list 101 permit icmp any host echo

!

route map LOCAL_POLICY permit 10

set ip next-hop 10.1.1.254 ! set this to the ISP side address of your WAN link

set interface null0

!

ip local policy route-map LOCAL_POLICY

!

ip route 0.0.0.0 0.0.0.0 10.1.1.254 track 100

ip route 0.0.0.0 0.0.0.0 Serial0 254

Hope that helps - pls rate the post if it does.

Paresh

New Member

Re: Redundant Route

Thanks, I won't get to run this until tomorrow. But if it works I will rate your post asap.

New Member

Re: Redundant Route

Paresh,

Apparently my router isn't capable of this. It's a 1721 running version 12.3<6>.

I'm not able to do anything with the rtr 1,,type echo... etc.

any other ideas for a simpler IOS

Thanks

Dale

New Member

Re: Redundant Route

So your fast-E interface is on the outside and your Serial is on the inside? Hmmm...perhaps turning on keepalives and simple interface line protocol tracking might work; something like:

interface fa0

keepalive

!

track 1 int fa0 line-protocol

...then run HSRP between your two routers' inside interfaces; I've never done it across serial interfaces, but as long as they are layer-2 adjacent, I would think it would work; something like:

interface s0

ip address

standby 1

standby 1 priority 105

standby 1 track 1 decrement 10

...the other router would look similar, except for the real IP of course. You can choose to track its outside interface or not. Better yet, if both links are available, asymmetric routing is of no concern and there are many inside hosts going out to the Internet, look into GLBP instead of HSRP.

129
Views
3
Helpful
7
Replies
CreatePlease to create content