Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Reverse telnet out the AUX port to the modem

I am tring to telnet to a modem connected to an aux

port (2600).

I am getting "Connection refused by remote host" message. Thanks for the help in advance...

Here is the output

Router#telnet 172.17.1.1 2065

Trying 172.17.1.1, 2065 ...

% Connection refused by remote host

========================================

Here is the config:

Router#sh run

Building configuration...

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router

!

enable password admin

!

username admin password 0 admin

memory-size iomem 30

ip subnet-zero

chat-script Dialout ABORT ERROR ABORT BUSY "" "AT" OK "ATDT \T" TIMEOUT 45 CONNECT \c

modemcap entry MY_USR_MODEM:MSC=&F1S0=1

!

!

!

interface Loopback0

ip address 172.17.1.1 255.255.255.0

no ip directed-broadcast

!

interface TokenRing0/0

no ip address

no ip directed-broadcast

shutdown

ring-speed 16

!

interface Async65

no ip address

no ip directed-broadcast

!

interface Group-Async0

physical-layer async

no ip address

no ip directed-broadcast

no group-range

!

ip classless

!

!

line con 0

transport input none

line aux 0

exec-timeout 0 0

script dialer Dialout

modem InOut

modem autoconfigure type MY_USR_MODEM

transport input all

stopbits 1

speed 115200

flowcontrol hardware

line vty 0 4

password admin

login

!

end

====================================

Router#sh line 65

Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns Int

* 65 AUX 115200/115200- inout - - - 0 1 0/1295333 -

Line 65, Location: "", Type: ""

Length: 24 lines, Width: 80 columns

Baud rate (TX/RX) is 115200/115200, no parity, 1 stopbits, 8 databits

Status: Ready, Active, No Exit Banner, Input Stopped

Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out

Modem Callout, Modem RI is CD, Modem Autoconfigure

Modem state: Ready

Modem hardware state: CTS* DSR* DTR noRTS

TTY NUMBER 65

Parity Error = 0 Framing Error = 0 Receive Error = 0 Overrun = 0

Outcount = 0 totalout = 3371780 incount = 2000 totalin = 3371780

Special Chars: Escape Hold Stop Start Disconnect Activation

^^x none - - none

Timeouts: Idle EXEC Idle Session Modem Answer Session Dispatch

never never none not set

Idle Session Disconnect Warning

never

Login-sequence User Response

00:00:30

Autoselect Initial Wait

not set

Modem type is MY_USR_MODEM.

Session limit is not set.

Time since activation: 00:38:23

Editing is enabled.

History is enabled, history size is 10.

DNS resolution in show commands is enabled

Full user help is disabled

Allowed transports are pad v120 telnet rlogin. Preferred is telnet.

No output characters are padded

No special data dispatching characters

Router#

========

4 REPLIES
New Member

Re: Reverse telnet out the AUX port to the modem

Try clearing the line first.. "clear line 65" couple of times and then try the telnet again..

-JJ

New Member

Re: Reverse telnet out the AUX port to the modem

clear line 65 many times.. still no love

New Member

Re: Reverse telnet out the AUX port to the modem

The modem is setting DSR constantly, which makes the port unavailable for telnet (even after you enter the "clear line" command). Try adding the command "no exec" to the AUX port, you should be able to get into the modem. Then see if the modem is configured to set DCD high all the time. It should only set DCD when it has a connection to the network (i.e. it's dialed up).

Michael J. Morris

CCNP, CCDA, MCSE, MCP+I

New Member

Re: Reverse telnet out the AUX port to the modem

Thanks Guys...

It worked.

Jebi

951
Views
0
Helpful
4
Replies
CreatePlease to create content