Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Reverse Telnet

Hi,

I am trying to toubleshoot a Router dialup connection where a user dails into the router to connect to the the Corporate network.

The User gets an error msg " remote computer didnot respond " when he tries to connec the router through a modem connected to the cisco 2600 async interface.whe i tried to reverse telnet to the Modem, the connection opens but junk characters keep coming and the modem don't respond to AT commands.I tried changing the speed in Line config mode.

When i tried calling the phone number of the Modem( Router end), i get a continous ring and the modem don't respond.

Pls suggest how i go about this.

regds

Ravi Reddy

4 REPLIES
Bronze

Re: Reverse Telnet

Hi Ravi,

try "debug confmodem" and configure the line that the modem is connected to with either "modem autoconfigure type " (where is the modemtype as listed by show modemcap) or "modem autoconfigure discovery" (if your modem type is not listed).

See also:

http://www.cisco.com/en/US/customer/tech/tk801/tk36/technologies_tech_note09186a008009428b.shtml

hth

Herbert

New Member

Re: Reverse Telnet

Hi Herbert,

Thanks for the reply.I tried as you said and the output for debug is as follows.I treid with some other Modem also.But these 2 modems are working fine when connected to a PC( connect to ISP).

And in Sh Line 2 , the modem status shows as

Modem hardware state: CTS noDSR DTR noRTS.

Could there be any problem with Hardware of Interface card( no RTS) or the Cable connecting the Router to Modem.Config in Line mode as follows.

line 2

modem InOut

modem autoconfigure discovery

autocommand ppp

transport input all

flowcontrol hardware

1d03h: TTY2: autoconfigure probe started

1d03h: TTY2: detection speed (115200) response U3-

1d03h: TTY2: detection speed (57600) response ---U3-

1d03h: TTY2: detection speed (38400) response ---U3-

1d03h: TTY2: detection speed (19200) response--U3---

1d03h: TTY2: detection speed (9600) response--U3---

1d03h: TTY2: detection speed (2400) response ---U3-

1d03h: TTY2: detection speed (1200) response ---U3--

1d03h: TTY2: detection speed (300) response ---U3---

1d03h: TTY2: No modem found

Pls suggest.

Thanks & Regards

Ravi Reddy M

Bronze

Re: Reverse Telnet

Strange. Is it a "Hayes compatible" modem, does it support AT commands?

Things I would try: connect the modem to a PC and fix the modem speed (maybe also the flowcontrol), then configure the line with this speed (and flowcontrol).

Herbert

New Member

Re: Reverse Telnet

Hi Herbert,

I am happy to inform you that the problem is solved.I connected the Modem on a different Interface(Int s0/0) with ths same configuration & modem and it started working.

After that i configured this interface(Int S0/1) as sync interface and connected a Leased line RAD modem.The moment the cable(V.35) is connected to the interface, the router seems to be hanging and i lose connectivity on the Leased Line (S0/2).

I am 500Miles away from the place where the problem is and am trying to troubleshoot it through telnet.The Cisco 2610 router with 1 Serial and 2 low speed Sync/Async interfaces.2 Leased lines and one Router dialup.Now one LL is down as i am using this interface(S0/0) for Router Dial-up.

Could this be a Hardware problem.If so how can i confirm.Any of the show commands help in this.

Pls Suggest.Thanks once again for the help.

Thanks & Regards

Ravi Reddy M

387
Views
0
Helpful
4
Replies
CreatePlease login to create content