Cisco Support Community
Community Member

RIP and IGRP is not working with (4) 2501 lab setup

I am having problem setting up (4) 2501 router in my lab. I cannot get dynamic routing to work. I can put static routing and it will work, but I wanted to know what I missed. I follow instruction from cybex ccna book and still not working. Like I said, I might overlooked something in my configuration.

I've tried to check on it for the las 12 hours and cannot find anything. Maybe everyone here can give me a hand... Please !!!

Here are a link to my lab diagram and some information from each of the router

Thank you


Cisco Employee

Re: RIP and IGRP is not working with (4) 2501 lab setup


I checked your configurations on the routers. Everything looks perfect except one thing, i e enabling IGRP routing protocol for a IP network. You have added which is a class C network. It has mask of /24, so IGRP is enabled only for network and not for the networks which you have configured in youe setup.

So go ahead and configure all individual networks in IGRP like,, and so on. And your dynamic routing will work fine.

If this doesn't work, please let me know.

Community Member

Re: RIP and IGRP is not working with (4) 2501 lab setup

Thank you so much...... Now I understand what is wrong with my configuration. The book used network 172.16.X.0 for their configuration. When they change from static to dynamic, they enter network

Now I realize that is a class B network that is why it works, and my network is using 192.168.X.0 and it is a class C network. That is why I have to enter every single network in my dynamic config. Thanks a lot......

CreatePlease to create content