Cisco Support Community
Community Member

RIP behaviour in release 12.1


I want to raise a strange issue. I was trying to configure RIP on a customers site using a 2501 series Router running 12.1 19 IOS release. While debugging I cam across an interesting behaviour by RIP. The routes were not being put into holddown upon topology change. If you bring up the down interface,a triggered update is sent and the route immediately resurfaces in the peer router. I tried it with IGRP but in that case it was exibiting the usual normal behaviour. I tried to check the Cisco Website but couldnt find any changes in RIP operation. It seems as if they have made RIP compliant with the RFC. If you see the sh ip proto command it still shows the hold-down timer as 180 seconds.


Re: RIP behaviour in release 12.1

I have tried this with IOS releases earlier and later than 12.1 also and discovered that when an interface is brought down manually (using the shutdown command ), then a flash update is sent immediately without the route going into holddown. The same is the case when a down route is brought up manually. However my guess is that the hold down feature would work in other cases and I don't think the behaviour of RIP has changed.

CreatePlease to create content