Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

RIP on 3750 switch

Hi,

do you think that this configuration will work.

atalyst3750#vlan data

Catalyst3750(config-vlan)# vlan 2 name Head Office

Catalyst3750(config-vlan)# vlan 9 name BR

Catalyst3750(config-Vlan)# vlan 204 name AppSrv

Catalyst3750(config)# int vlan 2

Catalyst3750(config)#ip address 10.170.2.1 255.255.255.0

Catalyst3750(config)#int vlan 9

Catalyst3750(config)#ip address 10.170.9.1 255.255.255.0

Catalyst3750(config)#int vlan 204

Catalyst3750(config)#ip address 204.4.4.56 255.255.255.0

Catalyst3750(config)#int gig1/0/1

Catalyst3750(config-if)#switchport mode access

Catalyst3750(config-if)#switchport access vlan 2

Catalyst3750(config)#int gig1/0/2

Catalyst3750(config-if)#switchport mode access

Catalyst3750(config-if)#switchport access vlan 204

Catalyst3750(config)#int gig1/0/20

Catalyst3750(config-if)#switchport mode access

Catalyst3750(config-if)#switchport access vlan 9

Catalyst3750(config)# ip routing

Catalyst3750(config)#router rip

Catalyst3750(config-router)#network 10.170.2.0

Catalyst3750(config-router)#network 10.170.9.0

Catalyst3750(config-router)#network 204.4.4.0

4 REPLIES
Silver

Re: RIP on 3750 switch

I am not shure why you are enabling dymic routing, since all the networks are directly connected.

Yes, RIP will run on networks 10.0.0.0 and 204.4.4.0. If you require RIP to propagate your roouting information I would suggest you switch to RIPv2.

Catalyst3750(config)#router rip

Catalyst3750(config-router)#version 2

Catalyst3750(config-router)#network 10.170.2.0

Catalyst3750(config-router)#network 10.170.9.0

Catalyst3750(config-router)#network 204.4.4.0

HTH

Leon

* Please rate posts.

Re: RIP on 3750 switch

yes its look okay...

just use rip verison 2 and make sure you have configured ip routing thats it

regards

Devang

Re: RIP on 3750 switch

Also dont forget to use "no auto-summary"

vlad

Gold

Re: RIP on 3750 switch

Along with the above 2 suggestion you should also only run rip on the interfaces you actually have other routers that you are going to exchange routing with.

The simple way to do this is put in

PASSIVE INTERFACE DEFAULT

No PASSIVE INTERFACE VLAN...

For example if your vlan 204 only contains servers it only wastes bandwidth to send out updates and if a misconfigured server sent you a rip route you could have major issues.

With passive interfaces it will still place the network into the rip routing table but it will not run the rip protocol on the interface.

1537
Views
0
Helpful
4
Replies