Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

RIP problems

I'm trying to use RIP to sync route tables from 2 router in the same network (Cisco 2620 ios 12.2 and 12.0).

I tryied with and without authentication, but the receiver router always says:

RIP: ignored v2 packet from 192.168.0.9 (not enabled on FastEthernet0/0).

What is missing ?

ROUTER A

interface FastEthernet0/0

ip address 192.168.0.9 255.255.255.0

no ip directed-broadcast

load-interval 30

duplex auto

speed auto

router rip

version 2

redistribute static

passive-interface Serial0/0

passive-interface Serial0/1

passive-interface Serial0/2

passive-interface Serial0/3

network 200.241.84.0

network 200.242.95.0

network 200.249.144.0

network 200.249.155.0

neighbor 192.168.0.17

default-metric 10

no auto-summary

ROUTER B

interface FastEthernet0/0

ip address 200.241.84.17 255.255.255.0

speed auto

full-duplex

router rip

version 2

network 200.242.95.0

network 200.249.86.0

network 200.249.144.0

network 200.249.155.0

default-metric 10

4 REPLIES
Silver

Re: RIP problems

you are not advertising the 192.168.0.0 255.255.255.0 network in your Rip config

Community Member

Re: RIP problems

Thanks a lot.

It was the problem.

Bronze

Re: RIP problems

Seems like you are missing the network 192.168.0.9 on your router A and also seems like the two routers are in totally different subnet. one in 192 and other is 200.. Do you have something in the middle that connects the two router or they are connected back to back..

also did u try without the v2 and see what happened.. Other than getting the error message, are you getting the routes

Community Member

Re: RIP problems

It works !!! Thanks a lot.

I didn't want to share the routing table for the network 192.168.0.0, but when I put it, it worked.

Thanks again.

156
Views
5
Helpful
4
Replies
CreatePlease to create content