Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started.

New Member

RIPv1 & WINS works but is too SLOW

--begin ciscomoderator note-- The following post has been edited to remove potentially confidential information. Please refrain from posting confidential information on the site to reduce security risks to your network. -- end ciscomoderator note --

I connected two W2K servers (1-domain controller & 1 member server) through 3 routers using RIPv1. I can ping each server from the other server. Two routes are available and shutting down a target interface makes packets go through the other route as expected. debug ip rip shows the expected updates and show ip traffic doesn't show any errors.

Then I wanted to use the shares and since NetBEUI is not routable, I implemented WINS.

Now I can get to the shares, but it is so slow that the network is not usable. Before routing,I could play mp3s stored on 1 server over the network. Now, it plays about 4 notes and then stalls before restarting. Even browsing directories is way too slow to be used. Any suggestions on how to diagnose this situation?

config info: 1 W2K (DC) plugs into hub and then into Router R1 e0, the other server uses a crossover cable directly into the router R2 e1. So the shortest path is domain controller-hub-R1e0-R1S0-R2S1-R2e1-member server. The longer path is domain controller-hub-R1e0-R1S1-FRS1-FRS0-R2S0-R2e1-member server.

router fr

fr#show config

Using 934 out of 32762 bytes

!

version 11.1

service udp-small-servers

service tcp-small-servers

!

hostname fr

!

enable secret 5 xxxxxxxxxxxxxxxxxxxxx

enable password xxxxxxxxxxxxxxxxxxxxx

!

isdn switch-type ntt

!

interface Serial0

description This interface connects to r2 s0

ip address 172.16.5.1 255.255.0.0

no ip mroute-cache

clockrate 56000

!

interface Serial1

description This interface goes to r1 s1

ip address x.x.x.2 255.255.0.0

clockrate 56000

!

interface Serial2

no ip address

no ip mroute-cache

shutdown

!

interface Serial3

no ip address

no ip mroute-cache

shutdown

!

interface TokenRing0

no ip address

no ip mroute-cache

shutdown

!

interface BRI0

no ip address

no ip mroute-cache

shutdown

!

router rip

network 172.16.0.0

network x.x.x.0

!

ip host r1 x.x.x.3

ip host r2 x.x.x.2

no ip classless

logging 192.168.1.89

!

line con 0

exec-timeout 0 0

password xxxxxxxxxxxxxxxxxxxx

login

line aux 0

line vty 0 4

password xxxxxxxxxxxxxxxxxxxx

login

!

end

router r1

r1#show config

Using 1111 out of 32762 bytes

!

version 11.0

service config

service udp-small-servers

service tcp-small-servers

!

hostname r1

!

enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

enable password xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

!

no ip domain-lookup

!

interface Loopback0

no ip address

!

interface Ethernet0

ip address 192.168.1.66 255.255.255.0

no ip mroute-cache

!

interface Serial0

description This interface connects to router2's s1 (DCE)

ip address x.x.x.3 255.0.0.0

no ip mroute-cache

no fair-queue

!

interface Serial1

description This interface goes to fr s1

ip address x.x.x.1 255.255.0.0

!

router rip

network 192.168.1.0

network x.x.x.0

network x.x.x.0

!

ip host moon 192.168.1.75

ip host fr x.x.x.2

ip host r2 172.16.5.2

ip name-server 192.168.1.75

logging 192.168.1.89

banner motd ^C

*******************************************************************

* This is r1 *

*******************************************************************

^C

line con 0

exec-timeout 0 0

logging synchronous

line aux 0

transport input all

line vty 0 4

exec-timeout 0 0

password xxxxxxxxxxxxxxxx

login

!

end

router r2

r2#show config

Using 668 out of 32762 bytes

!

version 10.2

service tcp-small-servers

!

hostname r2

!

enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

enable password xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

!

!

interface Ethernet0

ip address 192.168.1.26 255.255.255.0

!

interface Ethernet1

ip address 192.168.2.88 255.255.255.0

!

interface Serial0

description This interface goes to fr s0

ip address 172.16.5.2 255.255.0.0

!

interface Serial1

ip address x.x.x.2 255.0.0.0

clockrate 56000

!

router rip

network 172.16.0.0

network x.x.x.0

network 192.168.2.0

!

logging 192.168.1.89

!

line con 0

exec-timeout 0 0

password xxxxxxxxxxxxxxxx

logging synchronous

login

line aux 0

transport input all

line vty 0 4

exec-timeout 0 0

password xxxxxxxxxxxxxxxx

login

!

end

Any hints would be appreciated.

mk

  • Other Network Infrastructure Subjects
5 REPLIES
Bronze

Re: RIPv1 & WINS works but is too SLOW

Why do you want to use NetBEUI if you already have a TCP/IP connectivity to your servers. If the servers are Win2k, you should be able to use DNS to support host name lookup. Is there a specific requirement for NetBEUI? You should be able to access shares on Windows Servers with TCP/IP without WINS or NetBEUI.

Also, are the serial links really only 56k? If so RIP will consume a good deal of that bandwidth when it does it periodic update (every 30 seconds by default). You might want to use eigrp (which only sends updates for topology changes and small hello packets). Also, with eigrp, you can specify what % of the bandwidth is to be used for routing updates, etc.

New Member

Re: RIPv1 & WINS works but is too SLOW

Jamey, thanks for the response.

I implemented WINS only because my MCSE book said that was "THE" method of making shares available if routers didn't support broadcasts. How would one access a share on another machine using windows explorer like you are suggesting? I certainly don't mind doing some research on this, but if you could give me a topic to look under, I'd appreciate it.

I put 56K in the serial links because that was what an example in a book said to do. I think that was the speed used on a router simulation also. How does one tell the maximum speed a serial port supports?

The eigrp suggestion is an excellent one and I will do that, but I want to make sure I can get this RIPv1 configuration working in a real environment before moving on. Had I just stopped after getting the hosts to ping one another like the book said, I wouldn't be learning all these other little items and would miss out on all the fun of banging on something until it works!

And finally, I put network monitor on one of the servers and discovered a lot of errors

(SMB: R transact2 - NT error, System, Error, Code = (52) STATUS_OBJECT_NAME_NOT_FOUND), which according to microsoft's support page can be cured with the latest service pack on w2k server (http://support.microsoft.com/default.aspx?scid=kb;en-us;265396). I'm downloading it now to test that theory.

Thanks

mk

Bronze

Re: RIPv1 & WINS works but is too SLOW

Not sure what book you are using but Win2k (by default) uses DNS for name resolution, not WINS. WINS is used in a Win2k network for backwards support with pre-Win2k clients/servers. It shouldn't be needed if DNS is set up properly for name resolution. On your Win2k server, set up DNS in accordance with Microsoft specifications for a Win2k domain. On your servers/clients point them to the DNS server in TCP/IP config. Remove WINS. This won't speed anything up as far as file transfers, etc, but it is the recommended way of name resolution in pure Win2k environments.

You should be able to change the clockrate on your routers to higher values. I assume you have them connected back-to-back with DTE-DCE cables. It depends on various things what you can make the value of clock rate (like cable type, etc.) I suggest doubling the value (must be done on DCE interfaces only) and see if everything still works. If so, double it again until it breaks, then revert.

Yep, it is fun messing around with setups like you have to learn more than what the book is trying to teach you. I find that you often learn more useful information by going outside the book.

Regards

New Member

Re: RIPv1 & WINS works but is too SLOW

Service Pack 4 did not fix the error reported above. However, changing the speed of the serial ports on the routers did the trick. (Thanks Jamie)

r2 took a clock rate of 4000000 and stayed up. However router fr would only take a clockrate of 2000000. (Anyone know what controls this and if there is some method of determining this besides trial and error?)

Net Monitor still shows the Microsoft SMB errors, but the network is usable.

I would still like to know how to browse directories using windows explorer without using WINS in a routed environment. If only Microsoft had forums that were as good as Cisco's.....

mk

Bronze

Re: RIPv1 & WINS works but is too SLOW

The functionality you seek in your Win2k environemnt should be offered by use of properly setup DNS:

Some DNS stuff:

http://www.microsoft.com/technet/treeview/default.asp?url=/technet/columns/profwin/pw0302.asp

http://www.microsoft.com/windows2000/techinfo/howitworks/communications/nameadrmgmt/w2kdns.asp

Also, if you don't want/have DNS, a properly setup WINS environment should allow you to browse across routers also.

A nice paper on Windows Networking by Cisco:

http://www.cisco.com/en/US/tech/tk870/tk877/tk880/technologies_tech_note09186a00801aa01f.shtml#nameresolution

Finally, you can use the Cisco command "ip forward-protocol" to forward broadcasts not normally forwarded by routers:

http://www.cisco.com/en/US/products/hw/routers/ps380/products_configuration_guide_chapter09186a008007cdf0.html#xtocid297558

As for the clockrate, the max value is harware dependent:

http://www.cisco.com/en/US/products/sw/iosswrel/ps1826/products_command_reference_chapter09186a00800d9b6f.html

Cheers!

178
Views
0
Helpful
5
Replies