Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

RME Swim - Error code: '4159'

Hi all

I am trying to run a swim job but this is failing with the error message:

<snip>

Error info code: '4159'

Message: 'Device error: the copy to/from flash operation failed'.

Probable cause: Flash copy failed with return code of copyUnknownFailure

<snip>

I am running RME 3.4 (no IDU's) on W2k SP3 - the job is going to a 1721

As far as I know device credentials are configured correctly

Does anyone know what this error message indicates ?

Any suggestions welcome

Many thanks in advance

5 REPLIES
Community Member

Re: RME Swim - Error code: '4159'

NB: We've tried this on the following devices:

2610 running 12.0(3)T3

1720 running 12.0(4)T

Re: RME Swim - Error code: '4159'

Hi,

is there any free memory in flash or is it all in use? try to free up some flash memory.

regards,

Martin

Community Member

Re: RME Swim - Error code: '4159'

Hi Martin - Many thanks for your reply

I don't have access to the device at the moment, however, we did some tests as follows:

We loaded a 12.1 image on a device with a local tftp server and tried to pull the image from the device to the CW server - this worked. We then loaded the 12.1 image back to the device with RME and this worked. We then loaded the 12.0 image to the device with RME and this worked also, however, after changing the image on the device to 12.0 Swim jobs again failed

So Swim works fine if the device is already running a 12.1 image, but will not work if the device is running a 12.0 train image

I am not aware of any restriction for RME with IOS images running old Cisco MIBs and I can't find a bug on this, but if Swim does not function on devices running 12.0 train images then this seems like quite a serious issue ...

Has anyone seen this issue with their own devices when running 12.0 images ?

Martin, do you think this could still be a problem with the amount of free flash ?

Appreciate your help

Community Member

Re: RME Swim - Error code: '4159'

Just checked the debug from one of the Swim jobs on the 2610 and noted following flash information:

Max Flash: 8 388 608, max available Flash: 1 687 968

Community Member

Re: RME Swim - Error code: '4159'

Hi all

Anyone have any other ideas as to the cause of this "Error code: '4159'" - Don't think it is a flash memory issue as the problem does not occur in devices running larger images

Many thanks in advance for any help

Kind regards - Marcus

91
Views
0
Helpful
5
Replies
CreatePlease to create content