Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

rommon when boot up

I work for an ISP and we recently recieved an upgrade for our 2600. I was going to load it on a spare 2600 and then swap them out. I was in middle of tftp the image and it kept timing out. I shutdown the router and was going to move it somewhere else on the network with less traffic, now the router only boots in rommon and i cant figure how to tftp the new image to it. any suggestions?? I dont want to do to the one thats in use cause in keep having low memory problems, but i tried and it failed, now i fear if i reboot it, it will have the same problem. this going to be true?

thank in advance

mike

2 REPLIES
New Member

Re: rommon when boot up

Hi!

So you are on Romon. First attach a PC with TFTP server to the ethernet port on the 2600. Then on the romon configuration put the following:

rommon 16 > IP_ADDRESS=171.68.171.0

rommon 17 > IP_SUBNET_MASK=255.255.254.0

rommon 18 > DEFAULT_GATEWAY=171.68.170.3

rommon 19 > TFTP_SERVER=171.69.1.129

rommon 20 > TFTP_FILE=c2600-is-mz.113-2.0.3.Q

Of course, put the IP values that you want(make sure they are consistent). Then put

rommon 21 > tftpdnld

It will ask you to boot. When it boots it will try to grab the IOS image of the TFTP server. Make sure you write the proper IOS image name on TFTP_FILE parameter. Also check if you miss to write the .bin extension. If you receive an error regarding file not found on the TFTP log it may be that the file is not written correctly on the router variable or the path of the TFTP does not contain the image that you are looking for.

C ya!

Mario

New Member

Re: rommon when boot up

i tried that and it didnt work, i am going to try it again. my main problem though is the router that is in line right now has no flash cause it had to be erased to attempt the tftp. so if it reboots it will be stuck in rommon too and i dont want that. i am sure there is a way to restore my flash mem isnt there? the router has been having memory problems and thowing up errors so we were ugrading to the latest ios to try and fix it.

145
Views
0
Helpful
2
Replies
CreatePlease login to create content