Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Rookie needs Help configuing 2600

--begin ciscomoderator note-- The following post has been edited to remove potentially confidential information. Please refrain from posting confidential information on the site to reduce security risks to your network. -- end ciscomoderator note --

I'm a rookie and need help configuring a 2600 router.

Problem is I can only ping one subinterface which is 0/0.1 all others fail and I can't figure it out - The one that works is a 64k circuit all others are 256k Frame relay

Here's the config - TIA (Thanks in Advance)

Current configuration:

!

version 12.0

no service pad

service timestamps debug uptime

service timestamps log uptime

!

hostname TestLab

!

no logging buffered

enable secret 5 --moderator edit--

!

!

!

!

!

memory-size iomem 15

ip subnet-zero

no ip domain-lookup

ip host Bonifay 192.168.1.2

ip host B-Town 192.168.2.2

ip host Marianna 192.168.3.2

ip host Chipley 192.168.5.2

!

!

!

!

interface FastEthernet0/0

ip address 16x.xx.xx.2 255.255.255.192

ip helper-address 16x.xx.xx.7

no ip directed-broadcast

duplex auto

speed auto

!

interface Serial0/0

bandwidth 1544

no ip address

no ip directed-broadcast

encapsulation frame-relay IETF

no fair-queue

frame-relay lmi-type cisco

hold-queue 1024 out

!

interface Serial0/0.1 point-to-point

description To: Bonifay 64k circuit

ip address 192.168.1.1 255.255.255.0

no ip directed-broadcast

frame-relay interface-dlci 20

!

interface Serial0/0.2 point-to-point

description To: Blountstown 256k circuit

ip address 192.168.2.1 255.255.255.0

no ip directed-broadcast

frame-relay interface-dlci 19

!

interface Serial0/0.3 point-to-point

description To: Marianna 256k circuit

ip address 192.168.3.1 255.255.255.0

no ip directed-broadcast

frame-relay interface-dlci 21

!

interface Serial0/0.4 point-to-point

description To: Chipley 256k circuit

ip address 192.168.5.1 255.255.255.0

no ip directed-broadcast

frame-relay interface-dlci 22

!

interface FastEthernet0/1

ip address 192.168.20.1 255.255.255.0

no ip directed-broadcast

duplex auto

speed auto

!

router eigrp 1

redistribute static

network 16x.xx.0.0

network 192.168.1.0

network 192.168.2.0

network 192.168.3.0

network 192.168.5.0

distribute-list 1 out FastEthernet0/0

!

ip classless

ip route 0.0.0.0 0.0.0.0 16x.xx.xx.1

ip route 16x.xx.x.0 255.255.0.0 16x.xx.xx.0

ip route 16x.xx.xx.64 255.255.255.192 192.168.5.2

ip route 16x.xx.xx.192 255.255.255.192 192.168.3.2

ip route 16x.xx.xx.224 255.255.255.240 192.168.1.2

ip route 16x.xx.xx.128 255.255.255.192 192.168.2.2

no ip http server

access-list 1 permit 16x.xx.xx.0 0.0.0.255

access-list 1 deny any

banner motd ^C

************************************************************************

This ROUTER belongs to the CHIPOLA REGIONAL WORKFORCE and ONLY

AUTHORIZED CHIPOLA REGIONAL WORKFORCE EMPLOYEES are ALLOWED ACCESS

ALL OTHERS ARE DENIED ACCESS

************************************************************************

^C

!

line con 0

timeout login response 20

password xxxxx

logging synchronous

login

transport input none

line aux 0

line vty 0 4

password xxxxx

login

!

no scheduler allocate

end

12 REPLIES
Cisco Employee

Re: Rookie needs Help configuing 2600

We need to troubleshoot that issue. First you need to verify that the dlci on the other interface is in ACTIVE state using "show frame-relay pvc" . Also need to see the interface status itself.

Here is the good detailed url which will help you to troubleshoot almost any frame-relay probelm

http://www.cisco.com/warp/public/779/smbiz/service/troubleshooting/ts_fr.htm

One more link which explains the config and troubleshooting of different frame-relay scenarios.

http://www.cisco.com/warp/public/125/12.html

New Member

Re: Rookie needs Help configuing 2600

Thanks for the good info I will read over this tonight and test tomorrow am

New Member

Re: Rookie needs Help configuing 2600

Here are the online test - Note the only subinterface that worked fails now because the serial line is down on the other end.(that is the provider has a problem at the remote router end) sorry.

TestLab#sh ip int brief

Interface IP-Address OK? Method Status Prot

ocol

FastEthernet0/0 164.51.32.2 YES NVRAM up up

Serial0/0 unassigned YES NVRAM up down

Serial0/0.1 192.168.1.1 YES NVRAM up down

Serial0/0.2 192.168.2.1 YES NVRAM up down

Serial0/0.3 192.168.3.1 YES NVRAM up down

Serial0/0.4 192.168.5.1 YES NVRAM up down

FastEthernet0/1 192.168.20.1 YES NVRAM up down

TestLab#sh frame map

Serial0/0.1 (down): point-to-point dlci, dlci 20(0x14,0x440), broadcast, BW = 64

000

status defined, inactive

Serial0/0.3 (up): point-to-point dlci, dlci 21(0x15,0x450), broadcast, BW = 2560

00

status defined, active

Serial0/0.2 (up): point-to-point dlci, dlci 19(0x13,0x430), broadcast, BW = 2560

00

status defined, active

Serial0/0.4 (up): point-to-point dlci, dlci 22(0x16,0x460), broadcast, BW = 2560

00

status defined, active

TestLab#sh frame pvc

PVC Statistics for interface Serial0/0 (Frame Relay DTE)

Active Inactive Deleted Static

Local 3 1 0 0

Switched 0 0 0 0

Unused 0 0 0 0

DLCI = 19, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.2

input pkts 284 output pkts 46 in bytes 16130

out bytes 3619 dropped pkts 57 in FECN pkts 0

in BECN pkts 0 out FECN pkts 0 out BECN pkts 0

in DE pkts 0 out DE pkts 0

out bcast pkts 46 out bcast bytes 3619

pvc create time 00:06:16, last time pvc status changed 00:03:11

DLCI = 20, DLCI USAGE = LOCAL, PVC STATUS = INACTIVE, INTERFACE = Serial0/0.1

input pkts 0 output pkts 2 in bytes 0

out bytes 128 dropped pkts 0 in FECN pkts 0

in BECN pkts 0 out FECN pkts 0 out BECN pkts 0

in DE pkts 0 out DE pkts 0

out bcast pkts 2 out bcast bytes 128

pvc create time 00:06:23, last time pvc status changed 00:03:09

DLCI = 21, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.3

input pkts 104 output pkts 47 in bytes 16748

out bytes 3671 dropped pkts 1 in FECN pkts 0

in BECN pkts 0 out FECN pkts 0 out BECN pkts 0

in DE pkts 0 out DE pkts 0

out bcast pkts 46 out bcast bytes 3619

pvc create time 00:06:27, last time pvc status changed 00:03:22

DLCI = 22, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.4

input pkts 74 output pkts 48 in bytes 6111

out bytes 3747 dropped pkts 3 in FECN pkts 0

in BECN pkts 0 out FECN pkts 0 out BECN pkts 0

in DE pkts 0 out DE pkts 0

out bcast pkts 48 out bcast bytes 3747

pvc create time 00:06:29, last time pvc status changed 00:03:24

LMI Statistics for interface Serial0/0 (Frame Relay DTE) LMI TYPE = CISCO

Invalid Unnumbered info 0 Invalid Prot Disc 0

Invalid dummy Call Ref 0 Invalid Msg Type 0

Invalid Status Message 0 Invalid Lock Shift 0

Invalid Information ID 0 Invalid Report IE Len 0

Invalid Report Request 0 Invalid Keep IE Len 0

Num Status Enq. Sent 32 Num Status msgs Rcvd 32

Num Update Status Rcvd 0 Num Status Timeouts 0

TestLab#sh int ser 0/0

Serial0/0 is up, line protocol is up

Hardware is PQUICC with Fractional T1 CSU/DSU

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation FRAME-RELAY IETF, loopback not set

Keepalive set (10 sec)

LMI enq sent 40, LMI stat recvd 40, LMI upd recvd 0, DTE LMI up

LMI enq recvd 0, LMI stat sent 0, LMI upd sent 0

LMI DLCI 1023 LMI type is CISCO frame relay DTE

Broadcast queue 0/64, broadcasts sent/dropped 277/0, interface broadcasts 259

Last input 00:00:04, output 00:00:02, output hang never

Last clearing of "show interface" counters 00:09:38

Queueing strategy: fifo

Output queue 0/1024, 0 drops; input queue 0/75, 0 drops

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

704 packets input, 60203 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

323 packets output, 22870 bytes, 0 underruns

0 output errors, 0 collisions, 1 interface resets

0 output buffer failures, 0 output buffers swapped out

1 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

Serial0/0 is up, line protocol is up

Hardware is PQUICC with Fractional T1 CSU/DSU

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation FRAME-RELAY IETF, loopback not set

Keepalive set (10 sec)

LMI enq sent 53, LMI stat recvd 53, LMI upd recvd 0, DTE LMI up

LMI enq recvd 0, LMI stat sent 0, LMI upd sent 0

LMI DLCI 1023 LMI type is CISCO frame relay DTE

Broadcast queue 0/64, broadcasts sent/dropped 370/0, interface broadcasts 346

Last input 00:00:02, output 00:00:00, output hang never

Last clearing of "show interface" counters 00:11:52

Queueing strategy: fifo

Output queue 0/1024, 0 drops; input queue 0/75, 0 drops

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

796 packets input, 67249 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

429 packets output, 30341 bytes, 0 underruns

0 output errors, 0 collisions, 1 interface resets

0 output buffer failures, 0 output buffers swapped out

1 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

Serial0/0.1 is down, line protocol is down

Hardware is PQUICC with Fractional T1 CSU/DSU

Description: To: Bonifay 64k circuit

Internet address is 192.168.1.1/24

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation FRAME-RELAY IETF

Serial0/0.2 is up, line protocol is up

Hardware is PQUICC with Fractional T1 CSU/DSU

Description: To: Blountstown 256k circuit

Internet address is 192.168.2.1/24

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation FRAME-RELAY IETF

Serial0/0.3 is up, line protocol is up

Hardware is PQUICC with Fractional T1 CSU/DSU

Description: To: Marianna 256k circuit

Internet address is 192.168.3.1/24

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation FRAME-RELAY IETF

Serial0/0.4 is up, line protocol is up

Hardware is PQUICC with Fractional T1 CSU/DSU

Description: To: Chipley 256k circuit

Internet address is 192.168.5.1/24

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation FRAME-RELAY IETF

TestLab#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is 164.51.32.1 to network 0.0.0.0

C 192.168.5.0/24 is directly connected, Serial0/0.4

164.51.0.0/16 is variably subnetted, 4 subnets, 2 masks

S 164.51.32.192/26 [1/0] via 192.168.3.2

S 164.51.0.0/16 [1/0] via 164.51.32.0

C 164.51.32.0/26 is directly connected, FastEthernet0/0

S 164.51.32.64/26 [1/0] via 192.168.5.2

164.52.0.0/26 is subnetted, 1 subnets

S 164.52.32.128 [1/0] via 192.168.2.2

C 192.168.2.0/24 is directly connected, Serial0/0.2

C 192.168.3.0/24 is directly connected, Serial0/0.3

S* 0.0.0.0/0 [1/0] via 164.51.32.1

Tracing the route to 192.168.1.1

1 164.51.32.1 4 msec 4 msec 4 msec

2 164.51.196.117 8 msec 8 msec 4 msec

3 164.51.227.245 40 msec 40 msec 44 msec

4 164.51.227.194 44 msec 40 msec 40 msec

5 204.90.26.117 44 msec 40 msec 40 msec

6 192.168.253.9 44 msec 44 msec 44 msec

7 * * *

8 * *

TestLab#traceroute 192.168.2.1

Type escape sequence to abort.

Tracing the route to 192.168.2.1

1 * * *

2 * * *

3 * *

TestLab#traceroute 192.168.3.1

Type escape sequence to abort.

Tracing the route to 192.168.3.1

1 * * *

2 * * *

3 * *

TestLab#traceroute 192.168.4.1

Type escape sequence to abort.

Tracing the route to 192.168.4.1

1 164.51.32.1 4 msec 4 msec 4 msec

2 164.51.196.117 8 msec 8 msec 8 msec

3 164.51.203.57 28 msec 28 msec 28 msec

4 199.250.21.210 36 msec 36 msec 36 msec

5 199.250.21.28 28 msec 28 msec 32 msec

6 199.250.21.25 32 msec 28 msec 32 msec

7 * * *

8

Hope this helps - Thanks for all the help

New Member

Re: Rookie needs Help configuing 2600

Have you verified with the carrier that the PVC's have been provissioned correctly? Can you get the correct DLCI numbers from the carrier to verify?

New Member

Re: Rookie needs Help configuing 2600

All of the circuits and DLCI's are correct and working. I have a production router in place and the network functions properly. I am trying to setup a router to have as a backup.

New Member

Re: Rookie needs Help configuing 2600

Did you try to change any values of T1 service module commands.

Are the T1 service module command values are as specified by the service provider?

could you give the running config of the T1 serial interface and the subinterfaces?

-Deepu

New Member

Re: Rookie needs Help configuing 2600

No I have made no changes to the service module - figured if it works for one subinterface it should work for the others. As for the running config I gave it in the first post. But here' s the service module config. Thanks for the help.

Module type is T1/fractional

Hardware revision is 0.128, Software revision is 0.2,

Image checksum is 0xED22BEC5, Protocol revision is 0.1

Transmitter is sending remote alarm.

Receiver has loss of signal, loss of frame,

Framing is ESF, Line Code is B8ZS, Current clock source is line,

Fraction has 24 timeslots (64 Kbits/sec each), Net bandwidth is 1536 Kbits/sec.

Last module self-test (done at startup): Passed

Last clearing of alarm counters 00:00:38

loss of signal : 1, current duration 00:00:29

loss of frame : 1, current duration 00:00:29

AIS alarm : 0,

Remote alarm : 0,

Module access errors : 0,

Total Data (last 0 15 minute intervals):

0 Line Code Violations, 0 Path Code Violations

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Data in current interval (40 seconds elapsed):

255 Line Code Violations, 0 Path Code Violations

7 Slip Secs, 40 Fr Loss Secs, 40 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 40 Unavail Secs

Silver

Re: Rookie needs Help configuing 2600

The traces to 192.168.4.1 & 192.168.1.1 are following the 0.0.0.0 route because 4.1 does not exist and 1.1 is down down .

DO you get cdp across the Serial0/0.2 & Serial0/0.3 ?

can you ping these interfaces ?

New Member

Re: Rookie needs Help configuing 2600

yes to cdp - yes can ping 0.1 but no others

Silver

Re: Rookie needs Help configuing 2600

can you paste in sh cdp nei det

New Member

Re: Rookie needs Help configuing 2600

run the command nothing returns sh cdp nei det

Silver

Re: Rookie needs Help configuing 2600

What does the sh int serial s0/0.X and sh frame-relay pvc from the other side look like ?

186
Views
1
Helpful
12
Replies