Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Route between VLAN's using a 3750

Hello, I would like to use my 3750 switch as a level 3 switch so I can route between vlans.

Please reference the config below.

I currently have 5 vlans set up. Just for test purposes I have a PC in VLAN 2 and a PC in VLAN 6.

Vlan 2 IP address is 192.168.1.1 255.255.255.0

Vlan 5 IP address is 192.168.5.1 255.255.255.0

The PC on VLAN 2 has the ip address of 192.168.1.2 255.255.255.0 default gateway 192.168.1.1

The PC on VLAN 6 has the ip address of 192.168.5.2 255.255.255.0 default gateway 192.168.5.1

I have enabled ip routing in the config.

Niether PC can ping the other, with the PC in Vlan 2 giving this message ?Reply from 192.168.1.1: destination host unreachable

And the PC in Vlan 6 giving this message : Request timed out

Can anyone tell me where im going wrong?

Many thanks.

Test#show run

Building configuration...

Current configuration : 3766 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Test

!

enable secret xxxx

enable password xxx

!

no aaa new-model

switch 1 provision ws-c3750-48p

ip subnet-zero

ip routing

!

!

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface FastEthernet1/0/1

switchport access vlan 2

!

interface FastEthernet1/0/2

switchport access vlan 2

!

interface FastEthernet1/0/3

switchport access vlan 2

!

interface FastEthernet1/0/4

switchport access vlan 2

!

interface FastEthernet1/0/5

switchport access vlan 2

!

interface FastEthernet1/0/6

switchport access vlan 2

!

interface FastEthernet1/0/7

switchport access vlan 2

!

interface FastEthernet1/0/8

switchport access vlan 2

!

interface FastEthernet1/0/9

switchport access vlan 2

!

interface FastEthernet1/0/10

switchport access vlan 2

!

interface FastEthernet1/0/11

switchport access vlan 2

!

interface FastEthernet1/0/12

switchport access vlan 2

!

interface FastEthernet1/0/13

switchport access vlan 3

interface FastEthernet1/0/36

switchport access vlan 4

!

interface FastEthernet1/0/37

switchport access vlan 5

!

interface FastEthernet1/0/38

switchport access vlan 5

!

interface FastEthernet1/0/39

switchport access vlan 5

!

interface FastEthernet1/0/40

switchport access vlan 5

!

interface FastEthernet1/0/41

switchport access vlan 5

!

interface FastEthernet1/0/42

switchport access vlan 5

!

interface FastEthernet1/0/43

switchport access vlan 5

!

interface FastEthernet1/0/44

switchport access vlan 5

!

interface FastEthernet1/0/45

switchport access vlan 5

!

interface FastEthernet1/0/46

switchport access vlan 5

!

interface FastEthernet1/0/47

switchport access vlan 5

!

interface FastEthernet1/0/48

switchport access vlan 5

!

interface GigabitEthernet1/0/1

!

interface GigabitEthernet1/0/2

!

interface GigabitEthernet1/0/3

!

interface GigabitEthernet1/0/4

!

interface Vlan1

no ip address

shutdown

!

interface Vlan2

ip address 192.168.1.1 255.255.255.0

!

interface Vlan3

ip address 192.168.2.1 255.255.255.0

!

interface Vlan4

ip address 192.168.3.1 255.255.255.0

!

interface Vlan5

ip address 192.168.4.1 255.255.255.0

!

interface Vlan6

ip address 192.168.5.1 255.255.255.0

!

ip classless

ip http server

!

!

control-plane

!

!

line con 0

exec-timeout 0 0

line vty 0 4

password test

no login

line vty 5 15

password test

no login

!

!

end

21 REPLIES
Purple

Re: Route between VLAN's using a 3750

Hi,

Have you actually created the VLANs using the VLAN database ?

If not, enter VLAN configuration mode using the command 'vlan database' and then create both of these VLANs.

Hope that helps...

Paresh.

PS. Pls do remember to rate posts.

New Member

Re: Route between VLAN's using a 3750

No i havent, how do i enter vlan config mode?

Many thanks

Purple

Re: Route between VLAN's using a 3750

Simply enter in the command 'vlan database' from the privileged exec mode i.e. from the switch# prompt. You do not need to enter configuration mode.

Then enter in the following commands:

vlan 2

vlan 5

Both the VLANs will then be created with default paramaters...

Hope that helps - pls do rate the post if it does.

Paresh

New Member

Re: Route between VLAN's using a 3750

This does not seem to help, i saved the config and rebooted the switch and PC's and i still get the same results.

Any ideas?

Purple

Re: Route between VLAN's using a 3750

Can you post the output of:

- show vlan

- show interface vlan2

- show interface vlan5

Paresh

New Member

Re: Route between VLAN's using a 3750

Test>show vlan

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Gi1/0/1, Gi1/0/2, Gi1/0/3

Gi1/0/4

2 VLAN0002 active Fa1/0/1, Fa1/0/2, Fa1/0/3

Fa1/0/4, Fa1/0/5, Fa1/0/6

Fa1/0/7, Fa1/0/8, Fa1/0/9

Fa1/0/10, Fa1/0/11, Fa1/0/12

3 VLAN0003 active Fa1/0/13, Fa1/0/14, Fa1/0/15

Fa1/0/16, Fa1/0/17, Fa1/0/18

Fa1/0/19, Fa1/0/20, Fa1/0/21

Fa1/0/22, Fa1/0/23, Fa1/0/24

4 VLAN0004 active Fa1/0/25, Fa1/0/26, Fa1/0/27

Fa1/0/28, Fa1/0/29, Fa1/0/30

Fa1/0/31, Fa1/0/32, Fa1/0/33

Fa1/0/34, Fa1/0/35, Fa1/0/36

5 VLAN0005 active Fa1/0/37, Fa1/0/38, Fa1/0/39

Fa1/0/40, Fa1/0/41, Fa1/0/42

Fa1/0/43, Fa1/0/44, Fa1/0/45

Fa1/0/46, Fa1/0/47, Fa1/0/48

6 VLAN0006 active

1002 fddi-default act/unsup

1003 token-ring-default act/unsup

1004 fddinet-default act/unsup

1005 trnet-default act/unsup

New Member

Re: Route between VLAN's using a 3750

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

1 enet 100001 1500 - - - - - 0 0

2 enet 100002 1500 - - - - - 0 0

3 enet 100003 1500 - - - - - 0 0

4 enet 100004 1500 - - - - - 0 0

5 enet 100005 1500 - - - - - 0 0

6 enet 100006 1500 - - - - - 0 0

1002 fddi 101002 1500 - - - - - 0 0

1003 tr 101003 1500 - - - - - 0 0

1004 fdnet 101004 1500 - - - ieee - 0 0

1005 trnet 101005 1500 - - - ibm - 0 0

Remote SPAN VLANs

------------------------------------------------------------------------------

Primary Secondary Type Ports

------- --------- ----------------- ------------------------------------------

New Member

Re: Route between VLAN's using a 3750

Test>show interface vlan 2

Vlan2 is up, line protocol is up

Hardware is EtherSVI, address is 0017.9580.1b41 (bia 0017.9580.1b41)

Internet address is 192.168.1.1/24

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

1020 packets input, 77853 bytes, 0 no buffer

Received 0 broadcasts (0 IP multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

1013 packets output, 74342 bytes, 0 underruns

0 output errors, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

New Member

Re: Route between VLAN's using a 3750

Test>show interface vlan 2

Vlan2 is up, line protocol is up

Hardware is EtherSVI, address is 0017.9580.1b41 (bia 0017.9580.1b41)

Internet address is 192.168.1.1/24

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

1020 packets input, 77853 bytes, 0 no buffer

Received 0 broadcasts (0 IP multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

1013 packets output, 74342 bytes, 0 underruns

0 output errors, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

Re: Route between VLAN's using a 3750

hi micheal,

with your posting, i havn't seen any of the ports having "switchport access vlan 6", since your trying to ping from vlan 2(192.168.1.2) to vlan 6(192.168.5.2) pc, you need set "switchport access vlan 6" on the port where 192.168.5.2 pc is connected.this could the reason for not pinging.

hope this helps.

rate this post.

Purple

Re: Route between VLAN's using a 3750

Michael,

Can you try and configure 'switchport mode access' under the interfaces that are connected to the PCs that you are testing from ?

Paresh

New Member

Re: Route between VLAN's using a 3750

I have added switchport mode access on ports 1 and 47.

What does this command do? Im trying to understand in order to configure properly.

thanks.

Mike.

Purple

Re: Route between VLAN's using a 3750

By default, switches will try and form a trunk over the link if possible. This command hard-cores the interface to function solely as an access port.

Paresh

New Member

Re: Route between VLAN's using a 3750

Ok thanks for that, i still get the same results. No luck.

IS the config correct in principle?

I am working from this link, but obvisouly my set up is simple comapared to the cisco site.

http://www.cisco.com/en/US/tech/tk389/tk815/technologies_configuration_example09186a008015f17a.shtml

New Member

Re: Route between VLAN's using a 3750

How is it supposed to work if there is neither static routes configured or dynamic route process started?

New Member

Re: Route between VLAN's using a 3750

Throw me of the forum if you will, but does that mean my config is correct or i have gone wrong some where?

New Member

Re: Route between VLAN's using a 3750

a little late in this post sounds intresting . Michael can you do couple of steps please and post the results .

1. can you ping the default gateway .

2 can you do a shut no shut on that vlan interface please

thank

nh

Re: Route between VLAN's using a 3750

hi micheal,

with your posting, i havn't seen any of the ports having "switchport access vlan 6", since your trying to ping from vlan 2(192.168.1.2) to vlan 6(192.168.5.2) pc, you need set "switchport access vlan 6" on the port where 192.168.5.2 pc is connected.this could the reason for not pinging.

hope this helps.

rate this post.

New Member

Re: Route between VLAN's using a 3750

Indeed you are correct, user error, i have managed to magic vlan 6 up from no where. I have just changed the PC which i thought was on vlan 6 to have a vlan 5 IP address and everything is pinging fine.

Many thanks for your help I will rate all your posts with a 5.

Thanks again!!

New Member

Re: Route between VLAN's using a 3750

Ok, the PC on vlan 2 I can succefully ping the gateway.

The PC on VLAN 6 I can not = Request timed out.

I have performed a shutdown then a no shutdown for both VLANS (2 and 6) from the "test(config-vlan)#" prompt. No change.

Re: Route between VLAN's using a 3750

hi micheal,

post the rate which is there in the right side of the screen with the ratingz.

259
Views
50
Helpful
21
Replies
CreatePlease to create content