Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Route Problem

I have a customer with 2 cisco 2600's that connect over a t1. The customer has addtrans that manage the t1 and our connected via serial v.35 ports on the 2600's. They are trying to route between to lans. The problem is that the routers see each other fine. Ping and traceroute is great between serials and ethernet ports on both the routers. Router A host's can ping across the connection to hosts on the Router B lan and get replies. Router B cannot ping back across the connection to host attached on the Router A lan side but can ping Router A's ethernet address. Below are the configs for router A and Router B.

Thank you for any help you can provide.

Router A Config

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname RouterA

!

enable secret *****

!

!

ip subnet-zero

ip routing

!

interface Ethernet 0/0

no shutdown

description connected to EthernetLAN

ip address 192.168.0.13 255.255.255.0

keepalive 10

!

interface Serial 0/0

no shutdown

description connected to RouterB

ip address 10.10.10.2 255.0.0.0

encapsulation hdlc

!

ip classless

!

! IP Static Routes

ip route 172.168.1.0 255.255.255.0 10.10.10.1 1

Router B Config

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname RouterB

!

enable secret ****

!

!

ip subnet-zero

ip routing

!

interface Ethernet 0/0

no shutdown

description connected to EthernetLAN_1

ip address 172.168.1.1 255.255.255.0

keepalive 10

!

interface Serial 0/0

no shutdown

description connected to RouterA

ip address 10.10.10.1 255.0.0.0

encapsulation hdlc

!

!

ip classless

!

! IP Static Routes

ip route 192.168.0.0 255.255.255.0 10.10.10.2 1

4 REPLIES
Cisco Employee

Re: Route Problem

Make sure the hosts you are trying to ping have a default route pointing to router A LAN interface ip address.

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: Route Problem

The host default route is set to Router A ethernet ip address. The host can even telnet into router B, but router B cannot even ping the host.

Cisco Employee

Re: Route Problem

assuming you are using the same src and dst ip addr and unless you have some sort of ACL in the path that allows telnet but not pings, if you have connectivity in one direction you will have it also in the reverse direction.

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: Route Problem

Well I dont see anything in the running-config that would deny pings. I would agree with you that is the routes are there and can be traveled from Router B Serial to Router A ethernet then that same route should work from Router B serial to Host on Router A ethernet lan given the host has a default route for Router A ethernet. I also thought it could be an acl but I don't see anything in the config what you see is what is running on the routers.

By the way, Thank you for the feedback.

109
Views
5
Helpful
4
Replies