Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Route Switching Module

I'm in the process of setting up an RSM in a Catalyst 5505. I created the Vlan's in the Catalyst and then created the vlan's in the RSM module. After creating the vlan's interface in the RSM I tried to ping the Vlan interface, all tests failed even thought the interface stated UP/UP. For some reason I believe the RSM isn't communicating with the Catalyst 5505, one example is the session command is not working from the catalyst box to the RSM every time I run the "Session 2" (the RSM is located int slot 2)command the switch gives me the error "session: Unable to tunnel to Router-2 (57)". Then when I run a show module the software version of the RSM is not showing up. Here is the show version and the show module:

WS-C5505 Software, Version McpSW: 5.5(19) NmpSW: 5.5(19)

Copyright (c) 1995-2003 by Cisco Systems

NMP S/W compiled on Mar 27 2003, 17:25:19

MCP S/W compiled on Mar 27 2003, 17:28:15

System Bootstrap Version: 2.4(1)

Hardware Version: 1.0 Model: WS-C5505 Serial #: 066565474

Mod Port Model Serial # Versions

--- ---- ---------- --------- ----------------------------------------

1 2 WS-X5509 006778383 Hw : 2.1

Fw : 2.4(1)

Fw1: 2.4(1)

Sw : 5.5(19)

WS-F5511 006810387 Hw : 1.0

2 1 WS-X5302 013433261 Hw : 7.5

Fw : 0.0

Fw1: 3.1(1)

Sw :

3 12 WS-X5201R 014366552 Hw : 3.1

Fw : 4.3(1)

Sw : 5.5(19)

4 12 WS-X5201R 013475515 Hw : 3.1

Fw : 4.3(1)

Sw : 5.5(19)

5 24 WS-X5225R 011602548 Hw : 2.0

Fw : 4.1(1)

Sw : 5.5(19)

DRAM FLASH NVRAM

Module Total Used Free Total Used Free Total Used Free

------ ------- ------- ------- ------- ------- ------- ----- ----- -----

1 32768K 15450K 17318K 8192K 6656K 1536K 256K 184K 72K

Mod Sub-Type Sub-Model Sub-Serial Sub-Hw

--- -------- --------- ---------- ------

1 EARL 1+ WS-F5511 0006810387 1.0

Console> (enable) sh mod

Mod Slot Ports Module-Type Model Sub Status

--- ---- ----- ------------------------- ------------------- --- --------

1 1 2 100BaseTX Supervisor WS-X5509 yes ok

2 2 1 Route Switch WS-X5302 no ok

3 3 12 100BaseFX MM Ethernet WS-X5201R no ok

4 4 12 100BaseFX MM Ethernet WS-X5201R no ok

5 5 24 10/100BaseTX Ethernet WS-X5225R no ok

Mod Module-Name Serial-Num

--- ------------------- --------------------

1 00006778383

2 00013433261

3 00014366552

4 00013475515

5 00011602548

Mod MAC-Address(es) Hw Fw Sw

--- -------------------------------------- ------ ---------- -----------------

1 00-02-4a-12-78-00 to 00-02-4a-12-7b-ff 2.1 2.4(1) 5.5(19)

2 00-e0-1e-92-8e-1e to 00-e0-1e-92-8e-1f 7.5 0.0

3 00-50-a2-91-17-78 to 00-50-a2-91-17-83 3.1 4.3(1) 5.5(19)

4 00-60-83-fa-3f-58 to 00-60-83-fa-3f-63 3.1 4.3(1) 5.5(19)

5 00-50-a2-36-95-d0 to 00-50-a2-36-95-e7 2.0 4.1(1) 5.5(19)

Mod Sub-Type Sub-Model Sub-Serial Sub-Hw

--- -------- --------- ---------- ------

1 EARL 1+ WS-F5511 0006810387 1.0

Console> (enable)

Has anyone else run into this problem with an RSM in the 5505?

13 REPLIES
New Member

Re: Route Switching Module

I have had the results you mention, it was necessary to have a host (or hub) plugged into the vlan that I wanted to ping the vlan interface. I don't recall if the interface showed up/up or up/down. Is it possible to post a sup and rsm config if above test fails.

Regards,

Paul

New Member

Re: Route Switching Module

Yea, I've tried it with at least one of the vlan ports active but nothing changed. The weird thing is the vlan will show UP/UP even when I don't have a port active on that vlan. Now if I jump into the RSM and shut down the vlan then try and turn it back up I can never get it to come back up, even when one or all ports are active on the vlan. Here is the sup and rsm config:

begin

!

# ***** NON-DEFAULT CONFIGURATION *****

!

!

#time: Mon Oct 6 2003, 10:47:49

!

#version 5.5(19)

!

!

#test

set test diaglevel complete

!

#frame distribution method

set port channel all distribution mac both

!

#vtp

set vtp domain jeffersonlofts.flmultimedia.com

set vtp mode transparent

set vlan 1 name default type ethernet mtu 1500 said 100001 state active

set vlan 10 name Building1 type ethernet mtu 1500 said 100010 state active

set vlan 20 name Building2 type ethernet mtu 1500 said 100020 state active

set vlan 1002 name fddi-default type fddi mtu 1500 said 101002 state active

set vlan 1004 name fddinet-default type fddinet mtu 1500 said 101004 state activ

e stp ieee

set vlan 1005 name trnet-default type trbrf mtu 1500 said 101005 state active st

p ibm

set vlan 1003 name token-ring-default type trcrf mtu 1500 said 101003 state acti

ve mode srb aremaxhop 7 stemaxhop 7 backupcrf off

!

#ip

set interface sc0 1 192.168.1.1/255.255.255.252 192.168.1.3

!

#spantree

#vlan

set spantree fwddelay 15 1003

set spantree maxage 20 1003

set spantree fwddelay 15 1005

set spantree maxage 20 1005

!

#syslog

set logging level cdp 2 default

set logging level udld 2 default

!

# default port status is enable

!

!

#module 1 : 2-port 100BaseTX Supervisor

!

#module 2 : 1-port Route Switch

!

#module 3 : 12-port 100BaseFX MM Ethernet

set vlan 10 3/1

set vlan 20 3/2

set udld disable 3/1-12

set trunk 3/1 auto dot1q 1-1005

!

#module 4 : 12-port 100BaseFX MM Ethernet

!

#module 5 : 24-port 10/100BaseTX Ethernet

set vlan 10 5/1,5/3

set vlan 20 5/2

end

Console> (enable)

Here is RSM config:

Router#sh run

Building configuration...

Current configuration : 401 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router

!

!

!

!

!

!

ip subnet-zero

ip cef

!

!

!

!

interface Vlan1

ip address 192.168.1.1 255.255.255.252

!

interface Vlan10

ip address 10.0.1.1 255.255.255.0

!

ip classless

no ip http server

!

!

line con 0

line aux 0

line vty 0 4

login

!

end

Router#

New Member

Re: Route Switching Module

the rsm is on IP 192.168.1.1 and the sup is on 192.168.1.1, I would set the sup to the .2 addr. Also you do not have vlan20 defined on the rsm. correct those and test again, also include sh vlan on sup and sh int on rsm if you still have problem. Be sure to do a no shut on vlan20 when you set it up. can you also so a sh po on the port that you connect when you do the ping test.

regards,

paul

New Member

Re: Route Switching Module

OK, I set the second Vlan 20 up and when I first put the command "int vlan 20" in the RSM it took about 2 sec's before the Vlan went to up/up I then did a "no shut" and the interface then went down/down:

Router(config)#int vlan 20

Router(config-if)#ip address

00:00:45: %LINK-3-UPDOWN: Interface Vlan20, changed state to up

00:00:46: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state

Router(config-if)#

Router(config-if)#

Router(config-if)#no shut

Router(config-if)#

Router(config-if)#

Router(config-if)#

00:00:58: %LINK-3-UPDOWN: Interface Vlan20, changed state to down

00:00:59: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state

to down

Router(config-if)#

Router(config-if)#ip address 10.0.2.1 255.255.255.0

Router(config-if)#

Router(config-if)#exit

Router(config)#

Show Int:

Vlan1 is up, line protocol is up

Hardware is Cat5k Virtual Ethernet, address is 00d0.6366.5000 (bia 00d0.6366.5

000)

Internet address is 192.168.1.1/30

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

ARP type: ARPA, ARP Timeout 04:00:00

Last input never, output 00:00:21, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue :0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

25 packets output, 6568 bytes, 0 underruns

0 output errors, 1 interface resets

0 output buffer failures, 0 output buffers swapped out

Vlan10 is up, line protocol is up

Hardware is Cat5k Virtual Ethernet, address is 00d0.6366.5000 (bia 00d0.6366.5

000)

Internet address is 10.0.1.1/24

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

ARP type: ARPA, ARP Timeout 04:00:00

Last input never, output 00:06:53, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue :0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

15 packets output, 3357 bytes, 0 underruns

0 output errors, 1 interface resets

0 output buffer failures, 0 output buffers swapped out

Vlan20 is down, line protocol is down

Hardware is Cat5k Virtual Ethernet, address is 00d0.6366.5000 (bia 00d0.6366.5

000)

Internet address is 10.0.2.1/24

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

ARP type: ARPA, ARP Timeout 04:00:00

Last input never, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue :0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 packets output, 0 bytes, 0 underruns

0 output errors, 1 interface resets

0 output buffer failures, 0 output buffers swapped out

I can't seem to get the interface up/up and port 3/2 is active on the sup.

Console> (enable) sh port 3/1

Port Name Status Vlan Level Duplex Speed Type

----- ------------------ ---------- ---------- ------ ------ ----- ------------

3/1 connected 10 normal half 100 100BaseFX MM

Port Security Violation Shutdown-Time Age-Time Max-Addr Trap IfIndex

----- -------- --------- ------------- -------- -------- -------- -------

3/1 disabled shutdown 0 0 1 disabled 24

Console> (enable) sh port 3/2

Port Name Status Vlan Level Duplex Speed Type

----- ------------------ ---------- ---------- ------ ------ ----- ------------

3/2 connected 20 normal half 100 100BaseFX MM

Port Security Violation Shutdown-Time Age-Time Max-Addr Trap IfIndex

----- -------- --------- ------------- -------- -------- -------- -------

3/2 disabled shutdown 0 0 1 disabled 25

Still unable to ping the port.

New Member

Re: Route Switching Module

Did you change the IP address on the sup to 192.168.1.2? Also what is connected to the fiber port 3/1, what IP and mask are set?

New Member

Re: Route Switching Module

yes, I changed the sup to .2.

sc0: flags=63

vlan 1 inet 192.168.1.2 netmask 255.255.255.252 broadcast 192.168.1.3

I have the uplink of a HP2524 100FX connected to the 3/1 and off that I have a pc which has the ip address of 10.0.1.5 255.255.255.0 default gateway of 10.0.1.1 and he is trying to ping his gateway. Vlan 10 on the RSM.

New Member

Re: Route Switching Module

Lets simplify the problem.

Connect to a TX port (5/x) and assign an appropriate IP to the client 10.0.1.x or 10.0.2.x.

Can you now telnet from the sup to the rsm?

If yes then conn. to sup, telnet to rsm and ping the new tx client connect on po 5/x. Can you get a response from the client?

Check routes on the devices (rsm - sh ip route, sup sh route, on client route print).

New Member

Re: Route Switching Module

Also on the sup add a default route to the rsm interface so the sup can ping client on other vlans .

'set ip route 0.0.0.0 192.168.1.1'

New Member

Re: Route Switching Module

OK,

I connected a pc to port 5/1 on vlan 10 with IP address of 10.0.1.5 255.255.255.0 Default gateway of 10.0.1.1

Console> (enable) sh port 5/1

Port Name Status Vlan Level Duplex Speed Type

----- ------------------ ---------- ---------- ------ ------ ----- ------------

5/1 connected 10 normal a-full a-100 10/100BaseTX

I added the "set ip route 0.0.0.0 192.168.1.1 to the sup"

Console> (enable) sh route

Fragmentation Redirect Unreachable

------------- -------- -----------

enabled enabled enabled

The primary gateway: 192.168.1.1

Destination Gateway RouteMask Flags Use Interface

--------------- --------------- ---------- ----- -------- ---------

default 192.168.1.1 0x0 UG 7 sc0

192.168.1.0 192.168.1.2 0xfffffffc U 0 sc0

default default 0xff000000 UH 0 sl0

I still can't telnet to the RSM so I'll just change the console cable.

Router#ping 10.0.1.5

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.0.1.5, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

(by the way I keep getting this error on the console:

00:04:36: %C5IP: slot0 CCB (26) dropped, queue full...)

No luck..

Here is the sh ip route in the RSM:

Router#sh ip route c

10.0.0.0/24 is subnetted, 2 subnets

C 10.0.2.0 is directly connected, Vlan20

C 10.0.1.0 is directly connected, Vlan10

192.168.1.0/30 is subnetted, 1 subnets

C 192.168.1.0 is directly connected, Vlan1

Here is the route print from the client:

C:\Documents and Settings\Administrator>route print

===========================================================================

Interface List

0x1 ........................... MS TCP Loopback interface

0x2000003 ...00 d0 59 54 1d 01 ...... Accton EN5251 Series Chip Based Fast Ether

net Adapter NDIS5 Driver

===========================================================================

===========================================================================

Active Routes:

Network Destination Netmask Gateway Interface Metric

0.0.0.0 0.0.0.0 10.0.1.1 10.0.1.5 1

10.0.1.0 255.255.255.0 10.0.1.5 10.0.1.5 1

10.0.1.5 255.255.255.255 127.0.0.1 127.0.0.1 1

10.255.255.255 255.255.255.255 10.0.1.5 10.0.1.5 1

127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1

224.0.0.0 224.0.0.0 10.0.1.5 10.0.1.5 1

255.255.255.255 255.255.255.255 10.0.1.5 10.0.1.5 1

Default Gateway: 10.0.1.1

===========================================================================

Persistent Routes:

None

New Member

Re: Route Switching Module

When I look over your sup conf listing I don't see any settings for the rsm in slot 2. Can you do a cold start with a console connected to watch the boot process also do the same on the rsm on a second cold start. We need to get the sup and the rsm talking before we worry about a vlan.

New Member

Re: Route Switching Module

Here is the boot log of the sup:

ROM Power Up Diagnostics of Aug 19 1997

Init NVRAM Log

LED Test ................... done

ROM Checksum ............... passed

Dual Port RAM r/w Test ..... passed

ID PROM .................... passed

System DRAM Size(mb) ....... 32

DRAM Data Bus Test ......... passed

DRAM Address Test .......... passed

DRAM Byte/Word Access Test .. passed

EARL Test .................. passed

BOOTROM Version 2.4(1), Dated Aug 19 1997 11:00:58

BOOT date: 10/07/03 BOOT time: 06:23:00

Uncompressing NMP image. Using zlib uncompression method

NMP image is successfully uncompressed in DRAM

Downloading epld sram device please wait ...

Programming successful for Altera 10K10 SRAM EPLD

Updating epld flash version from 0000 to 0600

Running System Diagnostics from this Supervisor (Module 1)

This may take up to 2 minutes....please wait

Cisco Systems Console

Enter password:

2003 Oct 07 06:24:26 %SYS-5-MOD_OK:Module 1 is online

2003 Oct 07 06:24:52 %SYS-5-MOD_OK:Module 3 is online

2003 Oct 07 06:24:57 %SYS-5-MOD_OK:Module 4 is online

2003 Oct 07 06:25:06 %SYS-5-MOD_OK:Module 2 is online

2003 Oct 07 06:25:08 %SYS-5-MOD_OK:Module 5 is online

Here is the boot log of the RSM:

System Bootstrap, Version 11.2(17523) [mohsen 102], INTERIM SOFTWARE

Copyright (c) 1994-1997 by cisco Systems, Inc.

Warning: Slot 2 in Bank 1 has less memory than Slot 1 above 32M

Warning: There are errors in sizing bank2

Memory size is not accurate

SLOT 7 C5RSP is system master

C5RSP processor with 65536 Kbytes of main memory

Self decompressing the image : #################################################

################################################################################

################################################################################

################################################################################

########################################### [OK]

Self decompressing the image : #################################################

################################################################################

################################################################################

################################################################################

################################################################################

################################################################################

################################################################################

################################################################################

################################################################## [OK]

Restricted Rights Legend

Use, duplication, or disclosure by the Government is

subject to restrictions as set forth in subparagraph

(c) of the Commercial Computer Software - Restricted

Rights clause at FAR sec. 52.227-19 and subparagraph

(c) (1) (ii) of the Rights in Technical Data and Computer

Software clause at DFARS sec. 252.227-7013.

cisco Systems, Inc.

170 West Tasman Drive

San Jose, California 95134-1706

Cisco Internetwork Operating System Software

IOS (tm) C5RSM Software (C5RSM-ISV-M), Version 12.1(20), RELEASE SOFTWARE (fc2)

Copyright (c) 1986-2003 by cisco Systems, Inc.

Compiled Fri 30-May-03 03:24 by kellythw

Image text-base: 0x60010958, data-base: 0x60ED2000

cisco RSP2 (R4700) processor with 65536K/2072K bytes of memory.

R4700 CPU at 100Mhz, Implementation 33, Rev 1.0

Last reset from power-on

G.703/E1 software, Version 1.0.

G.703/JT2 software, Version 1.0.

X.25 software, Version 3.0.0.

Bridging software.

1 C5IP controller (1 Vlan).

1 Virtual Ethernet/IEEE 802.3 interface(s)

123K bytes of non-volatile configuration memory.

16384K bytes of Flash PCMCIA card at slot 1 (Sector size 128K).

8192K bytes of Flash internal SIMM (Sector size 256K).

Press RETURN to get started!

Here is the sup config after the boot:

Console> (enable) sh config

This command shows non-default configurations only.

Use 'show config all' to show both default and non-default configurations.

........

................

................

..

begin

!

# ***** NON-DEFAULT CONFIGURATION *****

!

!

#time: Tue Oct 7 2003, 06:29:43

!

#version 5.5(19)

!

!

#test

set test diaglevel complete

!

#frame distribution method

set port channel all distribution mac both

!

#vtp

set vtp domain jeffersonlofts.flmultimedia.com

set vtp mode transparent

set vlan 1 name default type ethernet mtu 1500 said 100001 state active

set vlan 10 name Building1 type ethernet mtu 1500 said 100010 state active

set vlan 20 name Building2 type ethernet mtu 1500 said 100020 state active

set vlan 1002 name fddi-default type fddi mtu 1500 said 101002 state active

set vlan 1004 name fddinet-default type fddinet mtu 1500 said 101004 state activ

e stp ieee

set vlan 1005 name trnet-default type trbrf mtu 1500 said 101005 state active st

p ibm

set vlan 1003 name token-ring-default type trcrf mtu 1500 said 101003 state acti

ve mode srb aremaxhop 7 stemaxhop 7 backupcrf off

!

#ip

set interface sc0 1 192.168.1.2/255.255.255.252 192.168.1.3

set ip route 0.0.0.0/0.0.0.0 192.168.1.1

!

#spantree

#vlan

set spantree fwddelay 15 1003

set spantree maxage 20 1003

set spantree fwddelay 15 1005

set spantree maxage 20 1005

!

#syslog

set logging level cdp 2 default

set logging level udld 2 default

!

# default port status is enable

!

!

#module 1 : 2-port 100BaseTX Supervisor

!

#module 2 : 1-port Route Switch

!

#module 3 : 12-port 100BaseFX MM Ethernet

set vlan 10 3/1

set vlan 20 3/2

set udld disable 3/1-12

set trunk 3/1 auto dot1q 1-1005

!

#module 4 : 12-port 100BaseFX MM Ethernet

!

#module 5 : 24-port 10/100BaseTX Ethernet

set vlan 10 5/1,5/3

set vlan 20 5/2

end

I really appreciate your help!!

New Member

Re: Route Switching Module

From the sup can you ping 192.168.1.1

--yes than add a passowrd to rsm vty 0 4 line

conf t ; line vty 0 4 ; password cisco ; ctlr z

retest telnet from sup to rsm

--no than ping 192.168.1.2

also do a sh cdp nei and sh trunk from the sup

email results to mercierpaul@hotmail.com

New Member

Re: Route Switching Module

Yesterday I opend a case with cisco on the RSM and after I told the engineer to read our postings on the forum he said right away that there is a failure with the traffic bus on the RSM. So I got the RSM replaced and I just put the new one in the Catalyst 5505 and everything is working great. I really appreciate all the help!!

124
Views
0
Helpful
13
Replies
CreatePlease to create content