Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

router 1721. Where is my image?!

Hi people,

I have a cisco 1721 router with the following "sh ver" output:

Cisco Internetwork Operating System Software

IOS (tm) C1700 Software (C1700-O3Y-M), Version 12.1(5), RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2000 by cisco Systems, Inc.

Compiled Wed 25-Oct-00 03:59 by cmong

Image text-base: 0x80008088, data-base: 0x8064D54C

ROM: System Bootstrap, Version 12.2(7r)XM1, RELEASE SOFTWARE (fc1)

barralife uptime is 1 hour, 53 minutes

System returned to ROM by power-on

System image file is "flash:c1700-o3y-mz_121-5.bin"

cisco IPM (MPC860) processor (revision 0x100) with 29492K/3276K bytes of memory.

Processor board ID FOC063301FN (1281980478), with hardware revision 0000

M860 processor: part number 5, mask 2

Bridging software.

X.25 software, Version 3.0.0.

32K bytes of non-volatile configuration memory.

Configuration register is 0x2102

----------------------------

The problem is that I can´t find the file "flash:c1700-o3y-mz_121-5.bin" in any file system of the router!

For example, if I type the command "cd flash: "

I get the message:

myrouter#cd flash:

^

% Invalid input detected at '^' marker.

------------------------------------

When I type the command "copy ?" I get the following output:

myrouter#copy ?

/erase Erase destination file system.

ftp: Copy from ftp: file system

null: Copy from null: file system

nvram: Copy from nvram: file system

rcp: Copy from rcp: file system

running-config Copy from current system configuration

startup-config Copy from startup configuration

system: Copy from system: file system

tftp: Copy from tftp: file system

xmodem: Copy from xmodem: file system

ymodem: Copy from ymodem: file system

Unknown file system

------------------------------------------

I don´t know anymore where to look for my .bin image file!! I´m needing to copy it ... And I´m also needing to copy another image to my router! where should I put it?!

Thanks in advance,

Bruno

16 REPLIES
VIP Purple

Re: router 1721. Where is my image?!

Hello Bruno,

I am not sure I understand your question right, a show flash should show you the system image file you are looking for. Which file systems do you see when you issue the command show file systems ?

Regards,

Georg

New Member

Re: router 1721. Where is my image?!

Hi,

thanks for your attention.

there´s no file system called "flash:" or "flash"

For example, the command "show flash" output an error at the word flash!

I think the "show file systems" command should output something similar to the output of the command "copy ?" that I previosly showed ... Right now I can´t test it, but tommorow I will post the output of the command "show file systems"

Thanks,

Bruno Galvao

New Member

Re: router 1721. Where is my image?!

Hi,

Is it possible that my image file is in ROM? I´m almost jumping at this conclusion!

New Member

Re: router 1721. Where is my image?!

show flash:

you should see this file "c1700-o3y-mz_121-5.bin" resided on flash.

If you want to copy it for backup, you would first need to have a tftp server (lots freeies out there). then "copy flash:c1700-o3y-mz_121.5.bin tftp:". You can do the same by copying from tftp server to flash "copy tftp: flash:"

hope this help.

New Member

Re: router 1721. Where is my image?!

You didn´t understand my problem!

I´m almofst sure that I don´t have flash memory in my router ...

The "show flash:" command returns "Invalid Input" at the word "flash"

Ftp? no problem, I have on in front of me ... :-)

HELP ME FIND MY IOS IMAGE!!! I´m suspecting it´s in rom ... or my router has a hardware problem!!!

New Member

Re: router 1721. Where is my image?!

you are confusing me. your sh ver clearly shows ios resides on flash. do you noticed any errors during boot up? can you get to the priviledge exec mode?

New Member

Re: router 1721. Where is my image?!

I know that its confusing ...

That´s why I´m posting it here!

The "sh ver" really shows clearly the image location ("flash:") Buts it´s not there! I don´t have this place ("flash:") in my router!

Something is really wrong with my ios!

If you take a look at my first post where I posted the output of the command "copy ?" that lists all possible sources of a copy ... you´ll notice that flash: isn´t there and also that there´s a "Unknown file system" at the last line!!

No errors at boot time! Yes, I´m doing it all under exec mode ... The router is mine! I have all the passwords!

Any clue?!

Thanks!

Bruno Galvao

e-mail: galvao@cebim.com.br

New Member

Re: router 1721. Where is my image?!

you're right! there is no flash listed on "sh ver". i wonder if this is an ios bug or corrupted image. remember this router runs from RAM, unlike the RFF types of routers. try cold boot, and get into Rommon mode. do a "dir flash". this way you can eliminate whether is an ios bug. if you do see flash from rommon mode, try xmodem upload of a newer image. noticed your "show ver" didn't detect any interfaces?

New Member

Re: router 1721. Where is my image?!

Ok. I will try it and tell you what happened.

Listen, when you say upload through xmodem you mean any method for uploading including tftp, right?

Is it possible to do this under rommon mode?

Yes, I´m having problems with interface rocognition too ... That´s why I´m trying to upgrade my ios.

If you want, I can tell you details about the int recognition problem that I´m facing

Thanks,

Bruno Galvao

CEBIM

galvao@cebim.com.br

New Member

Re: router 1721. Where is my image?!

upload via xmodem done in rommon mode, and is through console. therefore you should increase your console speed to 115200 first. the below url is very helpful.

when you are in rommon mode, do a "dir flash:" first. if you see an ios image in flash, most likely that it's corrupted. noticed the url shows you tftp and xmodem upload methods. but you can only use xmodem, because none of your router interfaces are seen. good luck.

http://www.cisco.com/en/US/products/hw/routers/ps221/products_tech_note09186a00800942dc.shtml

New Member

Re: router 1721. Where is my image?!

Hi, you were right!

Under rom mode, I could see my flash memory content through "dir flash:" command and saw the ios image file right there.

Then I downloaded another image through tftp and booted this image. The only problem is that this new image is a bit older than the original.

The router booted the new image but the patological situation is still taking place. Under this new ios I also can´t see my interfaces and the "show file systems" is still not showing the "flash:" file system.

Maybe a newer version could solve the problem but I don´t know where to find one :-( Can you help me?

Thanks,

Bruno Galvao

galvao@cebim.com.br

New Member

Re: router 1721. Where is my image?!

you currently have 12.1(5)LD IP/FW/IDS features. you should avoid Limited Deployment codes. i am not sure the amount of flash and the types of hardware installed on your router. if you have enough flash and simple hardware (serial and fastethernet), try 12.1(20)GD IP ONLY features. better yet. try this first. pull out all of the modular hardware from the router and power on. see if it boots ok (i doubt).

New Member

Re: router 1721. Where is my image?!

Ok. But where from where should I download this?

I´m not registered on cisco!

galvao@cebim.com.br

Thanks

New Member

Re: router 1721. Where is my image?!

did you receive my email attachment?

New Member

Re: router 1721. Where is my image?!

Yes Thank you very much!

I saved your attachement but received another one from a friend (version 12.3). Installed and everything worked!! :-)))

Thank you all!!!!

galvao@cebim.com.br

New Member

Re: router 1721. Where is my image?!

Hi folks!

Here is the output of my "sh file systems"

barralife#sh file systems

File Systems:

Size(b) Free(b) Type Flags Prefixes

29688 28902 nvram rw nvram:

- - opaque rw null:

- - opaque rw system:

- - opaque ro xmodem:

- - opaque ro ymodem:

- - network rw tftp:

- - network rw rcp:

- - network rw ftp:

160
Views
0
Helpful
16
Replies
CreatePlease login to create content