Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

router 2620

hi

i have 2620 router, and i would like to create subinterfaces on my fastethernet 0/0

when i create it, i would make an ip address but this is the message errore:

Configuring IP routing on a LAN subinterface is only allowed if that

subinterface is already configured as part of an IEEE 802.10, IEEE 802.1Q, or IS

L vLAN.

what can i do?

thanks.

11 REPLIES
Silver

Re: router 2620

Before you put the ip on try this on the subinterface.

Encap dot1q or Encap isl

Your just missing the tagging type of isl or dot1q and the vlan 10 it's associated with.

Hope this helps you,

Don

Community Member

Re: router 2620

hi

il would encapsulate this subinterface with isl for my vlan, to make my router a router on the stick, but when i enter to the subinterface config, there is no encaplsulation command, this the output when i do a ?

access-expression Build a bridge boolean access expression

arp Set arp type (arpa, probe, snap) or timeout

backup Modify backup parameters

bandwidth Set bandwidth informational parameter

bridge-group Transparent bridging interface parameters

carrier-delay Specify delay for interface transitions

cdp CDP interface subcommands

cmns OSI CMNS

custom-queue-list Assign a custom queue list to an interface

default Set a command to its defaults

delay Specify interface throughput delay

description Interface specific description

duplex Configure duplex operation.

exit Exit from interface configuration mode

fair-queue Enable Fair Queuing on an Interface

full-duplex Configure full-duplex operational mode

half-duplex Configure half-duplex and related commands

help Description of the interactive help system

hold-queue Set hold queue depth

ip Interface Internet Protocol config commands

keepalive Enable keepalive

llc2 LLC2 Interface Subcommands

load-interval Specify interval for load calculation for an

interface

logging Configure logging for interface

loopback Configure internal loopback on an interface

mac-address Manually set interface MAC address

max-reserved-bandwidth Maximum Reservable Bandwidth on an Interface

media-type Interface media type

mtu Set the interface Maximum Transmission Unit (MTU)

multilink-group Put interface in a multilink bundle

netbios Use a defined NETBIOS access list or enable

name-caching

no Negate a command or set its defaults

ntp Configure NTP

priority-group Assign a priority group to an interface

random-detect Enable Weighted Random Early Detection (WRED) on an

Interface

rate-limit Rate Limit

service-policy Configure QoS Service Policy

shutdown Shutdown the selected interface

snapshot Configure snapshot support on the interface

snmp Modify SNMP interface parameters

speed Configure speed operation.

standby HSRP interface configuration commands

timeout Define timeout values for this interface

traffic-shape Enable Traffic Shaping on an Interface or

Sub-Interface

transmit-interface Assign a transmit interface to a receive-only

interface

trunk-group Configure interface to be in a trunk group

tx-ring-limit Configure PA level transmit ring limit

what can i do?

can u help please

thanks.

Re: router 2620

You need IP Plus IOS.

Regards,

Milan

Community Member

Re: router 2620

oh thanks,

so i need ip plus ios,

if i get this ios, is it possible to seperate to lan by my subinterface on my 26.20, or the subinterfaces are use only in case of vlans.

and in the case of router on the stick, when we intercconect our vlans, is it possible to create access list to allow some vlan to see other vlan and vise versa?

thank you so much.

Community Member

Re: router 2620

hi

i am very surprised! because when i create a sub interface on my serial, and put on it an ip adress, it works, but if i do it whith my e0 it does'nt work.

Configuring IP routing on a LAN subinterface is only allowed if that

subinterface is already configured as part of an IEEE 802.10, IEEE 802.1Q, or IS

L vLAN.

why?

thanks.

Re: router 2620

You need to configure

interface FastEthernet0/0.20

encapsulation dot1Q 20

first and then you are able to add the IP address to the subinterface.

The reason is following:

If you want to assign subinterfaces to different VLANs and route between them it is necessary to separate VLAN traffic (i.e. to configure 802.1q trunk, e.g.).

You can "route" between VLANs (using E0 secondary IP address, e.g., you don't need subinterfaces then) but the traffic of particular VLANs is not separated, it's shared all over the Ethernet LAN.

But configuring true routing requires VLAN traffic separation on your Ethernet.

Regards,

Milan

Community Member

Re: router 2620

sorry tu bother you, but when a do a ? on my subinterface, there is no encapsulation command, and this is the output:

cisco(config-subif)#?

Interface configuration commands:

arp Set arp type (arpa, probe, snap) or timeout

backup Modify backup parameters

bandwidth Set bandwidth informational parameter

bridge-group Transparent bridging interface parameters

cdp CDP interface subcommands

default Set a command to its defaults

delay Specify interface throughput delay

description Interface specific description

exit Exit from interface configuration mode

ip Interface Internet Protocol config commands

llc2 LLC2 Interface Subcommands

mtu Set the interface Maximum Transmission Unit (MTU)

netbios Use a defined NETBIOS access list or enable name-caching

no Negate a command or set its defaults

ntp Configure NTP

rate-limit Rate Limit

service-policy Configure QoS Service Policy

shutdown Shutdown the selected interface

snapshot Configure snapshot support on the interface

standby HSRP interface configuration commands

timeout Define timeout values for this interface

thank you verry much.

Re: router 2620

This is what you should see:

router(config-subif)#?

Interface configuration commands:

arp Set arp type (arpa, probe, snap) or timeout

backup Modify backup parameters

bandwidth Set bandwidth informational parameter

bridge-group Transparent bridging interface parameters

carrier-delay Specify delay for interface transitions

cdp CDP interface subcommands

default Set a command to its defaults

delay Specify interface throughput delay

description Interface specific description

dspu Down Stream PU

encapsulation Set encapsulation type for an interface

exit Exit from interface configuration mode

fras DLC Switch Interface Command

ip Interface Internet Protocol config commands

llc2 LLC2 Interface Subcommands

mtu Set the interface Maximum Transmission Unit (MTU)

netbios Use a defined NETBIOS access list or enable name-caching

no Negate a command or set its defaults

ntp Configure NTP

rate-limit Rate Limit

shutdown Shutdown the selected interface

sna SNA pu configuration

snapshot Configure snapshot support on the interface

standby Hot standby interface subcommands

timeout Define timeout values for this interface

traffic-shape Enable Traffic Shaping on an Interface or Sub-Interface

Are you sure your IOS is IP Plus?

I'm running c2600-is-mz.120-4.T.bin and I think the "is" in the file name means IP Plus.

Use CCO Software Advisor

(http://www.cisco.com/cgi-bin/Support/CompNav/Index.pl) to find the correct IOS. Try to find "IEEE 802.1Q VLAN Support" IOS feature.

Regards,

Milan

Community Member

Re: router 2620

yes i think that the probléme is in my ios!

i have another pb

when i just restarted my router, it does not give me the control

and it displays:

%LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up

%LINK-3-UPDOWN: Interface Serial0/0, changed state to down

%SYS-5-CONFIG_I: Configured from memory by console

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state t

o up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to down

%SYS-5-RESTART: System restarted --

Cisco Internetwork Operating System Software

IOS (tm) C2600 Software (C2600-I-M), Version 12.2(7b), RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2002 by cisco Systems, Inc.

Compiled Tue 05-Mar-02 04:26 by pwade

%SNMP-5-COLDSTART: SNMP agent on host cisco is undergoing a cold start

and when i press enter nothing happens

do you know why and what can i do?

thank you verry much.

Community Member

Re: router 2620

there is some news.

now i can't manage my router via console, but i can do it whit vty.

really i don't anderstand.

and i am renning c2600-i-mz.122-7b.bin.

Community Member

Re: router 2620

You need to have a IOS IP Plus or better to assign IP addresses to sub-interfaces, you also need to set the encapsulation type first as well.

interface Ethernet0/1

description Dot1q Trunk

bandwidth 10000

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache

no ip split-horizon

no ip mroute-cache

ntp disable

!

interface Ethernet0/1.1

description Subif 1

bandwidth 10000

encapsulation dot1Q 8

ip address 1.1.1.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

no ip split-horizon

no ip mroute-cache

traffic-shape rate 10000000 250000 250000 1000

I hope that helps.

Stephen

445
Views
0
Helpful
11
Replies
CreatePlease to create content