Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Router 2621 Route between LAN segments

I have a new cisco 2600 router. It is used to segment beetween 2 internal lan nets - 10.10.0.0 & 10.80.0.0.

I have the interfaces set with correcct IP. THey are both up.

From the router I can ping all stations on either network fine.

I can not ping from a workstation on the 10.10. network to the 10.80 network. It is not crossing the router. IP and IPX routing is set on both interfaces.

I thought that the routing was automatic.

What could the problem be?????

Thank you

7 REPLIES
New Member

Re: Router 2621 Route between LAN segments

Hi.

Do you have the defaut gateway set on the workstations?

Hope it helps.

NM

New Member

Re: Router 2621 Route between LAN segments

Thank you. Yes I have a PC on the 10.80 network with a default gateway of the 10.80.1.1 interface on the router.

When I try to ping the 10.10.1.1 int on the router from the pc on the 10.80. segment I get the following message "request timed out" , when I try to ping another PC on the 10.10.0.0 network (beyond the router) I get the following message "destinaation host unreachable"

I do not have default gateways set on the router itself. I read not to do this if IP routing is enabled. How can I verify that it is??? I did the IP routing command in priv exec.mode.

ANy other suggestions.

Thank you

New Member

Re: Router 2621 Route between LAN segments

Hi.

I assume you are using a /16 mask. Am I right?

Do you have ACLs?

Can you post the router configuration?

If not, please post at least the output from "show ip route" and the interfaces configuration.

Try to do an extended ping from the router to a host on network 10.10.0.0 using as source IP 10.80.1.1. Do the same to a host on net 10.80.0.0 but with a using source IP 10.10.1.1.

Rgds.

NM

New Member

Re: Router 2621 Route between LAN segments

It still is not working . below is my config. I removed the passwords.

There are no access lists present.

On the bottom of the config I pasted the results of an SHOW IP ROUTE command.

I ultimately want to have IPX and IP route between the segments.

CONFIG:

!

version 12.1

service config

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname 2600

!

enable secret

enable password

!

!

ip subnet-zero

!

ipx routing 0008.a3d0.52e0

!

!

interface FastEthernet0/0

ip address 10.80.1.1 255.255.0.0

no ip mroute-cache

speed auto

half-duplex

no cdp enable

no mop enabled

!

interface FastEthernet0/1

ip address 10.10.1.2 255.255.0.0

duplex auto

speed auto

no cdp enable

!

ip classless

no ip http server

!

!

snmp-server engineID local 0000000902000008A3D052E0

snmp-server community public RO

banner motd _2621 - Unauthorized access is prohibited_

!

line con 0

exec-timeout 0 0

transport input none

line aux 0

line vty 0 4

password

login

!

no scheduler allocate

end

Here is what I get when I type SHOW IP ROUTE

Cisco2600#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/16 is subnetted, 1 subnets

C 10.80.0.0 is directly connected, FastEthernet0/0

Purple

Re: Router 2621 Route between LAN segments

I don't see it or missed it where you have any routing protocol configured ? What are you running, ospf, rip ,eigrp etc.... this needs to be configured on the router in order to rout packets . Assign a routing protocol then do your network statements .

New Member

Re: Router 2621 Route between LAN segments

Thank you. I can now ping on both sides. For IPX do I need to assign an IPX segment number to each interface for it to route properly?

Thank you

New Member

Re: Router 2621 Route between LAN segments

Hi.

You dont't need to enable any routing protocol in order to route IP packets between two directly connected networks... Can you post the output from the following commands : "show interface" and/or "show ip interface brief"? I think the interface connected to the 10.10.0.0 network shouldn't be up because network 10.10.0.0 isn't on the routing table!

Are you sure that the gateway set on the hosts on network 10.10.0.0 is 10.10.1.2?

Regarding the IPX question, the answer is yes.

Rgds.

NM

219
Views
0
Helpful
7
Replies