Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Router 3640 Errors

Greeting for all

I recently got these messages form the router

%SYS-2-CFORKMEM: Process creation of Exec failed (no memory).

-Process= "TTY Background", ipl= 0, pid= 19

-Traceback= 60335248 6032959C 6027CD74 6027D5A0 602909AC 60290E70 60291770 60291

930 602AA480 6030AC64 6030AC50

%SYS-2-MALLOCFAIL: Memory allocation of 1411 bytes failed from 0x607AB9FC, pool

Processor, alignment 0

-Process= "Modem Autoconfigure", ipl= 0, pid= 53

-Traceback= 60315448 603170A0 607ABA04 607AB730 6030AC64 6030AC50

%ISDN-6-DISCONNECT: Interface Serial1/1:4 disconnected from unknown , call last

ed 41 seconds

%SYS-2-MALLOCFAIL: Memory allocation of 19960 bytes failed from 0x6031202C, pool

Processor, alignment 4

-Process= "MICA Modem Events", ipl= 0, pid= 26

-Traceback= 60315448 60316CC8 60312034 60312928 6018B404 6030AC64 6030AC50

I currently have:

System image file is "flash:c3640-io3-mz.120-7.T.bin"

cisco 3640 (R4700) processor (revision 0x00) with 24576K/8192K bytes of memory.

Processor board ID 18729883

R4700 CPU at 100Mhz, Implementation 33, Rev 1.0

Channelized E1, Version 1.0.

MICA-6DM Firmware: CP ver 2940 - 7/24/2002, SP ver 2940 - 7/24/2002.

Bridging software.

X.25 software, Version 3.0.0.

Primary Rate ISDN software, Version 1.1.

Basic Rate ISDN software, Version 1.1.

1 Ethernet/IEEE 802.3 interface(s)

1 FastEthernet/IEEE 802.3 interface(s)

63 Serial network interface(s)

1 ISDN Basic Rate interface(s)

60 terminal line(s)

2 Channelized E1/PRI port(s)

DRAM configuration is 64 bits wide with parity disabled.

125K bytes of non-volatile configuration memory.

8192K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

I was use mica-modem-pw.2.7.3.0 for modems , I thought by upgrade to mica-modem-pw.2.9.4.0 will solve the problem but the problem still exist

any Ideas ?

Thank You

4 REPLIES
Silver

Re: Router 3640 Errors

Your router is suffering memory allocation failures. This means:

- The router has used all available memory (temporarily or permanently), or

- The memory has fragmented into such small pieces that the router cannot find a usable available block. This can happen with the processor memory (your case),used by IOS or with the packet memory (used by incoming and outgoing packets).

For pssible causes and troubleshooting procedures please refer to:

http://www.cisco.com/warp/public/63/mallocfail.shtml

Also, as your router is a 3600 series, please do a "sh memory summary" command and check if your processor memory is exhausted.

You can configure the memory-size for I/O process by means of the "memory-size iomem" command. Reducing I/O memory-size you're increasing your process memory-size.

Please, for reallocating DRAM memory in 3600 series, take a look at:

http://www.cisco.com/en/US/products/sw/iosswrel/ps1826/products_configuration_guide_chapter09186a00800d9b60.html#xtocid13

HTH.

Re: Router 3640 Errors

You are experiencing a router memory problem. This indicates usually a software problem. My advice is to upgrade to the latest IOS version available on CCO.

Here is a link with mode details on the issue:

http://www.cisco.com/en/US/customer/products/sw/iosswrel/ps1831/products_tech_note09186a00800a6f3a.shtml

Cheers

Silver

Re: Router 3640 Errors

Be careful about upgrading the IOS without checking the memory requirement for the version and feature set you are using. Note that you have 32Mb Dram on the router and that might not be sufficient in some situations. Consider upgrading the memory also, or do a sh mem or sh proc memory to find out what processes are taking up the memory.

New Member

Re: Router 3640 Errors

Thanks for all

There is development errors. the router suddenly crash and reboot by it self and delete the system configuration

here is the system configuration:

version 12.0

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname xxx

!

aaa new-model

aaa authentication login default group radius

aaa authentication login console line

aaa authentication login vty line

aaa authentication ppp default local group radius

aaa accounting exec default start-stop group radius

aaa accounting network default start-stop group radius

!

memory-size iomem 25

ip subnet-zero

!

ip audit notify log

ip audit po max-events 100

isdn switch-type basic-net3

isdn voice-call-failure 0

isdn tei-negotiation first-call

!

!

controller E1 1/0

pri-group timeslots 1-31

!

controller E1 1/1

pri-group timeslots 1-31

!

!

interface Ethernet0/0

no ip address

no ip directed-broadcast

shutdown

no cdp enable

!

interface Serial0/0

no ip address

no ip directed-broadcast

encapsulation frame-relay IETF

keepalive 11

!

interface Serial0/0.1 point-to-point

ip address xxx.xxx.xxx.xxx 255.255.255.252

no ip directed-broadcast

no cdp enable

frame-relay interface-dlci 16 IETF

!

interface BRI0/0

shutdown

!

interface FastEthernet1/0

ip address xxx.xxx.xxx.xxx 255.255.255.0

no ip directed-broadcast

duplex auto

speed auto

no cdp enable

!

interface Serial1/0:15

no ip address

no ip directed-broadcast

ip mroute-cache

dialer rotary-group 0

dialer-group 1

isdn switch-type primary-net5

isdn incoming-voice modem

no fair-queue

no cdp enable

!

interface Serial1/1:15

no ip address

no ip directed-broadcast

ip mroute-cache

dialer rotary-group 0

dialer-group 1

isdn switch-type primary-net5

isdn incoming-voice modem

no fair-queue

no cdp enable

!

interface Group-Async1

ip unnumbered FastEthernet1/0

no ip directed-broadcast

encapsulation ppp

ip tcp header-compression passive

async default routing

async mode interactive

peer default ip address pool 1

no cdp enable

ppp authentication pap callin

group-range 65 94

!

interface Group-Async2

ip unnumbered FastEthernet1/0

no ip directed-broadcast

encapsulation ppp

ip tcp header-compression passive

async default routing

async mode interactive

peer default ip address pool 1

no cdp enable

ppp authentication pap callin

group-range 97 126

!

interface Dialer0

ip unnumbered FastEthernet1/0

no ip directed-broadcast

encapsulation ppp

no ip mroute-cache

dialer in-band

dialer-group 1

peer default ip address pool 1

no fair-queue

no cdp enable

ppp authentication pap callin

ppp multilink

!

ip local pool 1 xxx ...

ip classless

ip route 0.0.0.0 0.0.0.0 Serial0/0.1

no ip http server

!

no cdp run

snmp-server engineID xxxx

snmp-server community public RO

radius-server host xxx.xxx.xxx.xxx auth-port 1645 acct-port 1646

radius-server key xxxxx

!

line con 0

exec-timeout 0 0

password xxxx

login authentication console

transport input none

line 65 94

exec-timeout 0 30

autoselect during-login

autoselect ppp

no vacant-message

modem Dialin

modem autoconfigure type mica

autocommand ppp

no history

transport input all

escape-character BREAK

stopbits 1

flowcontrol hardware

line 97 126

autoselect during-login

autoselect ppp

no vacant-message

modem Dialin

modem autoconfigure type mica

autocommand ppp

no history

transport input all

escape-character BREAK

stopbits 1

flowcontrol hardware

line aux 0

line vty 0 4

exec-timeout 0 0

password xxxx

login authentication vty

!

end

226
Views
0
Helpful
4
Replies
CreatePlease login to create content