Cisco Support Community
Community Member


I have a Router mc 3810 and i dont have the boot helper image (mc3810-wboot-mz.bin), how can do to find it???

Please HELP!!!

Router(boot)#sh ver

Cisco Internetwork Operating System Software

IOS (tm) MC3810 Software (MC3810-WBOOT-M), Version 12.0(7r)XK, RELEASE SOFTWARE


Copyright (c) 1986-1999 by cisco Systems, Inc.

Compiled Mon 20-Dec-99 14:05 by cmong

Image text-base: 0x00023000, data-base: 0x00356C8C

ROM: System Bootstrap, Version 12.0(7r)XK, RELEASE SOFTWARE (fc1)

Router uptime is 12 minutes

System returned to ROM by reload

System image file is "bootflash:"

Cisco MC3810-V3 (MPC860P) processor (revision 18.07) with 57344K/8192K bytes of


Processor board ID 26364715

PPC860 PowerQUICC, partnum 0x0005, version X02(0x0002)

Channelized E1, Version 1.0.

MC3810 SCB board (v01.F0)

1 Ethernet/IEEE 802.3 interface(s)

1 Serial network interface(s)

2 Serial(sync/async) network interface(s)

1 Channelized E1/PRI port(s)

256K bytes of non-volatile configuration memory.

8192K bytes of processor board System flash (AMD29F016)

Configuration register is 0x3922


Thank You very vey much

Cisco Employee

Re: Router(boot)#

MC3810 is already booted from boot image as reported by "sh version" So now you need to enter "sh flash" and see if you have a ios image file stored there. If you don't have it, you can get one from following location

Launch the ios upgrade planner.

Now if yo have it already in flash, then you need to change the config register to 0x2102 using following global commands

config-register 0x2102

boot system flash

Community Member

Re: Router(boot)#

thank you very much by your answer

I don´t have a cco password so i can´t download the images.

Router(boot)#sh flash

8192K bytes of processor board System flash (AMD29F016)

Directory of flash:/

2 -rwx 4923200 Mar 01 1993 00:07:25 mc3810-is-mz.120-5.XK1

8128000 bytes total (3203584 bytes free)


thank you very much


Re: Router(boot)#

It seems that you have the IOS in your flash. The problem could just be the configuration register setting. As what Tejal has suggested just change the value of the config register to 0x2102.

CreatePlease to create content