Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Router DHCP Straight Through / Cross Over

Hi All

   I am encountering a very strange issue. I've configured our 1921 router with DHCP. Then I've connected my laptop (to test) using a straight through and cross over to the router, but it doesn't pull an IP. I followed the commands and verified it from several sites. What else could be wrong?

ip dhcp pool DHCPPOOL

network 192.168.1.0 255.255.255.0

dns-server 4.2.2.2

default-router 192.168.1.1

ip dhcp excluded-addrss 192.168.1.1 192.168.1.99

service dhcp

Appreciate any input!

  • Other Network Infrastructure Subjects
1 ACCEPTED SOLUTION

Accepted Solutions
Purple

Router DHCP Straight Through / Cross Over

Hi,

you did a typo in your second ip dhcp excluded-address command by typing a 68 in second octet instead of 168

and by doing so you excluded all the addresses from your /24 scope.

don't forget to rate if helpful.

Regards.

Alain

Don't forget to rate helpful posts.
6 REPLIES
Purple

Router DHCP Straight Through / Cross Over

Hi,

Could you post the running config.

Regards.

Alain

Don't forget to rate helpful posts.
New Member

Router DHCP Straight Through / Cross Over

Current configuration : 3860 bytes
!

version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
no ipv6 cef
!
!
!
ip dhcp excluded-address 192.168.1.1 192.168.1.99
ip dhcp excluded-address 192.68.1.150 192.168.1.254
!
ip dhcp pool DHCP-POOL
network 192.168.1.0 255.255.255.0
dns-server 66.80.131.5 66.80.130.23 64.7.11.2
lease 7
!
!
no ip domain lookup
ip cef
multilink bundle-name authenticated
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-1406017923
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1406017923
revocation-check none
rsakeypair TP-self-signed-1406017923
!
!
crypto pki certificate chain TP-self-signed-1406017923
certificate self-signed 01
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 0505003

        quit
license udi pid CISCO1921/K9 sn XXXXXXXXXXXXX
!

username grant privilege 15 secret 5 $1$LgZ4$UXZanBF9.F45dXzBT1Fqy.
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/0/0
ip address x.x.x.82 255.255.255.240
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
!
ip nat inside source list 1 interface GigabitEthernet0/0/0 overload
ip nat inside source static tcp 192.168.1.18 3389 x.x.x.84 3389 extendable
ip nat inside source static tcp 192.168.1.21 3389 x.x.x.85 3389 extendable
ip nat inside source static tcp 192.168.1.24 3389 x.x.x.86 3389 extendable
ip nat inside source static tcp 192.168.1.45 3389 x.x.x.87 3389 extendable
ip route 0.0.0.0 0.0.0.0 x.x.x.81
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
!
!
control-plane
!
!
!
line con 0
login local
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
login local
transport input all
!
scheduler allocate 20000 1000
!
end

Router#

Bronze

Router DHCP Straight Through / Cross Over

When you connect the active and powered on host to the router, does the router interface become active (Up/Up)?

Is the host setup to request a DHCP address?

Frank

New Member

Router DHCP Straight Through / Cross Over

Yes the interface becomes up and up and yes my laptop is set to recieve DHCP.

Strange huh?!

Purple

Router DHCP Straight Through / Cross Over

Hi,

you did a typo in your second ip dhcp excluded-address command by typing a 68 in second octet instead of 168

and by doing so you excluded all the addresses from your /24 scope.

don't forget to rate if helpful.

Regards.

Alain

Don't forget to rate helpful posts.
New Member

Router DHCP Straight Through / Cross Over

Oh man how embarrassing.

Thanks.

523
Views
0
Helpful
6
Replies
This widget could not be displayed.