Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k

Router EIGRP updates question

Router A

interface eth 0

ip address 172.30.0.1 255.255.255.128

router eigrp 4444

network 172.30.1.0

Router B

interface eth0

ip address 172.30.2.1 255.255.255.128

router eigrp 4444

network 172.30.1.0

MAIN ROUTER

interface eth0

ip address 172.30.1.1 255.255.255.0

router eigrp 4444

network 172.30.0.0

Router A users should reach ONLY Main Router users.

Router B users should reach ONLY Main Router users.

based on the EIGRP network in Router A & B, they can reach ONLY Main Router users, where as Main Router can reach both.

am i right? if not please correct me.

2 REPLIES
Bronze

Re: Router EIGRP updates question

Hi,

In each EIGRP router you need to advertise the subnets at the router not the neighbors routers.

Router A

interface eth 0

ip address 172.30.0.1 255.255.255.128

router eigrp 4444

network 172.30.0.0

and disable the auto summarization.

Please read this document

http://www.cisco.com/en/US/products/sw/iosswrel/ps1831/products_command_reference_chapter09186a00800ca699.html#wp1018393

And please note, that these are class b addresses, the default will summarize 172.30.0.0 unless you add the network mask after the subnet.

Please rate if it does!

Abd Alqader

Re: Router EIGRP updates question

Hello,

in addition to Abd's post, keep in mind that with EIGRP, you are not actually advertising networks, you are advertising interfaces. So, when you say:

network 172.30.0.0

you tell the EIGRP process to let all interfaces that have an IP address within the 172.30.0.0/16 range participate in EIGRP. In order to avoid confusion, you could advertise just the exact interface addresses as following:

Router A

interface eth 0

ip address 172.30.0.1 255.255.255.128

router eigrp 4444

network 172.30.0.1 0.0.0.0

Router B

interface eth0

ip address 172.30.2.1 255.255.255.128

router eigrp 4444

network 172.30.2.1 0.0.0.0

MAIN ROUTER

interface eth0

ip address 172.30.1.1 255.255.255.0

router eigrp 4444

network 172.30.1.1 0.0.0.0

If you want both Router A and Router B to reach only the main router and not each other, you could configure a distribute list for the interfaces on Router A and Router B as following:

Router A

interface Serial0

description connection to Main

!

router eigrp 444

distribute-list 1 out Serial0

!

access-list 1 deny 172.30.2.1 0.0.0.0

access-list 1 permit any

!

Router B

interface Serial0

description connection to Main

!

router eigrp 444

distribute-list 1 out Serial0

!

access-list 1 deny 172.30.0.1 0.0.0.0

access-list 1 permit any

!

Does that make sense ?

Regards,

GNT

287
Views
0
Helpful
2
Replies
CreatePlease to create content