cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
319
Views
0
Helpful
1
Replies

router on a stick

jcajuste
Level 1
Level 1

i was tasked to implement internet access in a hotel

due to budget constraints this can only be done with a 1721 router and 6 2900 series xl switches.

1) the router should provide ip address for all host

2) host should not be able to see each other

i am posting my config for the router and switches.

problem number

clients can not obtain ip address therfore can not surf the web

can anyone tell me what i am doing wrong?

thank you

router

ip dhcp pool 2

network 10.10.10.0 255.255.255.224

domain-name

dns-server 0.0.0.0 0.0.0.0

default-router 10.10.10.1

lease 0 0 1

!

ip dhcp pool 3

network 10.10.11.0 255.255.255.0

domain-namet

dns-server 0.0.0.0 0.0.0.0

default-router 10.10.11.1

lease 0 0 1

interface FastEthernet0.1

encapsulation dot1Q 1 native

ip address 10.10.9.1 255.255.255.224

ip nat inside

!

interface FastEthernet0.2

encapsulation dot1Q 2

ip address 10.10.10.1 255.255.255.224

ip nat inside

interface Serial0

no ip address

ip nat outside

encapsulation frame-relay IETF

no keepalive

service-module t1 timeslots 9-24

!

interface Serial0.1 point-to-point

ip address 0.0.0.0 0.0.0.0 secondary

ip address 0.0.0.0 0.0.0.0

ip access-group 101 in

ip nat outside

frame-relay interface-dlci 16

!

no ip http server

!

access-list 100 permit ip 10.10.0.0 0.0.255.255 any

switch one

interface FastEthernet0/19

switchport access vlan 6

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/20

switchport access vlan 5

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/21

switchport access vlan 4

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/22

switchport access vlan 3

switchport trunk encapsulation dot1q

switchport mode trunk

switch 2

interface FastEthernet0/1

port protected

switchport access vlan 2

spanning-tree portfast

!

interface FastEthernet0/2

port protected

switchport access vlan 2

spanning-tree portfast

!

interface FastEthernet0/3

port protected

switchport access vlan 3

spanning-tree portfast

!

interface FastEthernet0/4

port protected

switchport access vlan 2

spanning-tree portfast

!interface FastEthernet0/24

switchport trunk encapsulation dot1q

switchport mode trunk

1 Reply 1

jasosmith
Level 1
Level 1

In my experience setting up a router to act as a DHCP server I have always used the "ip dhcp excluded-address" command. I have included a simple config I did to serve up addresses to my lab. I believe this should take care of your problem.

--------

ip dhcp excluded-address xx.xx.xx.65 xx.xx.xx.114

!

ip dhcp pool PRODRAIL

network xx.xx.xx.64 255.255.255.192

default-router xx.xx.xx.65

domain-name mylab.com.

dns-server xx.xx.xx.xx

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: