Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Router to Router callback

I'm working on trying to get callback to work between two 2611 routers over an asynchronous line. Everything works fine until the router acting as a the callback server makes the attempt to callback. When it does, it times out waiting for the modem to send the connect string. I've tried several things which haven't seemed to do anything. Here is the config file for the callback server, which works fine when not attempting callback. Any help would be appreciated.

no parser cache

service timestamps debug uptime

service timestamps log uptime

service password-encryption

service compress-config

!

hostname distnet

!

enable secret ******************

enable password ******************

!

username dialin callback-dialstring 24,61 callback-rotary 77 password ******************

ip cef

!

!

chat-script rstcnet "" "at&fs0=1s3=13&c1&d3&k3l=0m=0" "OK"

chat-script callback ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \T" TIMEOUT 60 CONNECT \c

chat-script backup "" "atdt \T" TIMEOUT 60 "CONNECT" \c

call rsvp-sync

!

!

!

!

interface Serial0/0

bandwidth 1544

no ip address

encapsulation frame-relay

load-interval 60

no fair-queue

frame-relay lmi-type cisco

!

interface Serial0/0.1 point-to-point

description Eau Claire to Plano

ip address 192.168.1.5 255.255.255.252

frame-relay interface-dlci 700 IETF

!

interface Async65

ip address 192.168.2.1 255.255.255.0

encapsulation ppp

dialer in-band

dialer callback-secure

dialer enable-timeout 10

dialer map ip 192.168.2.2 name derek class cback broadcast 24,61

dialer hold-queue 20 timeout 20

dialer-group 1

async default routing

async mode dedicated

ppp callback accept

ppp authentication chap

ppp chap password ******************

!

router eigrp 1

network 192.168.1.4 0.0.0.3

network 192.168.2.0 0.0.0.255

no auto-summary

no eigrp log-neighbor-changes

!

!

map-class dialer cback

dialer callback-server username

access-list 101 deny eigrp any any

access-list 101 permit ip any any

dialer-list 1 protocol ip list 101

!

!

!

!

line con 0

exec-timeout 0 0

password ******************

stopbits 1

line aux 0

exec-timeout 0 0

script dialer backup

script reset rstcnet

script callback callback

login local

modem InOut

modem autoconfigure discovery

rotary 77

transport input all

autohangup

stopbits 1

speed 38400

flowcontrol hardware

line vty 0 4

exec-timeout 0 0

password ******************

login

line vty 5 15

password ******************

login

!

end

Thanks,

George

5 REPLIES
Cisco Employee

Re: Router to Router callback

Duplicate question..If the modems are faling to CONNECT during callback, do you even hear the modem trainup sound? Anything unusual during trainup? have you tried replacing the modems?

We need to see the debug

debug chat

debug modem

debug ppp nego

debug aaa authorization

debug callbcak

debug ppp cbcp

New Member

Re: Router to Router callback

Here's the debug output from the callback server. To answer your questions: no i do not here any trainup when the router begins its callback and since there's no trainup there's nothing unusual about it, and yes i have tried replacing modems and the same thing happens.

1d21h: TTY65: DSR came up

1d21h: TTY65: no timer type 1 to destroy

1d21h: TTY65: no timer type 0 to destroy

1d21h: tty65: Modem: IDLE->(unknown)

1d21h: %LINK-3-UPDOWN: Interface Async65, changed state to up

1d21h: As65 DDR: Dialer statechange to up

1d21h: As65 DDR: Dialer received incoming call from

1d21h: As65 PPP: Treating connection as a callin

1d21h: As65 PPP: Phase is ESTABLISHING, Passive Open [0 sess, 0 load]

1d21h: As65 LCP: State is Listen

1d21h: As65 LCP: I CONFREQ [Listen] id 226 len 28

1d21h: As65 LCP: ACCM 0x000A0000 (0x0206000A0000)

1d21h: As65 LCP: AuthProto CHAP (0x0305C22305)

1d21h: As65 LCP: MagicNumber 0x32FFB57F (0x050632FFB57F)

1d21h: As65 LCP: PFC (0x0702)

1d21h: As65 LCP: ACFC (0x0802)

1d21h: As65 LCP: Callback 0 (0x0D0300)

1d21h: As65 LCP: O CONFREQ [Listen] id 102 len 25

1d21h: As65 LCP: ACCM 0x000A0000 (0x0206000A0000)

1d21h: As65 LCP: AuthProto CHAP (0x0305C22305)

1d21h: As65 LCP: MagicNumber 0x1331B782 (0x05061331B782)

1d21h: As65 LCP: PFC (0x0702)

1d21h: As65 LCP: ACFC (0x0802)

1d21h: As65 LCP: O CONFACK [Listen] id 226 len 28

1d21h: As65 LCP: ACCM 0x000A0000 (0x0206000A0000)

1d21h: As65 LCP: AuthProto CHAP (0x0305C22305)

1d21h: As65 LCP: MagicNumber 0x32FFB57F (0x050632FFB57F)

1d21h: As65 LCP: PFC (0x0702)

1d21h: As65 LCP: ACFC (0x0802)

1d21h: As65 LCP: Callback 0 (0x0D0300)

1d21h: As65 LCP: I CONFACK [ACKsent] id 102 len 25

1d21h: As65 LCP: ACCM 0x000A0000 (0x0206000A0000)

1d21h: As65 LCP: AuthProto CHAP (0x0305C22305)

1d21h: As65 LCP: MagicNumber 0x1331B782 (0x05061331B782)

1d21h: As65 LCP: PFC (0x0702)

1d21h: As65 LCP: ACFC (0x0802)

1d21h: As65 LCP: State is Open

1d21h: As65 PPP: Phase is AUTHENTICATING, by both [0 sess, 0 load]

1d21h: As65 CHAP: O CHALLENGE id 193 len 28 from "distnet"

1d21h: As65 CHAP: I CHALLENGE id 38 len 26 from "derek"

1d21h: As65 CHAP: Waiting for peer to authenticate first

1d21h: As65 CHAP: I RESPONSE id 193 len 26 from "derek"

1d21h: As65 CHAP: O SUCCESS id 193 len 4

1d21h: As65 CHAP: Processing saved Challenge, id 38

1d21h: As65 CHAP: O RESPONSE id 38 len 28 from "distnet"

1d21h: As65 CHAP: I SUCCESS id 38 len 4

1d21h: As65 DDR: PPP callback Callback server starting to derek 24,61

1d21h: As65 DDR: disconnecting call

1d21h: TTY65: Async Int reset: Dropping DTR

1d21h: TTY65: Set DTR to 0

1d21h: TTY65: DSR was dropped

1d21h: tty65: Modem: READY->(unknown)

1d21h: TTY65: dropping DTR, hanging up

1d21h: TTY65: Set DTR to 0

1d21h: tty65: Modem: HANGUP->(unknown)

1d21h: TTY65: cleanup pending. Delaying DTR

1d21h: TTY65: cleanup pending. Delaying DTR

1d21h: %LINK-5-CHANGED: Interface Async65, changed state to reset

1d21h: As65 PPP: Phase is TERMINATING [0 sess, 0 load]

1d21h: As65 LCP: State is Closed

1d21h: As65 PPP: Phase is DOWN [0 sess, 0 load]

1d21h: TTY65: cleanup pending. Delaying DTR

1d21h: TTY65: cleanup pending. Delaying DTR

1d21h: TTY65: cleanup pending. Delaying DTR

1d21h: TTY65: cleanup pending. Delaying DTR

1d21h: TTY65: cleanup pending. Delaying DTR

1d21h: TTY65: cleanup pending. Delaying DTR

1d21h: TTY65: no timer type 0 to destroy

1d21h: TTY65: no timer type 1 to destroy

1d21h: TTY65: no timer type 3 to destroy

1d21h: TTY65: no timer type 4 to destroy

1d21h: TTY65: no timer type 2 to destroy

1d21h: Async65: allowing modem_process to continue hangup

1d21h: TTY65: restoring DTR

1d21h: TTY65: Set DTR to 1

1d21h: TTY65: autoconfigure probe started

1d21h: TTY65: Modem command: --AT&F&C1&D2S0=1H0--

1d21h: %LINK-3-UPDOWN: Interface Async65, changed state to down

1d21h: As65 LCP: State is Closed

1d21h: TTY65: Modem configuration succeeded

1d21h: TTY65: Detected modem speed 38400

1d21h: TTY65: Done with modem configuration

1d21h: As65 DDR: re-enable timeout

1d21h: DDR: callback triggered by dialer_timers

1d21h: As65 DDR: beginning callback to derek 24,61

1d21h: As65 DDR: Attempting to dial 24,61

1d21h: CHAT65: Attempting async line dialer script

1d21h: CHAT65: Dialing using Modem script: backup & System script: none

1d21h: CHAT65: process started

1d21h: CHAT65: Asserting DTR

1d21h: TTY65: Set DTR to 1

1d21h: CHAT65: Chat script backup started

1d21h: CHAT65: Sending string: atdt \T<24,61>

1d21h: CHAT65: Expecting string: CONNECT

1d21h: DDR: Hold queue purge timeout, 0 packets unqueued and discarded

1d21h: CHAT65: Timeout expecting: CONNECT

1d21h: CHAT65: Chat script backup finished, status = Connection timed out; remote host not responding

1d21h: TTY65: Line reset by "Async dialer"

1d21h: As65 DDR: disconnecting call

1d21h: TTY65: Modem: (unknown)->HANGUP

1d21h: TTY65: no timer type 0 to destroy

1d21h: TTY65: no timer type 1 to destroy

1d21h: TTY65: no timer type 3 to destroy

1d21h: TTY65: no timer type 4 to destroy

1d21h: TTY65: no timer type 2 to destroy

1d21h: TTY65: dropping DTR, hanging up

1d21h: TTY65: Set DTR to 0

1d21h: tty65: Modem: HANGUP->IDLE

1d21h: TTY65: restoring DTR

1d21h: TTY65: Set DTR to 1

1d21h: TTY65: autoconfigure probe started

1d21h: TTY65: Modem command: --AT&F&C1&D2S0=1H0--

1d21h: TTY65: Modem configuration succeeded

1d21h: TTY65: Detected modem speed 38400

1d21h: TTY65: Done with modem configuration

1d21h: As65 DDR: re-enable timeout

1d21h: DDR: Freeing callback to derek 24,61

Thanks,

George

Cisco Employee

Re: Router to Router callback

you can see the when the modem dial 24,61 two modem can't connect (OR can't exchange CONNECT). So the question is the number format or the number itself is correct?

I would reverse telnet to the modem on a router and issue

ATDT24,61

and see i can get connect at all. Have you tried that?

What is the results?

You have comma here means for 2 sec pause, So is that enough for call process after number 24 dialed?

New Member

Re: Router to Router callback

I have tried reverse telnetting to the modem and have successfully dialed and connected to the 24,61 number. I have even successfully dialed out without using the comma from a reverse telnet session. This is why I'm confused. It looks like it should work, but it doesn't.

Thanks,

George

Cisco Employee

Re: Router to Router callback

Do you here any abnormal or different modem trainup sound during callback wrt dialin?

Does modem trainup stops before 60 secs after modem dials 24,61 number?

There should be something different wrt modem during callin and callback.

Make sure that if you have USR modems, dip switches on the back of the modems should be 3 and 8 are down and rest should be up.

If no Luck, open a tac case at www.cisco.com/tac

131
Views
0
Helpful
5
Replies
CreatePlease to create content