Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Router to switch port config

This may seem pretty redimentery but I just spent the last hour looking at google results on my search. I am hooking a Cisco 3560 switch to a 2811 rtr. Here is my current configs from the switch & RtR. Should I have any special setting on switch or router? It just seems like I should have more config paremeters on the switch

Switch Port Config

interface FastEthernet0/48

description Connected to 2811 RTR

Rtr Port Config

interface FastEthernet0/0

description connected to 10.1.34.0

ip address 10.1.34.2 255.255.255.0

ip helper-address 10.1.35.52

no ip redirects

ip nat inside

no ip virtual-reassembly

duplex auto

speed auto

3 REPLIES

Re: Router to switch port config

Your config looks pretty straight forward. By default all ports of a switch falls on vlan 1. So your port fa0/48 is also on vlan 1. Now i assume all the rest of the ports on the switch are also on vlan 1. If then the clients falling in subnet 10.1.34.0 subnet should be able to ping 10.1.34.2 (router).

Are you able to do this ?

I see you have helper-address, for getting DHCP for clients. Are you getting an ip address leased on each PC ?

New Member

Re: Router to switch port config

Yes All the rest of the ports are on vlan1. All clients do get and ip address from the 10.1.34.0 subnet. If the DCHP server is busy the do go across the 10.1.35.0 subnet and get an ip sitting on the DHCP server there.

So I am assuming all looks good and there is nothing else to configure on the switchport fa0/48 which connects to the router?

VIP Purple

Re: Router to switch port config

Hello,

I would also set the speed and duplex settings to full/100 fixed on both sides, that is good practice and might improve throughput...

Switch Port Config

interface FastEthernet0/48

description Connected to 2811 RTR

--> speed 100

--> duplex full

Rtr Port Config

interface FastEthernet0/0

description connected to 10.1.34.0

ip address 10.1.34.2 255.255.255.0

ip helper-address 10.1.35.52

no ip redirects

ip nat inside

no ip virtual-reassembly

--> duplex full

--> speed 100

Regards,

GP

510
Views
3
Helpful
3
Replies
CreatePlease login to create content